summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-12-17 01:42:46 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-12-17 01:42:46 +0000
commit40c74c3d5d71dd3438234965943ad6d34cd53e1e (patch)
tree9a9ca3df978229218510ab33e907ce8bb98a0fe9 /app-laptop
parentCleanup qemu mask (diff)
downloadgentoo-2-40c74c3d5d71dd3438234965943ad6d34cd53e1e.tar.gz
gentoo-2-40c74c3d5d71dd3438234965943ad6d34cd53e1e.tar.bz2
gentoo-2-40c74c3d5d71dd3438234965943ad6d34cd53e1e.zip
Marked ppc stable. Added x86 compile fix and re-added ~x86. Replaced autocon/automake with eautoconf.
(Portage version: 2.1.2_rc3-r5)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog7
-rw-r--r--app-laptop/pbbuttonsd/files/x86-fix.patch29
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild10
3 files changed, 40 insertions, 6 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 881925cc3b3f..0c725c9dd4e6 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.56 2006/10/03 02:32:04 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.57 2006/12/17 01:42:46 josejx Exp $
+
+ 17 Dec 2006; Joseph Jezak <josejx@gentoo.org> +files/x86-fix.patch,
+ pbbuttonsd-0.7.9.ebuild:
+ Marked ppc stable. Added x86 compile fix and re-added ~x86. Replaced
+ autoconf/automake with eautoconf.
03 Oct 2006; Joseph Jezak <josejx@gentoo.org> -pbbuttonsd-0.7.5.ebuild,
-pbbuttonsd-0.7.6.ebuild, pbbuttonsd-0.7.9.ebuild:
diff --git a/app-laptop/pbbuttonsd/files/x86-fix.patch b/app-laptop/pbbuttonsd/files/x86-fix.patch
new file mode 100644
index 000000000000..754aba50d281
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/x86-fix.patch
@@ -0,0 +1,29 @@
+--- class_backlight.c 2006-10-01 04:06:51.000000000 -0400
++++ /home/jjezak/pbbuttonsd-0.7.9/src/class_backlight.c 2006-10-03 22:04:34.000000000 -0400
+@@ -46,8 +46,9 @@
+ struct class_backlight *base = &modbase_backlight;
+
+ if (!base->driver) base->driver = driver_backlight_sysfs_init (taglist);
++#ifdef WITH_MODULE_PMAC
+ if (!base->driver) base->driver = driver_backlight_pmu_init (taglist);
+-
++#endif
+ if (base->driver)
+ print_msg (PBB_INFO, _("Initialized: %s\n"), _(base->driver->name));
+ else
+--- driver_backlight_pmu.c 2006-10-01 04:04:25.000000000 -0400
++++ /home/jjezak/pbbuttonsd-0.7.9/src/driver_backlight_pmu.c 2006-10-03 22:04:34.000000000 -0400
+@@ -15,6 +15,8 @@
+ # include <config.h>
+ #endif
+
++#ifdef WITH_MODULE_PMAC
++
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <fcntl.h>
+@@ -123,3 +125,4 @@
+ }
+
+
++#endif
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild
index 1ba9d0b4d53d..67bbfe2469a7 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild,v 1.2 2006/10/03 02:32:04 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild,v 1.3 2006/12/17 01:42:46 josejx Exp $
-inherit eutils flag-o-matic
+inherit autotools flag-o-matic
DESCRIPTION="Handles power management and special keys on laptops."
HOMEPAGE="http://pbbuttons.sf.net"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc ~ppc64"
+KEYWORDS="ppc ~ppc64 ~x86"
IUSE="acpi debug alsa oss ibam"
DEPEND=">=sys-apps/baselayout-1.8.6.12-r1
@@ -21,8 +21,8 @@ RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0 )
src_unpack() {
unpack ${A}
cd ${S}
- autoconf
- automake
+ epatch "${FILESDIR}/x86-fix.patch"
+ eautoconf
}
src_compile() {