summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2008-01-11 20:02:02 +0000
committerJoseph Jezak <josejx@gentoo.org>2008-01-11 20:02:02 +0000
commit384632a08a1c0e962eadd27711b0bffba40db49d (patch)
treefda278371e40055e620a2b555f19d197fe168254 /app-laptop
parentRevision bump fixing event device grabbing. (diff)
downloadgentoo-2-384632a08a1c0e962eadd27711b0bffba40db49d.tar.gz
gentoo-2-384632a08a1c0e962eadd27711b0bffba40db49d.tar.bz2
gentoo-2-384632a08a1c0e962eadd27711b0bffba40db49d.zip
Added patch to fix compile when not using alsa.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog8
-rw-r--r--app-laptop/pbbuttonsd/files/lm.patch11
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild5
3 files changed, 20 insertions, 4 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 8b4dda7db6ab..1d7351e593d3 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-laptop/pbbuttonsd
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.72 2007/12/01 16:52:36 josejx Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.73 2008/01/11 20:02:01 josejx Exp $
+
+ 11 Jan 2008; Joseph Jezak <josejx@gentoo.org> +files/lm.patch,
+ pbbuttonsd-0.8.1-r2.ebuild:
+ Added patch to fix compile when not using alsa.
01 Dec 2007; Joseph Jezak <josejx@gentoo.org> files/lz.patch,
pbbuttonsd-0.8.1-r2.ebuild:
diff --git a/app-laptop/pbbuttonsd/files/lm.patch b/app-laptop/pbbuttonsd/files/lm.patch
new file mode 100644
index 000000000000..feb7620ea97b
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/lm.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.in.bak 2008-01-11 14:48:19.000000000 -0500
++++ src/Makefile.in 2008-01-11 14:46:01.000000000 -0500
+@@ -255,7 +255,7 @@
+ module_peep.c module_peep.h debug.h \
+ tcp.c tcp.h
+
+-pbbuttonsd_LDADD = -lpbb $(INTLLIBS) $(PB_OBJECTS) $(PB_LIBS) @PACKAGE_LIBS@
++pbbuttonsd_LDADD = -lpbb -lm $(INTLLIBS) $(PB_OBJECTS) $(PB_LIBS) @PACKAGE_LIBS@
+ pbbuttonsd_LDFLAGS = -L$(top_srcdir)/libpbbipc
+ pbbuttonsd_DEPENDENCIES = $(PB_OBJECTS)
+ @DEBUG_TRUE@AM_CFLAGS1 = -DDEBUG
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild
index 407878ee47fd..281482fb0e26 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild,v 1.3 2007/12/01 16:52:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild,v 1.4 2008/01/11 20:02:01 josejx Exp $
inherit autotools flag-o-matic eutils
@@ -33,6 +33,7 @@ src_unpack() {
fi
### Fix macbook -lz issue
epatch "${FILESDIR}/lz.patch"
+ epatch "${FILESDIR}/lm.patch"
eautoconf
}