summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-08-26 00:30:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-08-26 00:30:56 +0000
commit2080026088f0676b2ea4932d0a4005c82dc3ae15 (patch)
treeb9060a20a1b5ee914499b53b0f7c04315a24f811 /app-laptop
parentAdjust LICENSE to reflect the fact that all kernel code is under the CDDL (diff)
downloadgentoo-2-2080026088f0676b2ea4932d0a4005c82dc3ae15.tar.gz
gentoo-2-2080026088f0676b2ea4932d0a4005c82dc3ae15.tar.bz2
gentoo-2-2080026088f0676b2ea4932d0a4005c82dc3ae15.zip
Remove old
(Portage version: 2.1.11.11/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/prey/ChangeLog6
-rw-r--r--app-laptop/prey/files/prey-0.5.3-gtk-ui.patch31
-rw-r--r--app-laptop/prey/prey-0.5.3.ebuild156
3 files changed, 5 insertions, 188 deletions
diff --git a/app-laptop/prey/ChangeLog b/app-laptop/prey/ChangeLog
index 2b4548383c52..f3cfc924bfe4 100644
--- a/app-laptop/prey/ChangeLog
+++ b/app-laptop/prey/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-laptop/prey
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/prey/ChangeLog,v 1.5 2012/07/19 21:42:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/prey/ChangeLog,v 1.6 2012/08/26 00:30:55 hwoarang Exp $
+
+ 26 Aug 2012; Markos Chandras <hwoarang@gentoo.org>
+ -files/prey-0.5.3-gtk-ui.patch, -prey-0.5.3.ebuild:
+ Remove old
*prey-0.5.4 (19 Jul 2012)
diff --git a/app-laptop/prey/files/prey-0.5.3-gtk-ui.patch b/app-laptop/prey/files/prey-0.5.3-gtk-ui.patch
deleted file mode 100644
index 7b55b83cd3e2..000000000000
--- a/app-laptop/prey/files/prey-0.5.3-gtk-ui.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Index: prey/platform/linux/prey-config.py
-===================================================================
---- prey.orig/platform/linux/prey-config.py
-+++ prey/platform/linux/prey-config.py
-@@ -23,7 +23,7 @@ import urllib
-
- app_name = 'prey-config'
- lang_path = 'lang'
--script_path = os.sys.path[0]
-+script_path = '/usr/share/prey/platform/linux/'
-
- ################################################
- # gettext localization
-@@ -42,7 +42,7 @@ _ = gettext.gettext
- ################################################
-
- PREY_PATH = '/usr/share/prey'
--CONFIG_FILE = PREY_PATH + '/config'
-+CONFIG_FILE = '/etc/config'
- CONTROL_PANEL_URL = 'http://control.preyproject.com'
- CONTROL_PANEL_URL_SSL = 'https://control.preyproject.com'
- GUEST_ACCOUNT_NAME = 'guest_account'
-@@ -293,7 +293,7 @@ class PreyConfigurator(object):
- return True
-
- def is_config_writable(self):
-- command = 'if [ ! -w "'+PREY_PATH+'/config" ]; then echo 1; fi'
-+ command = 'if [ ! -w '+CONFIG_FILE+' ]; then echo 1; fi'
- no_access = os.popen(command).read().strip()
- if no_access == '1':
- self.show_alert(_("Unauthorized"), _("You don't have access to manage Prey's configuration. Sorry."), True)
diff --git a/app-laptop/prey/prey-0.5.3.ebuild b/app-laptop/prey/prey-0.5.3.ebuild
deleted file mode 100644
index e051f7a1ee83..000000000000
--- a/app-laptop/prey/prey-0.5.3.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/prey/prey-0.5.3.ebuild,v 1.4 2012/06/01 00:22:28 zmedico Exp $
-
-EAPI=4
-
-inherit eutils user
-
-DESCRIPTION="Tracking software for asset recovery"
-HOMEPAGE="http://preyproject.com/"
-SRC_URI="http://preyproject.com/releases/${PV}/${P}-linux.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk userpriv"
-
-LINGUAS="en it sv es"
-for x in ${LINGUAS}; do
- IUSE="${IUSE} linguas_${x}"
-done
-
-MODULES="+alarm +alert +geo lock +network secure +session webcam"
-IUSE="${IUSE} ${MODULES}"
-
-DEPEND=""
-#TODO: some of these deps may be dependent on USE
-RDEPEND="${DEPEND}
- app-shells/bash
- virtual/cron
- || ( net-misc/curl net-misc/wget )
- dev-perl/IO-Socket-SSL
- dev-perl/Net-SSLeay
- sys-apps/net-tools
- alarm? ( media-sound/mpg123
- media-sound/pulseaudio
- )
- alert? ( || ( ( gnome-extra/zenity ) ( kde-base/kdialog ) ) )
- gtk? ( dev-python/pygtk )
- lock? ( dev-python/pygtk )
- network? ( net-analyzer/traceroute )
- session? ( sys-apps/iproute2
- || ( media-gfx/scrot media-gfx/imagemagick )
- )
- webcam? ( || ( ( media-video/mplayer[encode,jpeg,v4l] ) ( media-tv/xawtv ) ) )"
-
-S=${WORKDIR}/${PN}
-
-pkg_setup() {
- if use userpriv; then
- enewgroup ${PN}
- fi
- if use gtk; then
- ewarn "You have the 'gtk' useflag enabled"
- ewarn "This means that the ${PN} configuration"
- ewarn "will be accessible via a graphical user"
- ewarn "interface. This may allow the thief to alter"
- ewarn "or disable the ${PN} functionality"
- fi
-
- # remove system module since it depends on hal and we don't
- # have hal in portage anymore
- rm -rf "${S}"/modules/system || die
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-cron-functions.patch \
- "${FILESDIR}"/${P}-gtk-ui.patch \
- "${FILESDIR}"/${P}-mplayer-support.patch
- sed -i -e 's,readonly base_path=`dirname "$0"`,readonly \
- base_path="/usr/share/prey",' \
- "${S}"/prey.sh || die
-}
-
-src_install() {
- # Remove config app if -gtk
- if use gtk; then
- # fix the path
- doicon "${S}"/pixmaps/${PN}.png
- newbin "${S}"/platform/linux/${PN}-config.py ${PN}-config
- make_desktop_entry ${PN}-config "Prey Configuration" ${PN} \
- "System;Monitor"
- else
- rm -f "${S}"/platform/linux/prey-config.py || die
- fi
-
- # clear out unneeded language files
- for lang in ${LINGUAS}; do
- use "linguas_${lang}" || rm -f lang/${lang} modules/*/lang/${lang}
- done
-
- # Core files
- insinto /usr/share/prey
- doins -r "${S}"/core "${S}"/lang "${S}"/pixmaps "${S}"/platform "${S}"/version
-
- # Main script
- newbin ${PN}.sh ${PN}
-
- # Put the configuration file into /etc, strict perms, symlink
- insinto /etc/prey
- newins config ${PN}.conf
- # some scripts require /usr/share/prey/config file to be present
- # so symlink it to prey.conf
- dosym /etc/${PN}/${PN}.conf /usr/share/${PN}/config
- use userpriv && { fowners root:${PN} /etc/prey ; }
- fperms 770 /etc/prey
- use userpriv && { fowners root:${PN} /etc/prey/prey.conf ; }
- fperms 660 /etc/prey/prey.conf
-
- # Add cron.d script
- insinto /etc/cron.d
- doins "${FILESDIR}/prey.cron"
- use userpriv && { fowners root:${PN} /etc/cron.d/prey.cron ; }
- fperms 660 /etc/cron.d/prey.cron
-
- dodoc README
-
- # modules
- cd "${S}"/modules
- for mod in *
- do
- use ${mod} || continue
-
- # move config, if present, to /etc/prey
- if [ -f $mod/config ]
- then
- insinto "/etc/prey"
- newins "$mod/config" "mod-$mod.conf"
- use userpriv && { fowners root:${PN} "/etc/${PN}/mod-$mod.conf" ; }
- fperms 660 "/etc/${PN}/mod-$mod.conf"
- # Rest of the module in its expected location
- insinto /usr/share/prey/modules
- doins -r "$mod"
- if [[ $mod == "lock" ]]; then
- fperms 555 \
- "/usr/share/${PN}/modules/lock/platform/linux/${PN}-lock"
- fi
- fi
- done
-
-}
-pkg_postinst () {
- elog "--Configuration--"
- elog "Make sure you follow the next steps before running prey for the"
- elog "first time"
- if use userpriv; then
- elog "- Add your user to ${PN} group using"
- elog "gpasswd -a <your_user> ${PN}"
- else
- elog "You don't seem to have 'userpriv' enabled so"
- elog "${PN} configuration is only accessible as root"
- fi
- elog "- Create an account on http://preyproject.com/"
- elog "- Modify the core and module configuration in /etc/prey"
- elog "- Uncomment the line in /etc/cron.d/prey.cron"
-}