summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2006-03-12 02:27:35 +0000
committerStephen Klimaszewski <steev@gentoo.org>2006-03-12 02:27:35 +0000
commit8d8b7f498f44e897ddabaaa8e55335caa85f2b71 (patch)
treeeba4548f5794c9eacb0ff01915ff8bf18c7ca68d /app-laptop/tpctl/tpctl-4.17.ebuild
parentupstream has gone away (bug #125857) (diff)
downloadgentoo-2-8d8b7f498f44e897ddabaaa8e55335caa85f2b71.tar.gz
gentoo-2-8d8b7f498f44e897ddabaaa8e55335caa85f2b71.tar.bz2
gentoo-2-8d8b7f498f44e897ddabaaa8e55335caa85f2b71.zip
Update meta to show mobile as herd, version bump to 4.17
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'app-laptop/tpctl/tpctl-4.17.ebuild')
-rw-r--r--app-laptop/tpctl/tpctl-4.17.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-laptop/tpctl/tpctl-4.17.ebuild b/app-laptop/tpctl/tpctl-4.17.ebuild
new file mode 100644
index 000000000000..ee9e5d22fc3d
--- /dev/null
+++ b/app-laptop/tpctl/tpctl-4.17.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpctl/tpctl-4.17.ebuild,v 1.1 2006/03/12 02:27:35 steev Exp $
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Thinkpad system control user space programs"
+
+HOMEPAGE="http://tpctl.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+IUSE="tpctlir"
+
+DEPEND="app-laptop/thinkpad
+ dev-lang/perl
+ sys-libs/ncurses"
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use tpctlir; then
+ emake -C tpctlir || die "emake -C tpctlir failed"
+ fi
+}
+
+src_install() {
+ if use tpctlir; then
+ dodir /usr/sbin
+ newdoc tpctlir/README README.tpctlir
+ doman tpctlir/tpctlir.8
+ fi
+
+ emake DEST=${D} install_libraries install_binaries install_man || die "emake install failed"
+
+ newinitd ${FILESDIR}/apmiser.rc apmiser
+
+ dodoc ChangeLog SUPPORTED-MODELS TROUBLESHOOTING AUTHORS README VGA-MODES
+ newdoc apmiser/README README.apmiser
+}