summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-11-24 16:03:03 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-11-24 16:03:03 +0000
commit1755dc8d75cf8afc7e9561b7b3d614571207949e (patch)
tree16964c3446c1545452068682d789dc959b183fdb /app-laptop/smcinit/smcinit-0.4.ebuild
parentversion bump (#68206) (Manifest recommit) (diff)
downloadgentoo-2-1755dc8d75cf8afc7e9561b7b3d614571207949e.tar.gz
gentoo-2-1755dc8d75cf8afc7e9561b7b3d614571207949e.tar.bz2
gentoo-2-1755dc8d75cf8afc7e9561b7b3d614571207949e.zip
Initial import of app-laptop/smcinit, version 0.4, an app to initialize a SMC-IRCC based IrDA subsystem on laptops where the bios does not handle that automatically
Diffstat (limited to 'app-laptop/smcinit/smcinit-0.4.ebuild')
-rw-r--r--app-laptop/smcinit/smcinit-0.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-laptop/smcinit/smcinit-0.4.ebuild b/app-laptop/smcinit/smcinit-0.4.ebuild
new file mode 100644
index 000000000000..162d5dddc132
--- /dev/null
+++ b/app-laptop/smcinit/smcinit-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/smcinit/smcinit-0.4.ebuild,v 1.1 2004/11/24 16:03:03 s4t4n Exp $
+
+IUSE=""
+
+MY_PV="0.4-1"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A set of utilities to initialize a SMC-IRCC based IrDA subsystem on laptops where the BIOS does not handle it"
+HOMEPAGE="http://irda.sourceforge.net/smcinit/"
+SRC_URI="mirror://sourceforge/irda/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/pciutils-2.1.11-r1"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile()
+{
+ econf || die "Configuration failed"
+ emake CFLAGS="${CFLAGS}" || die "Compilation failed"
+}
+
+src_install()
+{
+ # First goes the software...
+ einstall PREFIX="${D}/usr" || die "Installation failed"
+
+ # ...then documentation...
+ dodoc AUTHORS CHANGELOG.Peri ChangeLog INSTALL README README.Peri README.Rob README.Tom
+ dohtml RobMiller-irda.html
+
+ # ...after that an init script...
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PN}.initscript ${PN}
+
+ # ...and finally its config file
+ insinto /etc/conf.d
+ newins ${FILESDIR}/${PN}.conf ${PN}
+}