summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-01-03 20:37:17 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-01-03 20:37:17 +0000
commitb33acc604bfdeb16b0cc8e3442fd8045502956d7 (patch)
treeba8e0ae01be08b359efc54f4125c232c875ec55f /app-laptop/ibm-acpi
parentPruned old versions. (Manifest recommit) (diff)
downloadgentoo-2-b33acc604bfdeb16b0cc8e3442fd8045502956d7.tar.gz
gentoo-2-b33acc604bfdeb16b0cc8e3442fd8045502956d7.tar.bz2
gentoo-2-b33acc604bfdeb16b0cc8e3442fd8045502956d7.zip
Ported to use linux-mod.eclass, bumping because of modules.d file addition.
Diffstat (limited to 'app-laptop/ibm-acpi')
-rw-r--r--app-laptop/ibm-acpi/ChangeLog7
-rw-r--r--app-laptop/ibm-acpi/Manifest2
-rw-r--r--app-laptop/ibm-acpi/files/digest-ibm-acpi-0.8-r11
-rw-r--r--app-laptop/ibm-acpi/ibm-acpi-0.8-r1.ebuild69
4 files changed, 78 insertions, 1 deletions
diff --git a/app-laptop/ibm-acpi/ChangeLog b/app-laptop/ibm-acpi/ChangeLog
index faa81e57b7f2..c6eeb75e5e1b 100644
--- a/app-laptop/ibm-acpi/ChangeLog
+++ b/app-laptop/ibm-acpi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/ibm-acpi
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/ibm-acpi/ChangeLog,v 1.15 2005/01/03 20:31:08 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/ibm-acpi/ChangeLog,v 1.16 2005/01/03 20:37:17 brix Exp $
+
+*ibm-acpi-0.8-r1 (03 Jan 2005)
+
+ 03 Jan 2005; Henrik Brix Andersen <brix@gentoo.org> +ibm-acpi-0.8-r1.ebuild:
+ Ported to use linux-mod.eclass, bumping because of modules.d file addition.
03 Jan 2005; Henrik Brix Andersen <brix@gentoo.org> -ibm-acpi-0.4.ebuild,
-ibm-acpi-0.7.ebuild:
diff --git a/app-laptop/ibm-acpi/Manifest b/app-laptop/ibm-acpi/Manifest
index ec5dad011a3b..572be19ebb42 100644
--- a/app-laptop/ibm-acpi/Manifest
+++ b/app-laptop/ibm-acpi/Manifest
@@ -1,4 +1,6 @@
MD5 82e8a78cafa40d4e9506e6c58556ddae ibm-acpi-0.8.ebuild 2272
+MD5 5358cf147b83e96794e96ce0ad5fa50b ibm-acpi-0.8-r1.ebuild 1419
MD5 7d62d170ac959c785650924f620593ac ChangeLog 2069
MD5 b280eebc74d70d85e664debf1adce2c3 metadata.xml 255
+MD5 bed3ae2596959ff1e380bfba86458bc5 files/digest-ibm-acpi-0.8-r1 63
MD5 bed3ae2596959ff1e380bfba86458bc5 files/digest-ibm-acpi-0.8 63
diff --git a/app-laptop/ibm-acpi/files/digest-ibm-acpi-0.8-r1 b/app-laptop/ibm-acpi/files/digest-ibm-acpi-0.8-r1
new file mode 100644
index 000000000000..3e5373d66ad7
--- /dev/null
+++ b/app-laptop/ibm-acpi/files/digest-ibm-acpi-0.8-r1
@@ -0,0 +1 @@
+MD5 8e5fa7d61a8e613513629133f9d7208c ibm-acpi-0.8.tar.gz 25979
diff --git a/app-laptop/ibm-acpi/ibm-acpi-0.8-r1.ebuild b/app-laptop/ibm-acpi/ibm-acpi-0.8-r1.ebuild
new file mode 100644
index 000000000000..fb906772c0fa
--- /dev/null
+++ b/app-laptop/ibm-acpi/ibm-acpi-0.8-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/ibm-acpi/ibm-acpi-0.8-r1.ebuild,v 1.1 2005/01/03 20:37:17 brix Exp $
+
+inherit linux-mod
+
+DESCRIPTION="IBM ThinkPad ACPI extras"
+
+HOMEPAGE="http://ibm-acpi.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="doc"
+
+BUILD_PARAMS="KDIR=${KV_DIR}"
+BUILD_TARGETS="default"
+MODULE_NAMES="ibm_acpi(acpi:)"
+MODULESD_IBM_ACPI_DOCS="LICENSE README"
+
+CONFIG_CHECK="!ACPI_IBM ACPI"
+ACPI_IBM_ERROR="${P} requires IBM ThinkPad Laptop Extras (CONFIG_ACPI_IBM) to be DISABLED in the kernel."
+ACPI_ERROR="${P} requires an ACPI (CONFIG_ACPI) enabled kernel."
+
+pkg_setup() {
+ if kernel_is 2 4; then
+ die "${P} does not support kernel 2.4.x"
+ fi
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ convert_to_m ${S}/Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ if use doc; then
+ docinto examples/etc/acpi/actions
+ dodoc config/etc/acpi/actions/*
+
+ docinto examples/etc/acpi/events
+ dodoc config/etc/acpi/events/*
+ fi
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "You may wish to install sys-apps/acpid to handle the ACPI events generated"
+ einfo "by ${PN}."
+
+ if useq doc; then
+ einfo ""
+ einfo "Example acpid configuration has been installed to"
+ einfo "/usr/share/doc/${PF}/examples/"
+ fi
+
+ einfo ""
+ einfo "For further instructions please see /usr/share/doc/${PF}/README.gz"
+ einfo ""
+
+ linux-mod_pkg_postinst
+}