summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-01-23 09:02:26 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-01-23 09:02:26 +0000
commit65f91304a30256a482af3b9d8c84d7156bd04888 (patch)
tree86cf65c3bbe1084ca9e39a25fc3f09f328ed4c67 /app-i18n
parentFixed LICENSE, bug #301123. Removed old version. (diff)
downloadgentoo-2-65f91304a30256a482af3b9d8c84d7156bd04888.tar.gz
gentoo-2-65f91304a30256a482af3b9d8c84d7156bd04888.tar.bz2
gentoo-2-65f91304a30256a482af3b9d8c84d7156bd04888.zip
Version bumped.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/nkf/ChangeLog9
-rw-r--r--app-i18n/nkf/nkf-2.1.0.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/app-i18n/nkf/ChangeLog b/app-i18n/nkf/ChangeLog
index 6b363ced4757..c914e6381af0 100644
--- a/app-i18n/nkf/ChangeLog
+++ b/app-i18n/nkf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/nkf
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.44 2008/12/08 14:58:29 matsuu Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.45 2010/01/23 09:02:26 matsuu Exp $
+
+*nkf-2.1.0 (23 Jan 2010)
+
+ 23 Jan 2010; MATSUU Takuto <matsuu@gentoo.org> +nkf-2.1.0.ebuild:
+ Version bumped.
*nkf-2.0.7-r1 (08 Dec 2008)
diff --git a/app-i18n/nkf/nkf-2.1.0.ebuild b/app-i18n/nkf/nkf-2.1.0.ebuild
new file mode 100644
index 000000000000..bcb7a732b560
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.1.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.1.0.ebuild,v 1.1 2010/01/23 09:02:26 matsuu Exp $
+
+EAPI="2"
+
+inherit eutils distutils perl-module toolchain-funcs
+
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+SRC_URI="mirror://sourceforge.jp/nkf/44486/${P}.tar.gz
+ python? ( http://city.plala.jp/moin/NkfPython?action=AttachFile&do=get&target=NKF_python20090602.tgz -> NKF_python20090602.tgz )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="perl python linguas_ja"
+
+src_prepare() {
+ sed -i \
+ -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
+ Makefile || die
+
+ if use python; then
+ mv "${WORKDIR}/NKF.python" "${S}" || die
+ sed -i -e "s/-s/${CFLAGS}/" NKF.python/setup.py || die
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" nkf || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_compile
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils_src_compile
+ fi
+}
+
+src_test() {
+ emake test || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ dobin nkf || die
+ doman nkf.1
+ if use linguas_ja; then
+ ./nkf -e nkf.1j > nkf.1
+ doman -i18n=ja nkf.1
+ fi
+ dodoc nkf.doc
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_install
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils_src_install
+ fi
+}