summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-10 11:51:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-10 11:51:50 +0000
commit040464f72d52058f25ebd02f5252116a736c32a2 (patch)
treea5d7d2f95735de8a65375a20724348c483179e3c /app-i18n/x-unikey
parentFix building with GCC 4.4+ and GLIBC 2.10+ wrt #277565. (diff)
downloadgentoo-2-040464f72d52058f25ebd02f5252116a736c32a2.tar.gz
gentoo-2-040464f72d52058f25ebd02f5252116a736c32a2.tar.bz2
gentoo-2-040464f72d52058f25ebd02f5252116a736c32a2.zip
Might as well tackle repoman issues too.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/x-unikey')
-rw-r--r--app-i18n/x-unikey/x-unikey-0.9.2.ebuild13
-rw-r--r--app-i18n/x-unikey/x-unikey-1.0.4.ebuild65
2 files changed, 7 insertions, 71 deletions
diff --git a/app-i18n/x-unikey/x-unikey-0.9.2.ebuild b/app-i18n/x-unikey/x-unikey-0.9.2.ebuild
index b35f061f142e..83aaef8438d0 100644
--- a/app-i18n/x-unikey/x-unikey-0.9.2.ebuild
+++ b/app-i18n/x-unikey/x-unikey-0.9.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/x-unikey-0.9.2.ebuild,v 1.8 2007/07/22 09:48:19 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/x-unikey-0.9.2.ebuild,v 1.9 2009/08/10 11:51:50 ssuominen Exp $
inherit eutils
@@ -18,6 +18,7 @@ DEPEND="x11-libs/libX11
x11-libs/libICE
nls? ( sys-devel/gettext )
gtk? ( >=x11-libs/gtk+-2.2 )"
+RDEPEND="${DEPEND}"
src_compile() {
local myconf
@@ -30,10 +31,10 @@ src_compile() {
src_install() {
if use gtk;then
dodir etc/gtk-2.0
- make DESTDIR=${D} install -C src/unikey-gtk
+ emake DESTDIR="${D}" install -C src/unikey-gtk
fi
dobin src/xim/ukxim src/gui/unikey
- doenvd ${FILESDIR}/01x-unikey
+ doenvd "${FILESDIR}"/01x-unikey
dodoc doc/manual doc/ukmacro doc/unikeyrc
}
@@ -43,7 +44,7 @@ pkg_postinst() {
elog "to enable x-unikey"
elog ""
if use gtk; then
- gtk-query-immodules-2.0 > ${ROOT}/etc/gtk-2.0/gtk.immodules
+ gtk-query-immodules-2.0 > "${ROOT}"/etc/gtk-2.0/gtk.immodules
elog "If you want to use x-unikey as the default gtk+ input method,"
elog "change GTK_IM_MODULE in /etc/env.d/01x-unikey to \"unikey\""
elog ""
@@ -52,6 +53,6 @@ pkg_postinst() {
pkg_postrm() {
if use gtk; then
- gtk-query-immodules-2.0 > ${ROOT}/etc/gtk-2.0/gtk.immodules
+ gtk-query-immodules-2.0 > "${ROOT}"/etc/gtk-2.0/gtk.immodules
fi
}
diff --git a/app-i18n/x-unikey/x-unikey-1.0.4.ebuild b/app-i18n/x-unikey/x-unikey-1.0.4.ebuild
deleted file mode 100644
index 282ea4db5d15..000000000000
--- a/app-i18n/x-unikey/x-unikey-1.0.4.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/x-unikey-1.0.4.ebuild,v 1.4 2007/07/22 09:48:19 calchan Exp $
-
-inherit eutils
-
-DESCRIPTION="Vietnamese X Input Method"
-HOMEPAGE="http://unikey.sourceforge.net/linux.php"
-SRC_URI="mirror://sourceforge/unikey/${P}.tar.bz2
- doc? ( http://unikey.org/manual/x-unikey-manual.html http://unikey.org/manual/x-unikey-manual.pdf )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ppc ~x86"
-IUSE="nls gtk doc"
-
-DEPEND="x11-libs/libX11
- x11-libs/libSM
- x11-libs/libICE
- nls? ( sys-devel/gettext )
- gtk? ( >=x11-libs/gtk+-2.2 )"
-
-src_unpack() {
- unpack ${P}.tar.bz2 || die "unpack failed"
- if use doc; then
- cp ${DISTDIR}/x-unikey-manual.html ${DISTDIR}/x-unikey-manual.pdf ${WORKDIR}/${P}/doc
- fi
-}
-
-src_compile() {
- local myconf
- # --with-gtk-sysconfdir to prevent sandbox violation only
- use gtk && myconf="--with-unikey-gtk --with-gtk-sysconfdir=${D}/etc/gtk-2.0"
- econf ${myconf} || die "./configure failed"
- emake || die
-}
-
-src_install() {
- if use gtk;then
- dodir etc/gtk-2.0
- make DESTDIR=${D} install -C src/unikey-gtk
- fi
- dobin src/xim/ukxim src/gui/unikey
- doenvd ${FILESDIR}/01x-unikey
- dodoc doc/*
-}
-
-pkg_postinst() {
- elog ""
- elog "Go to /etc/env.d/01x-unikey and uncomment appropriate lines"
- elog "to enable x-unikey"
- elog ""
- if use gtk; then
- gtk-query-immodules-2.0 > ${ROOT}/etc/gtk-2.0/gtk.immodules
- elog "If you want to use x-unikey as the default gtk+ input method,"
- elog "change GTK_IM_MODULE in /etc/env.d/01x-unikey to \"unikey\""
- elog ""
- fi
-}
-
-pkg_postrm() {
- if use gtk; then
- gtk-query-immodules-2.0 > ${ROOT}/etc/gtk-2.0/gtk.immodules
- fi
-}