summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2007-10-12 10:57:46 +0000
committerAkinori Hattori <hattya@gentoo.org>2007-10-12 10:57:46 +0000
commit24abe563e138f1bdc35cdbe619d6a12c40d7f0d2 (patch)
treedf1c1bfbc87fc02031bf4061bc52e0515582a55b /app-i18n/uim-svn
parentbump to 2.20.0 (diff)
downloadgentoo-2-24abe563e138f1bdc35cdbe619d6a12c40d7f0d2.tar.gz
gentoo-2-24abe563e138f1bdc35cdbe619d6a12c40d7f0d2.tar.bz2
gentoo-2-24abe563e138f1bdc35cdbe619d6a12c40d7f0d2.zip
fixes bug #194804.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-i18n/uim-svn')
-rw-r--r--app-i18n/uim-svn/ChangeLog6
-rw-r--r--app-i18n/uim-svn/files/50uim-gentoo.el6
-rw-r--r--app-i18n/uim-svn/files/50uim-svn-gentoo.el4
-rw-r--r--app-i18n/uim-svn/uim-svn-1.5.ebuild42
4 files changed, 32 insertions, 26 deletions
diff --git a/app-i18n/uim-svn/ChangeLog b/app-i18n/uim-svn/ChangeLog
index d5024278c24c..4be8ced660aa 100644
--- a/app-i18n/uim-svn/ChangeLog
+++ b/app-i18n/uim-svn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/uim-svn
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim-svn/ChangeLog,v 1.30 2007/09/03 14:31:52 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim-svn/ChangeLog,v 1.31 2007/10/12 10:57:45 hattya Exp $
+
+ 12 Oct 2007; Akinori Hattori <hattya@gentoo.org> -files/50uim-gentoo.el,
+ +files/50uim-svn-gentoo.el, uim-svn-1.5.ebuild:
+ fixes bug #194804.
03 Sep 2007; Akinori Hattori <hattya@gentoo.org> uim-svn-1.5.ebuild:
change the repository location and update HOMEPAGE.
diff --git a/app-i18n/uim-svn/files/50uim-gentoo.el b/app-i18n/uim-svn/files/50uim-gentoo.el
deleted file mode 100644
index a9c648411cd8..000000000000
--- a/app-i18n/uim-svn/files/50uim-gentoo.el
+++ /dev/null
@@ -1,6 +0,0 @@
-
-;;; uim site-lisp configuration
-
-(require 'uim-leim)
-(set-language-info "Japanese" 'input-method "japanese-@IM@-uim")
-
diff --git a/app-i18n/uim-svn/files/50uim-svn-gentoo.el b/app-i18n/uim-svn/files/50uim-svn-gentoo.el
new file mode 100644
index 000000000000..854b665b366f
--- /dev/null
+++ b/app-i18n/uim-svn/files/50uim-svn-gentoo.el
@@ -0,0 +1,4 @@
+;;; app-i18n/uim-svn site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'uim-mode "uim" nil t)
diff --git a/app-i18n/uim-svn/uim-svn-1.5.ebuild b/app-i18n/uim-svn/uim-svn-1.5.ebuild
index 57e712ad7824..b5e65540d9ae 100644
--- a/app-i18n/uim-svn/uim-svn-1.5.ebuild
+++ b/app-i18n/uim-svn/uim-svn-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim-svn/uim-svn-1.5.ebuild,v 1.4 2007/09/03 14:31:52 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim-svn/uim-svn-1.5.ebuild,v 1.5 2007/10/12 10:57:45 hattya Exp $
inherit elisp-common flag-o-matic kde-functions multilib subversion
@@ -93,6 +93,7 @@ src_compile() {
econf \
$(use_enable emacs) \
+ $(use_with emacs lispdir "${SITELISP}") \
$(use_enable fep) \
$(use_enable nls) \
$(use_with X x) \
@@ -132,25 +133,18 @@ src_install() {
done
if use emacs; then
- local im
-
- if has_version app-i18n/anthy || has_version app-i18n/anthy-ss; then
- im="anthy"
-
- elif has_version app-i18n/prime; then
- im="prime"
-
- else
- im="skk"
-
- fi
-
- elisp-site-file-install "${FILESDIR}"/50uim-gentoo.el
- dosed "s:@IM@:${im}:" ${SITELISP}/50uim-gentoo.el
+ cd "${D}/${SITELISP}"/uim-el
+ elisp-comp *.el || die
+ cd -
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el uim-el
fi
- # remove sigscheme headers
- rm -rf ${D}/usr/include/sigscheme
+ # remove empty directories
+ rm -rf "${D}"/usr/include/sigscheme
+ rm -rf "${D}"/usr/include/libgcroots
+
+ # remove unnecessary header
+ rm -f "${D}"/usr/include/gcroots.h
}
@@ -160,7 +154,17 @@ pkg_postinst() {
has_multilib_profile && chost=${CHOST}
use gtk && gtk-query-immodules-2.0 > "${ROOT}"/etc/gtk-2.0/${chost}/gtk.immodules
- use emacs && elisp-site-regen
+
+ if use emacs; then
+ elisp-site-regen
+
+ echo
+ elog "uim is autoloaded with Emacs with a minimal set of"
+ elog "features: There is no keybinding defined to call it directly,"
+ elog "so please create one yourself and choose an input method."
+ elog "Integration with LEIM is not done with this ebuild, please have a look"
+ elog "at the documentation how to achieve this."
+ fi
}