summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 01:58:14 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 01:58:14 +0000
commitfb047b1b54d3898159d146639749fc276fc9f789 (patch)
tree094592bb8e49fa12ffacb050dd18a04cc0bb11ad /app-i18n/nkf
parentQA - fix use invocation (Manifest recommit) (diff)
downloadgentoo-2-fb047b1b54d3898159d146639749fc276fc9f789.tar.gz
gentoo-2-fb047b1b54d3898159d146639749fc276fc9f789.tar.bz2
gentoo-2-fb047b1b54d3898159d146639749fc276fc9f789.zip
touch the libc
Diffstat (limited to 'app-i18n/nkf')
-rw-r--r--app-i18n/nkf/nkf-2.0.2-r1.ebuild22
-rw-r--r--app-i18n/nkf/nkf-2.0.4.ebuild22
2 files changed, 24 insertions, 20 deletions
diff --git a/app-i18n/nkf/nkf-2.0.2-r1.ebuild b/app-i18n/nkf/nkf-2.0.2-r1.ebuild
index 2b1f2df5537b..b627c7029b11 100644
--- a/app-i18n/nkf/nkf-2.0.2-r1.ebuild
+++ b/app-i18n/nkf/nkf-2.0.2-r1.ebuild
@@ -1,23 +1,26 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.2-r1.ebuild,v 1.7 2004/06/24 21:52:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.2-r1.ebuild,v 1.8 2004/06/28 01:57:16 vapier Exp $
+inherit gcc
use perl && inherit perl-module
MY_P="${PN}${PV//./}"
DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
-SRC_URI="http://www01.tcp-ip.or.jp/~furukawa/nkf_utf8/${MY_P}.tar.gz"
HOMEPAGE="http://sourceforge.jp/projects/nkf/"
-DEPEND="virtual/glibc
- $DEPEND"
-KEYWORDS="x86 ppc sparc alpha"
-IUSE="perl cjk"
+SRC_URI="http://www01.tcp-ip.or.jp/~furukawa/nkf_utf8/${MY_P}.tar.gz"
+
LICENSE="public-domain"
SLOT="0"
+KEYWORDS="x86 ppc sparc alpha"
+IUSE="perl cjk"
+
+DEPEND="virtual/libc"
+
S=${WORKDIR}/${MY_P}
src_compile() {
- emake CC=gcc CFLAGS="${CFLAGS}" nkf || die
+ emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" nkf || die
if use perl; then
cd ${S}/NKF.mod
perl-module_src_compile
@@ -25,9 +28,8 @@ src_compile() {
fi
}
-src_install () {
- into /usr
- dobin nkf
+src_install() {
+ dobin nkf || die
doman nkf.1
if use cjk; then
dodir /usr/share/man/ja/man1
diff --git a/app-i18n/nkf/nkf-2.0.4.ebuild b/app-i18n/nkf/nkf-2.0.4.ebuild
index 188f59c2dde7..7e579f069628 100644
--- a/app-i18n/nkf/nkf-2.0.4.ebuild
+++ b/app-i18n/nkf/nkf-2.0.4.ebuild
@@ -1,23 +1,26 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.4.ebuild,v 1.5 2004/06/24 21:52:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.4.ebuild,v 1.6 2004/06/28 01:57:16 vapier Exp $
+inherit gcc
use perl && inherit perl-module
MY_P="${PN}${PV//./}"
DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
-SRC_URI="http://www01.tcp-ip.or.jp/~furukawa/nkf_utf8/${MY_P}.tar.gz"
HOMEPAGE="http://sourceforge.jp/projects/nkf/"
-DEPEND="virtual/glibc
- $DEPEND"
-KEYWORDS="x86 ppc sparc alpha amd64"
-IUSE="perl cjk"
+SRC_URI="http://www01.tcp-ip.or.jp/~furukawa/nkf_utf8/${MY_P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
+KEYWORDS="x86 ppc sparc alpha amd64"
+IUSE="perl cjk"
+
+DEPEND="virtual/libc"
+
S=${WORKDIR}/${MY_P}
src_compile() {
- emake CC=gcc CFLAGS="${CFLAGS}" nkf || die
+ emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" nkf || die
if use perl; then
cd ${S}/NKF.mod
perl-module_src_compile
@@ -25,9 +28,8 @@ src_compile() {
fi
}
-src_install () {
- into /usr
- dobin nkf
+src_install() {
+ dobin nkf || die
doman nkf.1
if use cjk; then
dodir /usr/share/man/ja/man1