summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-06-15 23:07:34 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-06-15 23:07:34 +0000
commit3138e0da9ff53cba294bd07d1373ff552eb45d8c (patch)
tree4581a60eb110182d32dd530510c5189ebd5d9b34 /app-i18n/ibus-skk
parentRevbump fixing linking bug #369107, EAPI bump. Remove old. (diff)
downloadgentoo-2-3138e0da9ff53cba294bd07d1373ff552eb45d8c.tar.gz
gentoo-2-3138e0da9ff53cba294bd07d1373ff552eb45d8c.tar.bz2
gentoo-2-3138e0da9ff53cba294bd07d1373ff552eb45d8c.zip
Version bumped.
(Portage version: 2.1.10.2/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/ibus-skk')
-rw-r--r--app-i18n/ibus-skk/ChangeLog7
-rw-r--r--app-i18n/ibus-skk/ibus-skk-1.3.7.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-i18n/ibus-skk/ChangeLog b/app-i18n/ibus-skk/ChangeLog
index be6af3b6f96a..47050fe3e5c3 100644
--- a/app-i18n/ibus-skk/ChangeLog
+++ b/app-i18n/ibus-skk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-skk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.17 2011/05/14 00:40:05 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.18 2011/06/15 23:07:34 matsuu Exp $
+
+*ibus-skk-1.3.7 (15 Jun 2011)
+
+ 15 Jun 2011; MATSUU Takuto <matsuu@gentoo.org> +ibus-skk-1.3.7.ebuild:
+ Version bumped.
*ibus-skk-1.3.6 (14 May 2011)
diff --git a/app-i18n/ibus-skk/ibus-skk-1.3.7.ebuild b/app-i18n/ibus-skk/ibus-skk-1.3.7.ebuild
new file mode 100644
index 000000000000..00cdf47c6bcb
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-1.3.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-1.3.7.ebuild,v 1.1 2011/06/15 23:07:34 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="http://cloud.github.com/downloads/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.3
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}