summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-06 12:22:34 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-06 12:22:34 +0000
commitb9a7eae20e104de46811b06383a6d345b22014dc (patch)
treeec6069b1e022e2543b7a20734e1ca210b2665ac5 /app-forensics
parentVersion bump. (diff)
downloadgentoo-2-b9a7eae20e104de46811b06383a6d345b22014dc.tar.gz
gentoo-2-b9a7eae20e104de46811b06383a6d345b22014dc.tar.bz2
gentoo-2-b9a7eae20e104de46811b06383a6d345b22014dc.zip
Version bump. Update to new license.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afflib/ChangeLog7
-rw-r--r--app-forensics/afflib/afflib-3.6.16.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index db2baefdbd2e..2e8ef2dee935 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afflib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.28 2012/03/01 23:29:55 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.29 2012/03/06 12:22:34 radhermit Exp $
+
+*afflib-3.6.16 (06 Mar 2012)
+
+ 06 Mar 2012; Tim Harder <radhermit@gentoo.org> +afflib-3.6.16.ebuild:
+ Version bump. Update to new license.
01 Mar 2012; Brent Baude <ranger@gentoo.org> afflib-3.6.12.ebuild:
Marking afflib-3.6.12 ppc stable for bug 374321
diff --git a/app-forensics/afflib/afflib-3.6.16.ebuild b/app-forensics/afflib/afflib-3.6.16.ebuild
new file mode 100644
index 000000000000..48d0292c689a
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.6.16.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.6.16.ebuild,v 1.1 2012/03/06 12:22:34 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils python
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="http://afflib.org/"
+SRC_URI="http://afflib.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="fuse ncurses python qemu readline s3 static-libs threads"
+
+RDEPEND="dev-libs/expat
+ dev-libs/openssl
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.6.12-python-module.patch
+ "${FILESDIR}"/${PN}-3.6.12-pyaff-header.patch
+)
+
+pkg_setup() {
+ if use python ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i -e "/FLAGS/s: -g::" configure.ac || die
+ sed -i -e "/-static/d" tools/Makefile.am || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # Hacks for automagic dependencies
+ use ncurses || export ac_cv_lib_ncurses_initscr=no
+ use readline || export ac_cv_lib_readline_readline=no
+
+ local myeconfargs=(
+ $(use_enable fuse)
+ $(use_enable python)
+ $(use_enable qemu)
+ $(use_enable s3)
+ $(use_enable threads threading)
+ )
+ autotools-utils_src_configure
+}