summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-04-09 03:43:46 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-04-09 03:43:46 +0000
commit345f79343480c7e628aa5a1d9fce10695686bc76 (patch)
treee44cd2509308e131caa13654c5ef71efcbb82b77 /app-forensics
parentDepend on setuptools, #408241 by lucapost. Confirmed by Ian Delaney. Remove old. (diff)
downloadgentoo-2-345f79343480c7e628aa5a1d9fce10695686bc76.tar.gz
gentoo-2-345f79343480c7e628aa5a1d9fce10695686bc76.tar.bz2
gentoo-2-345f79343480c7e628aa5a1d9fce10695686bc76.zip
Revision bump to add upstream patch for sys-apps/file compatibility
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/rkhunter/ChangeLog8
-rw-r--r--app-forensics/rkhunter/files/rkhunter-1.3.8-file-compat.patch62
-rw-r--r--app-forensics/rkhunter/rkhunter-1.3.8-r1.ebuild68
3 files changed, 137 insertions, 1 deletions
diff --git a/app-forensics/rkhunter/ChangeLog b/app-forensics/rkhunter/ChangeLog
index b0256735b9d8..4c8323fd9af4 100644
--- a/app-forensics/rkhunter/ChangeLog
+++ b/app-forensics/rkhunter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/rkhunter
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.89 2012/01/12 00:09:42 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.90 2012/04/09 03:43:46 darkside Exp $
+
+*rkhunter-1.3.8-r1 (09 Apr 2012)
+
+ 09 Apr 2012; Jeremy Olexa <darkside@gentoo.org> +rkhunter-1.3.8-r1.ebuild,
+ +files/rkhunter-1.3.8-file-compat.patch:
+ Revision bump to add upstream patch for sys-apps/file compatibility
12 Jan 2012; Tim Harder <radhermit@gentoo.org> -files/rkhunter-ppc64.patch,
-rkhunter-1.3.4-r3.ebuild, -rkhunter-1.3.6.ebuild:
diff --git a/app-forensics/rkhunter/files/rkhunter-1.3.8-file-compat.patch b/app-forensics/rkhunter/files/rkhunter-1.3.8-file-compat.patch
new file mode 100644
index 000000000000..595e99f60147
--- /dev/null
+++ b/app-forensics/rkhunter/files/rkhunter-1.3.8-file-compat.patch
@@ -0,0 +1,62 @@
+Applied upstream repo @
+http://rkhunter.cvs.sourceforge.net/viewvc/rkhunter/rkhunter/files/rkhunter?r1=1.396&r2=1.397
+
+--- rkhunter 2011/04/11 22:29:08 1.396
++++ rkhunter 2011/06/01 21:49:23 1.397
+@@ -3,7 +3,7 @@
+ #
+ # rkhunter -- Scan the system for rootkits and other known security issues.
+ #
+-# Copyright (c) 2003-2010, Michael Boelen ( michael AT rootkit DOT nl )
++# Copyright (c) 2003-2011, Michael Boelen ( michael AT rootkit DOT nl )
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+@@ -725,7 +725,7 @@
+ #
+
+ if [ $STRICT -eq 1 ]; then
+- if [ -n "`echo \"${RKHTMPVAR}\" | grep '[][?*{}]'`" ]; then
++ if [ -n "`echo \"${RKHTMPVAR}\" | grep '[][?*]'`" ]; then
+ ERRCODE=1
+ test $CONFIG_CHECK -eq 1 && RET_CODE=1
+ echo "Invalid ${OPT_NAME} configuration option: Invalid pathname: ${RKHTMPVAR}"
+@@ -3987,7 +3987,7 @@
+ HASH_CMD=`echo "${HASH_FUNC}" | cut -d' ' -f1`
+
+ # Stop globbing from being expanded.
+- if [ -z "`echo \"${HASH_CMD}\" | grep '[][*?{}]'`" ]; then
++ if [ -z "`echo \"${HASH_CMD}\" | grep '[][*?]'`" ]; then
+ HASH_FUNC=`echo ${HASH_FUNC}`
+ else
+ LEAVE=1
+@@ -4756,7 +4756,7 @@
+
+ test -z "${FNAME}" && break
+
+- if [ -n "`echo \"${FNAME}\" | grep '^[^/]*[][*?{}][^/]*$'`" ]; then
++ if [ -n "`echo \"${FNAME}\" | grep '^[^/]*[][*?][^/]*$'`" ]; then
+ ERRCODE=1
+ echo "Invalid USER_FILEPROP_FILES_DIRS configuration option: Invalid pathname: ${FNAME}"
+ fi
+@@ -9898,9 +9898,9 @@
+ test -n "${BASENAME_CMD}" && RKHTMPVAR=`${BASENAME_CMD} ${FNAME}` || RKHTMPVAR=`echo "${FNAME}" | sed -e 's:^.*/::'`
+
+ if [ "${RKHTMPVAR}" = "rkhunter" ]; then
+- SYSSCRIPT=`${FILE_CMD} ${FNAME} 2>&1 | tr -s ' ' ' ' | cat -v | egrep -i -v '(shell|/bin/sh) script( |$)'`
++ SYSSCRIPT=`${FILE_CMD} ${FNAME} 2>&1 | tr -s ' ' ' ' | cat -v | egrep -i -v '(shell|/bin/sh) script( |,|$)'`
+ else
+- SYSSCRIPT=`${FILE_CMD} ${FNAME} 2>&1 | tr -s ' ' ' ' | cat -v | egrep -i ' script( |$)'`
++ SYSSCRIPT=`${FILE_CMD} ${FNAME} 2>&1 | tr -s ' ' ' ' | cat -v | egrep -i ' script( |,|$)'`
+ fi
+
+ test -n "${SYSSCRIPT}" && TEST_RESULT="${TEST_RESULT} script"
+@@ -16508,7 +16508,7 @@
+ PROGRAM_NAME="Rootkit Hunter"
+ PROGRAM_version="1.3.9"
+ PROGRAM_copyright_owner="Michael Boelen"
+-PROGRAM_copyright="Copyright (c) 2003-2010, ${PROGRAM_copyright_owner}"
++PROGRAM_copyright="Copyright (c) 2003-2011, ${PROGRAM_copyright_owner}"
+ PROGRAM_blurb="
+ Currently under active development by the ${PROGRAM_NAME} project team.
+ Please review your rkhunter.conf before using.
diff --git a/app-forensics/rkhunter/rkhunter-1.3.8-r1.ebuild b/app-forensics/rkhunter/rkhunter-1.3.8-r1.ebuild
new file mode 100644
index 000000000000..5b6456983fd2
--- /dev/null
+++ b/app-forensics/rkhunter/rkhunter-1.3.8-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/rkhunter-1.3.8-r1.ebuild,v 1.1 2012/04/09 03:43:46 darkside Exp $
+
+EAPI=4
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers."
+HOMEPAGE="http://rkhunter.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ dev-lang/perl
+ sys-process/lsof
+ virtual/cron
+"
+
+S="${WORKDIR}/${P}/files"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}.conf.patch"
+ epatch "${FILESDIR}/${P}-file-compat.patch"
+}
+
+src_install() {
+ # rkhunter requires to be root
+ dosbin ${PN}
+
+ # rkhunter doesn't create it by itself
+ dodir /var/lib/${PN}/tmp
+
+ insinto /etc
+ doins ${PN}.conf
+
+ exeinto /usr/lib/${PN}/scripts
+ doexe *.pl
+
+ insinto /var/lib/${PN}/db
+ doins *.dat
+
+ insinto /var/lib/${PN}/db/i18n
+ doins i18n/*
+
+ doman ${PN}.8
+ dodoc ACKNOWLEDGMENTS CHANGELOG FAQ README
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}-1.3.cron" ${PN}
+
+ newbashcomp "${FILESDIR}/${PN}.bash-completion" ${PN}
+}
+
+pkg_postinst() {
+ elog "A cron script has been installed to /etc/cron.daily/rkhunter."
+ elog "To enable it, edit /etc/cron.daily/rkhunter and follow the"
+ elog "directions."
+ elog "If you want ${PN} to send mail, you will need to install"
+ elog "virtual/mailx or alter the EMAIL_CMD variable in the"
+ elog "cron script and possibly the MAIL_CMD variable in the"
+ elog "${PN}.conf file to use another mail client."
+}