summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-10-30 21:01:35 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-10-30 21:01:35 +0000
commiteb1bcaf87ef63d454a27f82cf5ad22bd184f396f (patch)
tree63e03781c8d779db70bb52bbe33cb045c71c0a5d /app-emulation
parentUse new switch for paralel jobs count. Solves quite few bugs we had on gentoo... (diff)
downloadgentoo-2-eb1bcaf87ef63d454a27f82cf5ad22bd184f396f.tar.gz
gentoo-2-eb1bcaf87ef63d454a27f82cf5ad22bd184f396f.tar.bz2
gentoo-2-eb1bcaf87ef63d454a27f82cf5ad22bd184f396f.zip
Ensure no one uses USE=bluetooth with USE=static since it doesn't work.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog7
-rw-r--r--app-emulation/qemu/qemu-1.1.1-r1.ebuild4
-rw-r--r--app-emulation/qemu/qemu-1.1.2-r1.ebuild5
-rw-r--r--app-emulation/qemu/qemu-1.1.2-r2.ebuild6
-rw-r--r--app-emulation/qemu/qemu-1.2.0.ebuild10
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild10
6 files changed, 21 insertions, 21 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 8774b13a4509..044e70fb6eec 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.138 2012/10/30 20:53:33 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.139 2012/10/30 21:01:35 cardoe Exp $
+
+ 30 Oct 2012; Doug Goldstein <cardoe@gentoo.org> qemu-1.1.1-r1.ebuild,
+ qemu-1.1.2-r1.ebuild, qemu-1.1.2-r2.ebuild, qemu-1.2.0.ebuild,
+ qemu-9999.ebuild:
+ Ensure no one uses USE=bluetooth with USE=static since it doesn't work.
30 Oct 2012; Doug Goldstein <cardoe@gentoo.org> qemu-1.1.1-r1.ebuild,
qemu-1.1.2-r1.ebuild, qemu-1.1.2-r2.ebuild:
diff --git a/app-emulation/qemu/qemu-1.1.1-r1.ebuild b/app-emulation/qemu/qemu-1.1.1-r1.ebuild
index 5c959fabfa4e..939593f3b928 100644
--- a/app-emulation/qemu/qemu-1.1.1-r1.ebuild
+++ b/app-emulation/qemu/qemu-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.1.1-r1.ebuild,v 1.4 2012/10/30 20:53:33 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.1.1-r1.ebuild,v 1.5 2012/10/30 21:01:35 cardoe Exp $
EAPI="4"
@@ -52,7 +52,7 @@ for target in ${IUSE_USER_TARGETS}; do
IUSE="${IUSE} qemu_user_targets_${target}"
done
-REQUIRED_USE="static? ( !alsa !pulseaudio )
+REQUIRED_USE="static? ( !alsa !pulseaudio !bluetooth )
amd64? ( qemu_softmmu_targets_x86_64 )
x86? ( qemu_softmmu_targets_x86_64 )
virtfs? ( xattr )"
diff --git a/app-emulation/qemu/qemu-1.1.2-r1.ebuild b/app-emulation/qemu/qemu-1.1.2-r1.ebuild
index 1b74d3727ce1..92f9fcc95423 100644
--- a/app-emulation/qemu/qemu-1.1.2-r1.ebuild
+++ b/app-emulation/qemu/qemu-1.1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.1.2-r1.ebuild,v 1.3 2012/10/30 20:53:33 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.1.2-r1.ebuild,v 1.4 2012/10/30 21:01:35 cardoe Exp $
EAPI="4"
@@ -39,7 +39,6 @@ IUSE_USER_TARGETS="${COMMON_TARGETS} armeb ppc64abi32 sparc32plus unicore32"
# Setup the default SoftMMU targets, while using the loops
# below to setup the other targets.
-IUSE="${IUSE}"
REQUIRED_USE="|| ("
for target in ${IUSE_SOFTMMU_TARGETS}; do
@@ -53,7 +52,7 @@ for target in ${IUSE_USER_TARGETS}; do
done
REQUIRED_USE="${REQUIRED_USE}
- static? ( !alsa !pulseaudio )
+ static? ( !alsa !pulseaudio !bluetooth )
virtfs? ( xattr )"
# Yep, you need both libcap and libcap-ng since virtfs only uses libcap.
diff --git a/app-emulation/qemu/qemu-1.1.2-r2.ebuild b/app-emulation/qemu/qemu-1.1.2-r2.ebuild
index d31727f60595..02eeb1ab704a 100644
--- a/app-emulation/qemu/qemu-1.1.2-r2.ebuild
+++ b/app-emulation/qemu/qemu-1.1.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.1.2-r2.ebuild,v 1.3 2012/10/30 20:53:33 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.1.2-r2.ebuild,v 1.4 2012/10/30 21:01:35 cardoe Exp $
EAPI="4"
@@ -39,7 +39,6 @@ IUSE_USER_TARGETS="${COMMON_TARGETS} armeb ppc64abi32 sparc32plus unicore32"
# Setup the default SoftMMU targets, while using the loops
# below to setup the other targets.
-IUSE="${IUSE}"
REQUIRED_USE="|| ("
for target in ${IUSE_SOFTMMU_TARGETS}; do
@@ -52,8 +51,9 @@ for target in ${IUSE_USER_TARGETS}; do
IUSE="${IUSE} qemu_user_targets_${target}"
done
+# Block USE flag configurations known to not work
REQUIRED_USE="${REQUIRED_USE}
- static? ( !alsa !pulseaudio )
+ static? ( !alsa !pulseaudio !bluetooth )
virtfs? ( xattr )"
# Yep, you need both libcap and libcap-ng since virtfs only uses libcap.
diff --git a/app-emulation/qemu/qemu-1.2.0.ebuild b/app-emulation/qemu/qemu-1.2.0.ebuild
index 02977be3e49a..7696ea8a640d 100644
--- a/app-emulation/qemu/qemu-1.2.0.ebuild
+++ b/app-emulation/qemu/qemu-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.2.0.ebuild,v 1.6 2012/10/29 23:50:54 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.2.0.ebuild,v 1.7 2012/10/30 21:01:35 cardoe Exp $
EAPI="4"
@@ -33,16 +33,13 @@ kernel_FreeBSD mixemu ncurses opengl +png pulseaudio python rbd sasl +seccomp \
sdl smartcard spice static systemtap tci +threads tls usbredir +uuid vde \
+vhost-net virtfs +vnc xattr xen xfs"
-# Block USE flag configurations known to not work
-REQUIRED_USE="static ( !bluetooth )"
-
COMMON_TARGETS="i386 x86_64 alpha arm cris m68k microblaze microblazeel mips mipsel ppc ppc64 sh4 sh4eb sparc sparc64 s390x"
IUSE_SOFTMMU_TARGETS="${COMMON_TARGETS} lm32 mips64 mips64el ppcemb xtensa xtensaeb"
IUSE_USER_TARGETS="${COMMON_TARGETS} armeb ppc64abi32 sparc32plus unicore32"
# Setup the default SoftMMU targets, while using the loops
# below to setup the other targets.
-REQUIRED_USE="${REQUIRED_USE} || ("
+REQUIRED_USE="|| ("
for target in ${IUSE_SOFTMMU_TARGETS}; do
IUSE="${IUSE} qemu_softmmu_targets_${target}"
@@ -54,8 +51,9 @@ for target in ${IUSE_USER_TARGETS}; do
IUSE="${IUSE} qemu_user_targets_${target}"
done
+# Block USE flag configurations known to not work
REQUIRED_USE="${REQUIRED_USE}
- static? ( !alsa !pulseaudio )
+ static? ( !alsa !pulseaudio !bluetooth )
virtfs? ( xattr )"
# Yep, you need both libcap and libcap-ng since virtfs only uses libcap.
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 57e9c56a1c9e..33ebf4c2113b 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.28 2012/10/29 23:50:54 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.29 2012/10/30 21:01:35 cardoe Exp $
EAPI="4"
@@ -33,16 +33,13 @@ kernel_FreeBSD mixemu ncurses opengl +png pulseaudio python rbd sasl +seccomp \
sdl smartcard spice static systemtap tci +threads tls usbredir +uuid vde \
+vhost-net virtfs +vnc xattr xen xfs"
-# Block USE flag configurations known to not work
-REQUIRED_USE="static ( !bluetooth )"
-
COMMON_TARGETS="i386 x86_64 alpha arm cris m68k microblaze microblazeel mips mipsel ppc ppc64 sh4 sh4eb sparc sparc64 s390x"
IUSE_SOFTMMU_TARGETS="${COMMON_TARGETS} lm32 mips64 mips64el ppcemb xtensa xtensaeb"
IUSE_USER_TARGETS="${COMMON_TARGETS} armeb ppc64abi32 sparc32plus unicore32"
# Setup the default SoftMMU targets, while using the loops
# below to setup the other targets.
-REQUIRED_USE="${REQUIRED_USE} || ("
+REQUIRED_USE="|| ("
for target in ${IUSE_SOFTMMU_TARGETS}; do
IUSE="${IUSE} qemu_softmmu_targets_${target}"
@@ -54,8 +51,9 @@ for target in ${IUSE_USER_TARGETS}; do
IUSE="${IUSE} qemu_user_targets_${target}"
done
+# Block USE flag configurations known to not work
REQUIRED_USE="${REQUIRED_USE}
- static? ( !alsa !pulseaudio )
+ static? ( !alsa !pulseaudio !bluetooth )
virtfs? ( xattr )"
# Yep, you need both libcap and libcap-ng since virtfs only uses libcap.