summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-01-13 04:30:37 +0000
committerMike Frysinger <vapier@gentoo.org>2003-01-13 04:30:37 +0000
commite73199537d9eabc0b9d11918908407c595d8d3e2 (patch)
tree52a3f81a4119b83fe62aae7f7316f9ee1b2cbbef /app-emulation
parentfixes bug #13659 (diff)
downloadgentoo-2-e73199537d9eabc0b9d11918908407c595d8d3e2.tar.gz
gentoo-2-e73199537d9eabc0b9d11918908407c595d8d3e2.tar.bz2
gentoo-2-e73199537d9eabc0b9d11918908407c595d8d3e2.zip
gcc-2.x/dos fix
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/pcsx/pcsx-1.4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-emulation/pcsx/pcsx-1.4.ebuild b/app-emulation/pcsx/pcsx-1.4.ebuild
index d404bb3afd77..8f0a622e4e97 100644
--- a/app-emulation/pcsx/pcsx-1.4.ebuild
+++ b/app-emulation/pcsx/pcsx-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pcsx/pcsx-1.4.ebuild,v 1.2 2002/12/13 19:57:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pcsx/pcsx-1.4.ebuild,v 1.3 2003/01/13 04:30:37 vapier Exp $
S=${WORKDIR}
DESCRIPTION="Playstation emulator"
@@ -38,6 +38,11 @@ src_compile() {
<LnxMain.c >LnxMain.tmp
mv -f LnxMain.tmp LnxMain.c
+ for f in `find ${WORKDIR} -regex '.*\.[ch]'` ; do
+ cp ${f}{,.old}
+ sed -e 's/ $//' ${f}.old > ${f}
+ done
+
emake CC=gcc OPTIMIZE="${CFLAGS} -fPIC -fomit-frame-pointer -finline-functions -ffast-math" || die
mv pcsx pcsx.bin
}