summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-01-19 22:55:55 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-01-19 22:55:55 +0000
commitc3f0e9ef92f964efece00e27a20a81da479e4202 (patch)
tree2c7dd717f21a66400b35ae0d7cd7d59b5b77f8d1 /app-emulation
parentdisables DirectFB now if directfb is not in USE (diff)
downloadgentoo-2-c3f0e9ef92f964efece00e27a20a81da479e4202.tar.gz
gentoo-2-c3f0e9ef92f964efece00e27a20a81da479e4202.tar.bz2
gentoo-2-c3f0e9ef92f964efece00e27a20a81da479e4202.zip
Version bump
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/bochs/ChangeLog7
-rw-r--r--app-emulation/bochs/bochs-2.0.ebuild51
-rw-r--r--app-emulation/bochs/files/digest-bochs-2.02
3 files changed, 59 insertions, 1 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index f9b33e30f650..c44dda4361e8 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.5 2002/07/22 21:41:22 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.6 2003/01/19 22:55:55 lu_zero Exp $
+
+*bochs-2.0 (19 Jan 2003)
+
+ 19 Jan 2003; Luca Barbato <lu_zero@gentoo.org> ChangeLog : bochs-2.0.ebuild
+ Version bump
*bochs-1.4.1 (23 Jul 2002)
diff --git a/app-emulation/bochs/bochs-2.0.ebuild b/app-emulation/bochs/bochs-2.0.ebuild
new file mode 100644
index 000000000000..c1bddde06536
--- /dev/null
+++ b/app-emulation/bochs/bochs-2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.ebuild,v 1.1 2003/01/19 22:55:55 lu_zero Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Bochs is a pc emulator.
+This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
+CDROM drive. It also comes with a disk image using dlxlinux."
+SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
+ http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
+HOMEPAGE="http://bochs.sourceforge.net"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="sdl"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=x11-base/xfree-4.0.1
+ sdl? media-libs/libsdl"
+KEYWORDS="~x86 ~ppc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd $S
+ cp Makefile.in Makefile.in.orig
+ sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
+
+}
+
+src_compile() {
+
+ [ "$ARCH" == "x86" ] && myconf="--enable-idle-hack"
+ use sdl && myconf="${myconf} --with-sdl" \
+ || myconf="${myconf} --without-sdl"
+ ./configure --enable-fpu --enable-cdrom --enable-control-panel \
+ --enable-ne2000 --enable-sb16=linux --enable-slowdown --prefix=/usr \
+ --infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} --with-x11 $myconf || die
+
+
+ emake || die
+}
+
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPYING CVS README TESTFORM.txt
+}
+
diff --git a/app-emulation/bochs/files/digest-bochs-2.0 b/app-emulation/bochs/files/digest-bochs-2.0
new file mode 100644
index 000000000000..7bedb9d7adb6
--- /dev/null
+++ b/app-emulation/bochs/files/digest-bochs-2.0
@@ -0,0 +1,2 @@
+MD5 11f613f0383791a958d6528d30ab8e1d bochs-2.0.tar.gz 3266323
+MD5 b1c1592f105fa7aa0ffaba349d38fcaa dlxlinux3.tar.gz 1504727