summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-02 14:12:59 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-02 14:12:59 +0000
commit9a03d6783966bb9f3c50d9e8f55b972fd95b8832 (patch)
tree263ab19876b7d696edeb4886164153568505bf0f /app-emulation
parentAdd ~sparc keyword at user request. (Manifest recommit) (diff)
downloadgentoo-2-9a03d6783966bb9f3c50d9e8f55b972fd95b8832.tar.gz
gentoo-2-9a03d6783966bb9f3c50d9e8f55b972fd95b8832.tar.bz2
gentoo-2-9a03d6783966bb9f3c50d9e8f55b972fd95b8832.zip
Version bump #73080 by David Guembel. Fix the no-stack-protector patch #72449 by Malte S. Stretz. Disable maketest (it requires X to be running) #72375 by Sascha Silbe.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog11
-rw-r--r--app-emulation/wine/files/20041019-no-stack.patch16
-rw-r--r--app-emulation/wine/files/digest-wine-200412011
-rw-r--r--app-emulation/wine/wine-20041019-r3.ebuild3
-rw-r--r--app-emulation/wine/wine-20041201.ebuild107
5 files changed, 128 insertions, 10 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index e0dd697da8dd..8a5478c0c542 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.83 2004/11/09 16:12:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.84 2004/12/02 14:12:59 vapier Exp $
+
+*wine-20041201 (02 Dec 2004)
+
+ 02 Dec 2004; Mike Frysinger <vapier@gentoo.org>
+ files/20041019-no-stack.patch, wine-20041019-r3.ebuild,
+ +wine-20041201.ebuild:
+ Version bump #73080 by David Guembel. Fix the no-stack-protector patch
+ #72449 by Malte S. Stretz. Disable maketest (it requires X to be running)
+ #72375 by Sascha Silbe.
09 Nov 2004; Mike Frysinger <vapier@gentoo.org> wine-20041019-r3.ebuild:
USE=lcms support #70520.
diff --git a/app-emulation/wine/files/20041019-no-stack.patch b/app-emulation/wine/files/20041019-no-stack.patch
index 3b9b927c4b41..a615f28d42be 100644
--- a/app-emulation/wine/files/20041019-no-stack.patch
+++ b/app-emulation/wine/files/20041019-no-stack.patch
@@ -1,9 +1,9 @@
---- loader/Makefile.in.orig 2004-10-27 21:26:15.663148264 -0400
-+++ loader/Makefile.in 2004-10-27 21:27:44.434652944 -0400
-@@ -55,3 +55,6 @@
- $(RM) $(WINE_BINARIES) $(MODULE)
+--- loader/Makefile.in.orig 2004-12-02 08:57:46.540539616 -0500
++++ loader/Makefile.in 2004-12-02 08:57:53.043551008 -0500
+@@ -21,5 +21,6 @@
- ### Dependencies:
-+
-+preloader.o:
-+ $(CC) -c -fno-pic -fno-stack-protector $(ALLCFLAGS) -o $@ preloader.c
+ @MAKE_RULES@
++CFLAGS += -fno-pic -fno-stack-protector
+
+ LIBPTHREAD = @LIBPTHREAD@
+ LDEXECFLAGS = @LDEXECFLAGS@
diff --git a/app-emulation/wine/files/digest-wine-20041201 b/app-emulation/wine/files/digest-wine-20041201
new file mode 100644
index 000000000000..818f850b8e86
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20041201
@@ -0,0 +1 @@
+MD5 f47c26c012a78a37f22ad56122402f11 Wine-20041201.tar.gz 11264647
diff --git a/app-emulation/wine/wine-20041019-r3.ebuild b/app-emulation/wine/wine-20041019-r3.ebuild
index fcadec1a3ab3..7f14e2c8c72f 100644
--- a/app-emulation/wine/wine-20041019-r3.ebuild
+++ b/app-emulation/wine/wine-20041019-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.5 2004/11/17 13:59:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.6 2004/12/02 14:12:59 vapier Exp $
inherit eutils flag-o-matic
@@ -12,6 +12,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="-* ~x86"
IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses doc lcms"
+RESTRICT="maketest" #72375
RDEPEND=">=media-libs/freetype-2.0.0
ncurses? ( >=sys-libs/ncurses-5.2 )
diff --git a/app-emulation/wine/wine-20041201.ebuild b/app-emulation/wine/wine-20041201.ebuild
new file mode 100644
index 000000000000..bec63040ac14
--- /dev/null
+++ b/app-emulation/wine/wine-20041201.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041201.ebuild,v 1.1 2004/12/02 14:12:59 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses doc lcms"
+RESTRICT="maketest" #72375
+
+RDEPEND=">=media-libs/freetype-2.0.0
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ X? ( virtual/x11 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ gif? ( media-libs/libungif )
+ jpeg? ( media-libs/jpeg )
+ glut? ( virtual/glut )
+ lcms? ( media-libs/lcms )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-devel/bison
+ sys-devel/gcc
+ doc? ( app-text/docbook-sgml-utils app-text/jadetex )
+ sys-devel/flex"
+
+src_unpack() {
+ unpack Wine-${PV}.tar.gz
+
+ cd ${S}
+ epatch ${FILESDIR}/winearts-kdecvs-fix.patch
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+
+ test_flag -fstack-protector && epatch ${FILESDIR}/20041019-no-stack.patch #66002
+}
+
+config_cache() {
+ local h ans="no"
+ use ${1} && ans="yes"
+ shift
+ for h in "$@" ; do
+ export ac_cv_${h}=${ans}
+ done
+}
+
+src_compile() {
+ export LDCONFIG=/bin/true
+ config_cache jack header_jack_jack_h
+ config_cache cups header_cups_cups_h
+ config_cache alsa header_alsa_asoundlib_h header_sys_asoundlib_h lib_asound_snd_pcm_open
+ use arts || export ARTSCCONFIG="/bin/false"
+ config_cache nas header_audio_audiolib_h header_audio_soundlib_h
+ config_cache gif header_gif_lib_h
+ config_cache glut lib_glut_glutMainLoop
+ config_cache jpeg header_jpeglib_h
+ config_cache oss header_sys_soundcard_h header_machine_soundcard_h header_soundcard_h
+ config_cache lcms header_lcms_h
+
+ strip-flags
+ use lcms && append-flags -I${ROOT}/usr/include/lcms
+
+ # $(use_enable amd64 win64)
+ # USE=debug is broken in this release
+ # $(use_enable debug trace)
+ # $(use_enable debug)
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with ncurses curses) \
+ $(use_with opengl) \
+ $(use_with X x) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+ emake all || die "all"
+ if use doc ; then
+ emake -C documentation doc || die "docs"
+ fi
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ datadir=${D}/usr/share \
+ includedir=${D}/usr/include/wine \
+ sysconfdir=${D}/etc/wine \
+ mandir=${D}/usr/share/man \
+ libdir=${D}/usr/lib \
+ dlldir=${D}/usr/lib/wine \
+ install || die
+ use doc && dodoc documentation/*.pdf
+
+ insinto /usr/share/wine
+ doins documentation/samples/config || die "doins config"
+
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS README
+}