summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-12-26 20:41:02 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-12-26 20:41:02 +0000
commit66ab7b3dc3f853999d455c89698ac89303625e19 (patch)
treefc379ae75364470bfcaa1397ca1116fdb79ba4ff /app-emulation
parentnew version (diff)
downloadgentoo-2-66ab7b3dc3f853999d455c89698ac89303625e19.tar.gz
gentoo-2-66ab7b3dc3f853999d455c89698ac89303625e19.tar.bz2
gentoo-2-66ab7b3dc3f853999d455c89698ac89303625e19.zip
new package. Fixes #12562
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/mupen64/ChangeLog8
-rw-r--r--app-emulation/mupen64/files/digest-mupen64-0.0.90a1
-rw-r--r--app-emulation/mupen64/files/mupen6413
-rw-r--r--app-emulation/mupen64/mupen64-0.0.90a.ebuild37
4 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/mupen64/ChangeLog b/app-emulation/mupen64/ChangeLog
new file mode 100644
index 000000000000..6ad8f986392a
--- /dev/null
+++ b/app-emulation/mupen64/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/mupen64
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mupen64/ChangeLog,v 1.1 2002/12/26 20:41:02 rphillips Exp $
+
+*mupen64-0.0.90a (26 Dec 2002)
+
+ 26 Dec 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+ initial release
diff --git a/app-emulation/mupen64/files/digest-mupen64-0.0.90a b/app-emulation/mupen64/files/digest-mupen64-0.0.90a
new file mode 100644
index 000000000000..903a969fe86a
--- /dev/null
+++ b/app-emulation/mupen64/files/digest-mupen64-0.0.90a
@@ -0,0 +1 @@
+MD5 d5e3aa5cbf37deadbe88d8df5adc846c mupen64_linux_0_0_90a.tgz 437069
diff --git a/app-emulation/mupen64/files/mupen64 b/app-emulation/mupen64/files/mupen64
new file mode 100644
index 000000000000..227de815e6ca
--- /dev/null
+++ b/app-emulation/mupen64/files/mupen64
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+if ! [ -d ~/.mupen64/save ]
+then
+ mkdir -p ~/.mupen64/{save,plugins}
+ cd ~/.mupen64
+ ln -s /usr/lib/mupen64/plugins/* plugins/
+ ln -s /opt/mupen64/mupen64 mupen64
+fi
+
+cd $HOME/.mupen64
+./mupen64
+
diff --git a/app-emulation/mupen64/mupen64-0.0.90a.ebuild b/app-emulation/mupen64/mupen64-0.0.90a.ebuild
new file mode 100644
index 000000000000..0c210c014aed
--- /dev/null
+++ b/app-emulation/mupen64/mupen64-0.0.90a.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mupen64/mupen64-0.0.90a.ebuild,v 1.1 2002/12/26 20:41:02 rphillips Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A Nintendo 64 (N64) emulator"
+SRC_URI="http://mupen64.emulation64.com/mupen64_linux_0_0_90a.tgz"
+HOMEPAGE="http://mupen64.emulation64.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ media-libs/libsdl
+ virtual/glu
+ virtual/opengl"
+
+src_install () {
+ dodir /opt/${PN} /opt/${PN}/plugins
+
+ exeinto /opt/${PN}/
+ doexe mupen64
+ dobin ${FILESDIR}/mupen64
+
+ insinto /usr/lib/${PN}/plugins
+ doins plugins/*
+
+ dodoc *.txt README.OBSIDIAN
+ dohtml index.html
+}
+
+pkg_postinst() {
+ einfo "Please note that mupen64 currectly only works in pure interpreter mode."
+ einfo "For best results, use the TR64 gfx plugin and emerge the blight_input plugin."
+}
+