summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-13 11:00:04 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-13 11:00:04 +0000
commit26166916f8e664363ad79e370e9f2d613c4809e1 (patch)
treee575f970974fb2f5b6ba0a96c050b3609d2a866a /app-emulation
parentAdded patch from gnomemeeting cvs that fixes building on systems without libsdl (diff)
downloadgentoo-2-26166916f8e664363ad79e370e9f2d613c4809e1.tar.gz
gentoo-2-26166916f8e664363ad79e370e9f2d613c4809e1.tar.bz2
gentoo-2-26166916f8e664363ad79e370e9f2d613c4809e1.zip
Version bump #84792.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/files/digest-wine-200503101
-rw-r--r--app-emulation/wine/wine-20050310.ebuild114
3 files changed, 121 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 6762e959e88c..2a4d5669831e 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.88 2005/02/20 02:30:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.89 2005/03/13 11:00:04 vapier Exp $
+
+*wine-20050310 (13 Mar 2005)
+
+ 13 Mar 2005; Mike Frysinger <vapier@gentoo.org> +wine-20050310.ebuild:
+ Version bump #84792.
19 Feb 2005; Mike Frysinger <vapier@gentoo.org>
+files/20050211-docs.patch, wine-20050111.ebuild, wine-20050211.ebuild:
diff --git a/app-emulation/wine/files/digest-wine-20050310 b/app-emulation/wine/files/digest-wine-20050310
new file mode 100644
index 000000000000..9cf471077c5a
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20050310
@@ -0,0 +1 @@
+MD5 d90d31716ba71211af26ac773934f57e Wine-20050310.tar.gz 11798040
diff --git a/app-emulation/wine/wine-20050310.ebuild b/app-emulation/wine/wine-20050310.ebuild
new file mode 100644
index 000000000000..542ccabbc1d4
--- /dev/null
+++ b/app-emulation/wine/wine-20050310.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310.ebuild,v 1.1 2005/03/13 11:00:04 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses doc lcms"
+RESTRICT="maketest" #72375
+
+RDEPEND=">=media-libs/freetype-2.0.0
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ X? ( virtual/x11 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ gif? ( media-libs/libungif )
+ jpeg? ( media-libs/jpeg )
+ glut? ( virtual/glut )
+ lcms? ( media-libs/lcms )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-soundlibs
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ doc? ( app-text/docbook-sgml-utils app-text/jadetex )
+ sys-devel/flex"
+
+src_unpack() {
+ unpack Wine-${PV}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+
+ test_flag -fstack-protector && epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+}
+
+config_cache() {
+ local h ans="no"
+ use ${1} && ans="yes"
+ shift
+ for h in "$@" ; do
+ export ac_cv_${h}=${ans}
+ done
+}
+
+src_compile() {
+ export LDCONFIG=/bin/true
+ config_cache jack header_jack_jack_h
+ config_cache cups header_cups_cups_h
+ config_cache alsa header_alsa_asoundlib_h header_sys_asoundlib_h lib_asound_snd_pcm_open
+ use arts || export ARTSCCONFIG="/bin/false"
+ config_cache nas header_audio_audiolib_h header_audio_soundlib_h
+ config_cache gif header_gif_lib_h
+ config_cache glut lib_glut_glutMainLoop
+ config_cache jpeg header_jpeglib_h
+ config_cache oss header_sys_soundcard_h header_machine_soundcard_h header_soundcard_h
+ config_cache lcms header_lcms_h
+
+ strip-flags
+ use lcms && append-flags -I${ROOT}/usr/include/lcms
+
+ if ! built_with_use app-text/docbook-sgml-utils tetex ; then
+ export DB2PDF=true
+ export DB2PS=true
+ fi
+
+ # $(use_enable amd64 win64)
+ # USE=debug is broken in this release
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with ncurses curses) \
+ $(use_with opengl) \
+ $(use_with X x) \
+ $(use_enable debug trace) \
+ $(use_enable debug) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+ emake all || die "all"
+ if use doc ; then
+ emake -j1 -C documentation doc || die "docs"
+ fi
+}
+
+src_install() {
+ make \
+ prefix="${D}"/usr \
+ bindir="${D}"/usr/bin \
+ datadir="${D}"/usr/share \
+ includedir="${D}"/usr/include/wine \
+ sysconfdir="${D}"/etc/wine \
+ mandir="${D}"/usr/share/man \
+ libdir="${D}"/usr/$(get_libdir) \
+ dlldir="${D}"/usr/$(get_libdir)/wine \
+ install || die
+ use doc && dodoc documentation/*.pdf
+
+ insinto /usr/share/wine
+ doins documentation/samples/config || die "doins config"
+
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS README
+}