summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2009-12-17 17:05:20 +0000
committerLance Albertson <ramereth@gentoo.org>2009-12-17 17:05:20 +0000
commit1f2ca987020557a4ac85f25ac34882b22e146f90 (patch)
tree97c28b2e799fbfc00092153bd57fd5f13e5f7e5d /app-emulation
parentbug #287546, thanks to Engelbert Gruber <grubert@users.sourceforge.net> and M... (diff)
downloadgentoo-2-1f2ca987020557a4ac85f25ac34882b22e146f90.tar.gz
gentoo-2-1f2ca987020557a4ac85f25ac34882b22e146f90.tar.bz2
gentoo-2-1f2ca987020557a4ac85f25ac34882b22e146f90.zip
Version bumps for CVE-2009-4261
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti/ChangeLog12
-rw-r--r--app-emulation/ganeti/ganeti-1.2.9.ebuild54
-rw-r--r--app-emulation/ganeti/ganeti-2.0.5.ebuild66
-rw-r--r--app-emulation/ganeti/ganeti-2.1.0_rc2.ebuild73
4 files changed, 204 insertions, 1 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 650c6059942e..f656757a43c8 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.12 2009/12/17 00:47:24 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.13 2009/12/17 17:05:20 ramereth Exp $
+
+*ganeti-2.1.0_rc2 (17 Dec 2009)
+*ganeti-2.0.5 (17 Dec 2009)
+*ganeti-1.2.9 (17 Dec 2009)
+
+ 17 Dec 2009; Lance Albertson <ramereth@gentoo.org> +ganeti-1.2.9.ebuild,
+ +ganeti-2.0.5.ebuild, +ganeti-2.1.0_rc2.ebuild:
+ Version bumps for CVE-2009-4261
+
+ See http://www.ocert.org/advisories/ocert-2009-019.html for details
*ganeti-2.1.0_rc1 (17 Dec 2009)
diff --git a/app-emulation/ganeti/ganeti-1.2.9.ebuild b/app-emulation/ganeti/ganeti-1.2.9.ebuild
new file mode 100644
index 000000000000..69fc9293035f
--- /dev/null
+++ b/app-emulation/ganeti/ganeti-1.2.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-1.2.9.ebuild,v 1.1 2009/12/17 17:05:20 ramereth Exp $
+
+NEED_PYTHON=2.4
+
+inherit python autotools eutils
+
+MY_P=${P/_beta/b}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Ganeti is a virtual server management software tool built upon Xen"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=app-emulation/xen-3.0
+ dev-libs/openssl
+ dev-python/pyopenssl
+ dev-python/pyparsing
+ dev-python/simplejson
+ dev-python/twisted
+ net-analyzer/arping
+ net-misc/bridge-utils
+ net-misc/openssh
+ sys-apps/iproute2
+ sys-cluster/drbd
+ sys-fs/lvm2
+ sys-fs/mdadm"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ econf --localstatedir=/var --with-ssh-initscript=/etc/init.d/sshd
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}/ganeti.initd" ganeti
+
+ keepdir /var/{lib,log,run}/ganeti/
+ keepdir /srv/ganeti/{os,export}/
+}
diff --git a/app-emulation/ganeti/ganeti-2.0.5.ebuild b/app-emulation/ganeti/ganeti-2.0.5.ebuild
new file mode 100644
index 000000000000..5af58b8d46dd
--- /dev/null
+++ b/app-emulation/ganeti/ganeti-2.0.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.0.5.ebuild,v 1.1 2009/12/17 17:05:20 ramereth Exp $
+
+EAPI=2
+
+inherit eutils confutils bash-completion
+
+DESCRIPTION="Ganeti is a virtual server management software tool"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kvm xen drbd"
+
+DEPEND="xen? ( >=app-emulation/xen-3.0 )
+ kvm? ( app-emulation/qemu-kvm )
+ drbd? ( >=sys-cluster/drbd-8.0 )
+ dev-libs/openssl
+ dev-python/pyopenssl
+ dev-python/pyparsing
+ dev-python/simplejson
+ net-analyzer/arping
+ net-misc/bridge-utils
+ net-misc/openssh
+ net-misc/socat
+ sys-apps/iproute2
+ sys-fs/lvm2"
+RDEPEND="${DEPEND}"
+
+src_prepare () {
+ epatch "${FILESDIR}/${PN}-2.0.3-gentoo-brctl-path.patch"
+}
+
+pkg_setup () {
+ confutils_require_any kvm xen
+}
+
+src_configure () {
+ econf --localstatedir=/var \
+ --docdir=/usr/share/doc/${P} \
+ --with-ssh-initscript=/etc/init.d/sshd \
+ --with-export-dir=/var/lib/ganeti-storage/export \
+ --with-os-search-path=/usr/share/ganeti/os \
+ --with-file-storage-dir=/var/lib/ganeti-storage/file
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/ganeti2.initd ganeti
+ dobashcompletion doc/examples/bash_completion ganeti
+ dodoc DEVNOTES INSTALL NEWS README doc/*.rst doc/*.txt
+ rm -rf "${D}"/usr/share/doc/ganeti
+ docinto examples
+ dodoc doc/examples/dumb-allocator doc/examples/ganeti.cron
+
+ keepdir /var/{lib,log,run}/ganeti/
+ keepdir /usr/share/ganeti/os/
+ keepdir /var/lib/ganeti-storage/{export,file}/
+}
+
+pkg_postinst () {
+ bash-completion_pkg_postinst
+}
diff --git a/app-emulation/ganeti/ganeti-2.1.0_rc2.ebuild b/app-emulation/ganeti/ganeti-2.1.0_rc2.ebuild
new file mode 100644
index 000000000000..1c9fe1becc5f
--- /dev/null
+++ b/app-emulation/ganeti/ganeti-2.1.0_rc2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.1.0_rc2.ebuild,v 1.1 2009/12/17 17:05:20 ramereth Exp $
+
+EAPI=2
+
+inherit eutils confutils bash-completion
+
+MY_PV="${PV/_rc/~rc}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Ganeti is a virtual server management software tool"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kvm xen drbd"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="xen? ( >=app-emulation/xen-3.0 )
+ kvm? ( app-emulation/qemu-kvm )
+ drbd? ( >=sys-cluster/drbd-8.0 )
+ dev-libs/openssl
+ dev-python/pyopenssl
+ dev-python/pyparsing
+ dev-python/pyinotify
+ dev-python/simplejson
+ net-analyzer/arping
+ net-misc/bridge-utils
+ net-misc/openssh
+ net-misc/socat
+ sys-apps/iproute2
+ sys-fs/lvm2"
+RDEPEND="${DEPEND}"
+
+src_prepare () {
+ epatch "${FILESDIR}/${PN}-2.1.0_rc1-fix-brctl-path-for-gentoo.patch"
+}
+
+pkg_setup () {
+ confutils_require_any kvm xen
+}
+
+src_configure () {
+ econf --localstatedir=/var \
+ --docdir=/usr/share/doc/${P} \
+ --with-ssh-initscript=/etc/init.d/sshd \
+ --with-export-dir=/var/lib/ganeti-storage/export \
+ --with-os-search-path=/usr/share/ganeti/os \
+ --with-file-storage-dir=/var/lib/ganeti-storage/file
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
+ dobashcompletion doc/examples/bash_completion ganeti
+ dodoc INSTALL NEWS README doc/*.{rst,png}
+ rm -rf "${D}"/usr/share/doc/ganeti
+ docinto examples
+ dodoc doc/examples/{dumb-allocator,ganeti.cron,gnt-config-backup}
+ docinto examples/hooks
+ dodoc doc/examples/hooks/{ipsec,ethers}
+
+ keepdir /var/{lib,log,run}/ganeti/
+ keepdir /usr/share/ganeti/os/
+ keepdir /var/lib/ganeti-storage/{export,file}/
+}
+
+pkg_postinst () {
+ bash-completion_pkg_postinst
+}