summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-05-04 18:59:11 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-05-04 18:59:11 +0000
commit1247cac260274a9961da13969a0a71976b2322e2 (patch)
tree55f1ff2927d0de376ac06494d61584e0f1c09ad0 /app-emulation/xen-tools
parent[Bug 219598] [PATCH] sys-libs/uclibc-0.9.28.3 - backport of splice(2), tee(2)... (diff)
downloadgentoo-2-1247cac260274a9961da13969a0a71976b2322e2.tar.gz
gentoo-2-1247cac260274a9961da13969a0a71976b2322e2.tar.bz2
gentoo-2-1247cac260274a9961da13969a0a71976b2322e2.zip
Version bump to the Xen 3.2.1 release (bug #219339), thanks to Troy Bowman
for testig. Disable magic building of QEMU documentation (bug #192427). (Portage version: 2.1.5_rc4)
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/ChangeLog10
-rw-r--r--app-emulation/xen-tools/files/xen-tools-3.2.1-qemu-nodocs.patch36
-rw-r--r--app-emulation/xen-tools/xen-tools-3.2.1.ebuild (renamed from app-emulation/xen-tools/xen-tools-3.1.2.ebuild)13
3 files changed, 53 insertions, 6 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 75e17abb14cd..1ff79117ff0f 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.36 2008/02/08 22:17:46 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.37 2008/05/04 18:59:10 rbu Exp $
+
+*xen-tools-3.2.1 (04 May 2008)
+
+ 04 May 2008; Robert Buchholz <rbu@gentoo.org>
+ +files/xen-tools-3.2.1-qemu-nodocs.patch, -xen-tools-3.1.2.ebuild,
+ +xen-tools-3.2.1.ebuild:
+ Version bump to the Xen 3.2.1 release (bug #219339), thanks to Troy Bowman
+ for testig. Disable magic building of QEMU documentation (bug #192427).
*xen-tools-3.2.0 (08 Feb 2008)
diff --git a/app-emulation/xen-tools/files/xen-tools-3.2.1-qemu-nodocs.patch b/app-emulation/xen-tools/files/xen-tools-3.2.1-qemu-nodocs.patch
new file mode 100644
index 000000000000..d112dd4ac438
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-3.2.1-qemu-nodocs.patch
@@ -0,0 +1,36 @@
+Introduce a configure option to disable building of qemu documentation.
+Gentoo Bug #192427
+
+Index: xen-3.2.1/tools/ioemu/configure
+===================================================================
+--- xen-3.2.1.orig/tools/ioemu/configure
++++ xen-3.2.1/tools/ioemu/configure
+@@ -214,6 +214,8 @@ for opt do
+ ;;
+ --disable-sdl) sdl="no"
+ ;;
++ --enable-docs) build_docs="yes"
++ ;;
+ --enable-coreaudio) coreaudio="yes"
+ ;;
+ --enable-alsa) alsa="yes"
+@@ -295,6 +297,7 @@ echo " --enable-coreaudio enable
+ echo " --enable-alsa enable ALSA audio driver"
+ echo " --enable-fmod enable FMOD audio driver"
+ echo " --enabled-dsound enable DirectSound audio driver"
++echo " --enable-docs enable building of docs (requires texi2html and pod2man)"
+ echo " --disable-vnc-tls disable TLS encryption for VNC server"
+ echo " --enable-system enable all system emulation targets"
+ echo " --disable-system disable all system emulation targets"
+@@ -576,8 +579,9 @@ EOF
+ fi
+
+ # Check if tools are available to build documentation.
+-if [ -x "`which texi2html`" ] && [ -x "`which pod2man`" ]; then
+- build_docs="yes"
++if [ ! -x "`which texi2html`" ] || [ ! -x "`which pod2man`" ]; then
++ echo "Missing texi2html or pod2man, will not build docs"
++ build_docs="no"
+ fi
+
+ if test "$mingw32" = "yes" ; then
diff --git a/app-emulation/xen-tools/xen-tools-3.1.2.ebuild b/app-emulation/xen-tools/xen-tools-3.2.1.ebuild
index 299d67122bcd..df3741a084e2 100644
--- a/app-emulation/xen-tools/xen-tools-3.1.2.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.2.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.1.2.ebuild,v 1.2 2007/12/14 17:26:58 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.2.1.ebuild,v 1.1 2008/05/04 18:59:10 rbu Exp $
inherit flag-o-matic eutils multilib
DESCRIPTION="Xend daemon and tools"
-HOMEPAGE="http://www.xensource.com/xen/xen/"
-SRC_URI="mirror://gentoo/xen-${PV}.tar.gz"
+HOMEPAGE="http://xen.org/"
+SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
S="${WORKDIR}/xen-${PV}"
LICENSE="GPL-2"
@@ -114,10 +114,13 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-3.0.4_p1--as-needed.patch"
# Fix network broadcast on bridged networks
- epatch "${FILESDIR}/${PN}-3.0.4_p1-network-bridge-broadcast.patch"
+ epatch "${FILESDIR}/${PN}-3.1.3-network-bridge-broadcast.patch"
# Fix building small dumb utility called 'xen-detect' on hardened
epatch "${FILESDIR}/${PN}-3.1.0-xen-detect-nopie-fix.patch"
+
+ # Introduce a configure option to disable qemu documentation building, #192427
+ epatch "${FILESDIR}/${PN}-3.2.1-qemu-nodocs.patch"
}
src_compile() {