summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-30 17:52:17 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-30 17:52:17 +0000
commitf675364a4a9f4fdc86d1d51757f611ace1686986 (patch)
treefe4bd8e7e01d1e2bd5c209e119aef3764fb8b48a /app-emulation/wine
parentmerge latest wine changes (diff)
downloadgentoo-2-f675364a4a9f4fdc86d1d51757f611ace1686986.tar.gz
gentoo-2-f675364a4a9f4fdc86d1d51757f611ace1686986.tar.bz2
gentoo-2-f675364a4a9f4fdc86d1d51757f611ace1686986.zip
Add support for USE=hal/dbus #141532 by Niels van Aert.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog6
-rw-r--r--app-emulation/wine/wine-0.9.18.ebuild8
-rw-r--r--app-emulation/wine/wine-9999.ebuild8
3 files changed, 17 insertions, 5 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 4a62022839db..d65b13b2badb 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.150 2006/07/30 16:49:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.151 2006/07/30 17:52:17 vapier Exp $
+
+ 30 Jul 2006; Mike Frysinger <vapier@gentoo.org> wine-0.9.18.ebuild,
+ wine-9999.ebuild:
+ Add support for USE=hal/dbus #141532 by Niels van Aert.
*wine-0.9.18 (30 Jul 2006)
diff --git a/app-emulation/wine/wine-0.9.18.ebuild b/app-emulation/wine/wine-0.9.18.ebuild
index 0cf2a5f61de7..2e286202da14 100644
--- a/app-emulation/wine/wine-0.9.18.ebuild
+++ b/app-emulation/wine/wine-0.9.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.18.ebuild,v 1.1 2006/07/30 16:49:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.18.ebuild,v 1.2 2006/07/30 17:52:17 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -11,13 +11,15 @@ SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE="alsa arts cups debug esd gif glut jack jpeg lcms ldap nas ncurses opengl oss scanner xml X"
+IUSE="alsa arts cups dbus debug esd gif glut hal jack jpeg lcms ldap nas ncurses opengl oss scanner xml X"
RESTRICT="test" #72375
RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
+ dbus? ( sys-apps/dbus )
+ hal? ( sys-apps/hal )
X? ( || ( ( x11-libs/libXrandr x11-libs/libXi x11-libs/libXmu
x11-libs/libXxf86dga x11-libs/libXxf86vm x11-apps/xmessage )
virtual/x11 )
@@ -87,6 +89,8 @@ src_compile() {
config_cache ldap ldap.h lber.h
config_cache gif gif_lib.h
config_cache glut glut:glutMainLoop
+ config_cache dbus dbus/dbus.h
+ config_cache hal hal/libhal.h
config_cache jpeg jpeglib.h
config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
config_cache lcms lcms.h
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index ecf9841743f2..055343d5f815 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.13 2006/07/30 17:46:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.14 2006/07/30 17:52:17 vapier Exp $
ECVS_SERVER="cvs.winehq.org:/home/wine"
ECVS_MODULE="wine"
@@ -16,13 +16,15 @@ SRC_URI=""
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="-*"
-IUSE="alsa arts cups debug esd gif glut jack jpeg lcms ldap nas ncurses opengl oss scanner truetype xml X"
+IUSE="alsa arts cups dbus debug esd gif glut hal jack jpeg lcms ldap nas ncurses opengl oss scanner xml X"
RESTRICT="test" #72375
RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
+ dbus? ( sys-apps/dbus )
+ hal? ( sys-apps/hal )
X? ( || ( ( x11-libs/libXrandr x11-libs/libXi x11-libs/libXmu
x11-libs/libXxf86dga x11-libs/libXxf86vm x11-apps/xmessage )
virtual/x11 )
@@ -94,6 +96,8 @@ src_compile() {
config_cache ldap ldap.h lber.h
config_cache gif gif_lib.h
config_cache glut glut:glutMainLoop
+ config_cache dbus dbus/dbus.h
+ config_cache hal hal/libhal.h
config_cache jpeg jpeglib.h
config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
config_cache lcms lcms.h