summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2009-05-09 21:59:41 +0000
committerMike Auty <ikelos@gentoo.org>2009-05-09 21:59:41 +0000
commit2aba5c4c018cb7d340e2f070c262ea82872dc0e8 (patch)
tree370fc9b5f5be70dec6c8df45a4bf8d5246c2fbcd /app-emulation/vmware-server-console
parentBump vmware-server and add in version 2. (diff)
downloadgentoo-2-2aba5c4c018cb7d340e2f070c262ea82872dc0e8.tar.gz
gentoo-2-2aba5c4c018cb7d340e2f070c262ea82872dc0e8.tar.bz2
gentoo-2-2aba5c4c018cb7d340e2f070c262ea82872dc0e8.zip
Version bump vmware-server-console.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-emulation/vmware-server-console')
-rw-r--r--app-emulation/vmware-server-console/ChangeLog8
-rw-r--r--app-emulation/vmware-server-console/vmware-server-console-1.0.9.156507.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/app-emulation/vmware-server-console/ChangeLog b/app-emulation/vmware-server-console/ChangeLog
index 5464ce45af68..df97fbce3732 100644
--- a/app-emulation/vmware-server-console/ChangeLog
+++ b/app-emulation/vmware-server-console/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vmware-server-console
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-server-console/ChangeLog,v 1.40 2009/02/22 23:22:17 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-server-console/ChangeLog,v 1.41 2009/05/09 21:59:41 ikelos Exp $
+
+*vmware-server-console-1.0.9.156507 (09 May 2009)
+
+ 09 May 2009; Mike Auty <ikelos@gentoo.org>
+ +vmware-server-console-1.0.9.156507.ebuild:
+ Version bump vmware-server-console.
22 Feb 2009; Mike Auty <ikelos@gentoo.org>
-vmware-server-console-1.0.5.80187-r1.ebuild,
diff --git a/app-emulation/vmware-server-console/vmware-server-console-1.0.9.156507.ebuild b/app-emulation/vmware-server-console/vmware-server-console-1.0.9.156507.ebuild
new file mode 100644
index 000000000000..97b13142185a
--- /dev/null
+++ b/app-emulation/vmware-server-console/vmware-server-console-1.0.9.156507.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-server-console/vmware-server-console-1.0.9.156507.ebuild,v 1.1 2009/05/09 21:59:41 ikelos Exp $
+
+# Unlike many other binary packages the user doesn't need to agree to a licence
+# to download VMWare. The agreeing to a licence is part of the configure step
+# which the user must run manually.
+
+inherit eutils versionator vmware
+
+MY_PN=${PN/vm/VM}
+MY_PV=$(replace_version_separator 3 '-')
+MY_P="${MY_PN}-${MY_PV}"
+FN="VMware-server-linux-client-${MY_PV}"
+S="${WORKDIR}/${PN}-distrib"
+
+DESCRIPTION="VMware Remote Console for Linux"
+HOMEPAGE="http://www.vmware.com/"
+SRC_URI="mirror://vmware/software/vmserver/${FN}.zip"
+
+LICENSE="vmware"
+IUSE=""
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+
+DEPEND=">=sys-libs/glibc-2.3.5
+ virtual/os-headers
+ >=dev-lang/perl-5
+ >=sys-apps/portage-2.0.54
+ app-arch/unzip"
+
+# vmware-server-console should not use virtual/libc as this is a
+# precompiled binary package thats linked to glibc.
+RDEPEND=">=sys-libs/glibc-2.3.5
+ amd64? ( app-emulation/emul-linux-x86-gtklibs )
+ !amd64? ( x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXcursor
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXtst )
+ >=dev-lang/perl-5
+ !<sys-apps/dbus-0.62"
+
+etcdir="/etc/${PN}"
+ANY_ANY=""
+
+pkg_setup() {
+ vmware_pkg_setup
+ enewgroup "${VMWARE_GROUP}"
+}
+
+src_unpack() {
+ cd "${WORKDIR}"
+ unpack ${A}
+ unpack ./${MY_P}.tar.gz
+}
+
+src_install() {
+ echo 'libdir = "'${VMWARE_INSTALL_DIR}'/lib"' > etc/config
+ vmware_src_install
+
+ # Fix an ugly GCC error on start
+ rm -f "${D}${VMWARE_INSTALL_DIR}/lib/lib/libgcc_s.so.1/libgcc_s.so.1"
+ make_desktop_entry ${PN} "VMWare Remote Console" ${PN}.png System
+
+ dodir /usr/bin
+ dosym ${VMWARE_INSTALL_DIR}/bin/${PN} /usr/bin/${PN}
+}
+
+pkg_config() {
+ einfo "Running ${ROOT}${dir}/bin/vmware-config-server-console.pl"
+ "${ROOT}${dir}/bin/vmware-config-server-console.pl"
+}