summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2012-04-05 07:44:41 +0000
committerLars Wendler <polynomial-c@gentoo.org>2012-04-05 07:44:41 +0000
commit7b233d582fb81a1aaa336d6eaa85cacc4be1dd48 (patch)
treea652e8b5997e3e8e114757bc365d5d7d3bc0d916 /app-emulation/virtualbox
parentmarked x86 per bug 409879 (diff)
downloadgentoo-2-7b233d582fb81a1aaa336d6eaa85cacc4be1dd48.tar.gz
gentoo-2-7b233d582fb81a1aaa336d6eaa85cacc4be1dd48.tar.bz2
gentoo-2-7b233d582fb81a1aaa336d6eaa85cacc4be1dd48.zip
Version bump (bug #410811). Removed old
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/virtualbox')
-rw-r--r--app-emulation/virtualbox/ChangeLog8
-rw-r--r--app-emulation/virtualbox/virtualbox-4.1.10.ebuild4
-rw-r--r--app-emulation/virtualbox/virtualbox-4.1.12.ebuild (renamed from app-emulation/virtualbox/virtualbox-4.1.6-r1.ebuild)39
3 files changed, 29 insertions, 22 deletions
diff --git a/app-emulation/virtualbox/ChangeLog b/app-emulation/virtualbox/ChangeLog
index f91d5bf87f60..ddd666db3f48 100644
--- a/app-emulation/virtualbox/ChangeLog
+++ b/app-emulation/virtualbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/virtualbox
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/ChangeLog,v 1.103 2012/03/23 20:18:07 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/ChangeLog,v 1.104 2012/04/05 07:44:41 polynomial-c Exp $
+
+*virtualbox-4.1.12 (05 Apr 2012)
+
+ 05 Apr 2012; Lars Wendler <polynomial-c@gentoo.org>
+ -virtualbox-4.1.6-r1.ebuild, +virtualbox-4.1.12.ebuild:
+ Version bump (bug #410811). Removed old.
23 Mar 2012; Markos Chandras <hwoarang@gentoo.org>
+files/virtualbox-4.1.10-libgsoapssl.patch, virtualbox-4.1.10.ebuild:
diff --git a/app-emulation/virtualbox/virtualbox-4.1.10.ebuild b/app-emulation/virtualbox/virtualbox-4.1.10.ebuild
index 5982efe53898..d7e6c1f4b6b2 100644
--- a/app-emulation/virtualbox/virtualbox-4.1.10.ebuild
+++ b/app-emulation/virtualbox/virtualbox-4.1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.1.10.ebuild,v 1.2 2012/03/23 20:18:07 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.1.10.ebuild,v 1.3 2012/04/05 07:44:41 polynomial-c Exp $
EAPI=4
@@ -182,7 +182,7 @@ src_prepare() {
# Link to correct gsoap library. Bug #408569
# This has been fixed upstream and should be removed when virtualbox is
# bumped
- epatch ${FILESDIR}/${P}-libgsoapssl.patch
+ epatch "${FILESDIR}"/${P}-libgsoapssl.patch
}
src_configure() {
diff --git a/app-emulation/virtualbox/virtualbox-4.1.6-r1.ebuild b/app-emulation/virtualbox/virtualbox-4.1.12.ebuild
index 87d1699ba8f5..d627acb8c3f6 100644
--- a/app-emulation/virtualbox/virtualbox-4.1.6-r1.ebuild
+++ b/app-emulation/virtualbox/virtualbox-4.1.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.1.6-r1.ebuild,v 1.3 2011/12/20 13:14:14 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.1.12.ebuild,v 1.1 2012/04/05 07:44:41 polynomial-c Exp $
EAPI=4
@@ -13,7 +13,7 @@ if [[ ${PV} == "9999" ]] ; then
else
MY_P=VirtualBox-${PV}
SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
- S="${WORKDIR}/${MY_P}_OSE"
+ S="${WORKDIR}/${MY_P}"
fi
DESCRIPTION="Family of powerful x86 virtualization products for enterprise as well as home use"
@@ -48,7 +48,7 @@ RDEPEND="!app-emulation/virtualbox-bin
media-libs/libsdl[X,video]
)
vnc? ( >=net-libs/libvncserver-0.9.7 )
- java? ( >=virtual/jre-1.5 )"
+ java? ( virtual/jre:1.6 )"
DEPEND="${RDEPEND}
>=dev-util/kbuild-0.1.999
>=dev-lang/yasm-0.6.2
@@ -66,7 +66,7 @@ DEPEND="${RDEPEND}
dev-texlive/texlive-fontsrecommended
dev-texlive/texlive-fontsextra
)
- java? ( >=virtual/jdk-1.5 )
+ java? ( virtual/jdk:1.6 )
dev-util/pkgconfig
alsa? ( >=media-libs/alsa-lib-1.0.13 )
!headless? ( x11-libs/libXinerama )
@@ -116,15 +116,6 @@ REQUIRED_USE="
"
pkg_setup() {
- if built_with_use sys-devel/gcc hardened && gcc-config -c | grep -qv -E "hardenednopie|vanilla"; then
- eerror "The PIE feature provided by the \"hardened\" compiler is incompatible with ${PF}."
- eerror "You must use gcc-config to select a profile without this feature. You may"
- eerror "choose either \"hardenednopie\", \"hardenednopiessp\" or \"vanilla\" profile;"
- eerror "however, \"hardenednopie\" is preferred because it gives the most hardening."
- eerror "Remember to run \"source /etc/profile\" before continuing. See bug #339914."
- die
- fi
-
if ! use headless && ! use qt4 ; then
einfo "No USE=\"qt4\" selected, this build will not include"
einfo "any Qt frontend."
@@ -168,9 +159,6 @@ src_prepare() {
# Don't build vboxpci.ko module (D'oh!)
epatch "${FILESDIR}"/${PN}-4.1.2-vboxpci-build.patch
- # Fixed compilation with yasm-1.2.0 (bug #391189)
- epatch "${FILESDIR}"/${P}-yasm120-fix.patch
-
# Use PAM only when pam USE flag is enbaled (bug #376531)
if ! use pam ; then
elog "Disabling PAM removes the possibility to use the VRDP features."
@@ -185,6 +173,11 @@ src_prepare() {
-i "${S}"/Config.kmk || die
java-pkg-opt-2_src_prepare
fi
+
+ # Fix compile error on hardened bug 339914 (disable PIE)
+ if gcc-specs-pie ; then
+ epatch "${FILESDIR}"/virtualbox_nopie.patch
+ fi
}
src_configure() {
@@ -220,7 +213,7 @@ src_compile() {
# strip-flags
MAKE="kmk" emake \
- VBOX_VERSION_STRING='$(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)'-Gentoo_ \
+ VBOX_VERSION_STRING='$(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)'_Gentoo_ \
TOOL_GCC3_CC="$(tc-getCC)" TOOL_GCC3_CXX="$(tc-getCXX)" \
TOOL_GCC3_AS="$(tc-getCC)" TOOL_GCC3_AR="$(tc-getAR)" \
TOOL_GCC3_LD="$(tc-getCXX)" TOOL_GCC3_LD_SYSMOD="$(tc-getLD)" \
@@ -306,7 +299,14 @@ src_install() {
newmenu "${FILESDIR}"/${PN}-ose.desktop-2 ${PN}.desktop
fi
- newicon "${S}"/src/VBox/Frontends/VirtualBox/images/OSE/VirtualBox_32px.png ${PN}.png
+ pushd "${S}"/src/VBox/Resources/OSE &>/dev/null || die
+ for size in 16 20 32 40 48 64 128 ; do
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
+ newins ${PN}-${size}px.png ${PN}.png
+ done
+ insinto /usr/share/pixmaps
+ newins ${PN}-48px.png ${PN}.png
+ popd &>/dev/null || die
else
doins VBoxHeadless || die
fowners root:vboxusers /usr/$(get_libdir)/${PN}/VBoxHeadless
@@ -314,6 +314,7 @@ src_install() {
pax-mark -m "${D}"/usr/$(get_libdir)/${PN}/VBoxHeadless
fi
+ insinto /usr/$(get_libdir)/${PN}
# Install EFI Firmware files (bug #320757)
pushd "${S}"/src/VBox/Devices/EFI/FirmwareBin &>/dev/null || die
for fwfile in VBoxEFI{32,64}.fd ; do