summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-02 11:55:44 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-02 11:55:44 +0000
commite3299a8ec1cabafe38cc3caea07f8b421459cadd (patch)
treeb148fb4c5ed59d723c57c5f82176f2dcc7797ce0 /app-emulation/uae
parentDowngrade 4.2_p46-r1 to EAPI 4 per Poly-C's request, as this is an essential ... (diff)
downloadgentoo-2-e3299a8ec1cabafe38cc3caea07f8b421459cadd.tar.gz
gentoo-2-e3299a8ec1cabafe38cc3caea07f8b421459cadd.tar.bz2
gentoo-2-e3299a8ec1cabafe38cc3caea07f8b421459cadd.zip
[QA] Revision bump to 0.8.29-r2. EAPI 5.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-emulation/uae')
-rw-r--r--app-emulation/uae/ChangeLog10
-rw-r--r--app-emulation/uae/uae-0.8.29-r2.ebuild (renamed from app-emulation/uae/uae-0.8.29-r1.ebuild)34
2 files changed, 25 insertions, 19 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index 8c6c7ea0152f..01de5281b88f 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/uae
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.41 2013/02/27 09:15:15 kensington Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.42 2014/04/02 11:55:44 tomwij Exp $
+
+*uae-0.8.29-r2 (02 Apr 2014)
+
+ 02 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +uae-0.8.29-r2.ebuild,
+ -uae-0.8.29-r1.ebuild:
+ [QA] Revision bump to 0.8.29-r2. EAPI 5.
27 Feb 2013; Michael Palimaka <kensington@gentoo.org> -files/split_cpuemu.pl:
Remove unused file wrt bug #340731.
diff --git a/app-emulation/uae/uae-0.8.29-r1.ebuild b/app-emulation/uae/uae-0.8.29-r2.ebuild
index f7cb14784d08..8f0c3b0c758c 100644
--- a/app-emulation/uae/uae-0.8.29-r1.ebuild
+++ b/app-emulation/uae/uae-0.8.29-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.29-r1.ebuild,v 1.3 2011/03/27 10:31:29 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.29-r2.ebuild,v 1.1 2014/04/02 11:55:44 tomwij Exp $
-EAPI="1"
+EAPI="5"
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.amigaemulator.org/pub/uae/sources/develop/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="sdl alsa scsi"
DEPEND="sdl? ( media-libs/libsdl
@@ -27,17 +27,15 @@ DEPEND="sdl? ( media-libs/libsdl
scsi? ( app-cdr/cdrtools )"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/uae-0.8.25-allow_spaces_in_zip_filenames.diff
- epatch "${FILESDIR}"/uae-0.8.25-struct_uae_wrong_fields_name.diff
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.25-allow_spaces_in_zip_filenames.diff
+ epatch "${FILESDIR}"/${PN}-0.8.25-struct_uae_wrong_fields_name.diff
epatch "${FILESDIR}"/${PN}-0.8.26-uae_reset_args.diff
- cp "${FILESDIR}"/sdlgfx.h "${S}"/src
+
+ cp "${FILESDIR}"/sdlgfx.h "${S}"/src || die
}
-src_compile() {
+src_configure() {
# disabling lots of options, cause many code-paths are broken, these should compile,
# if you want/need other options, please test if they work with other combinations
# before opening a bug
@@ -45,15 +43,17 @@ src_compile() {
--without-asciiart --without-sdl-sound --enable-threads \
$(use_with sdl) $(use_with sdl sdl-gfx) \
$(use_with alsa) \
- $(use_enable scsi scsi-device) || die "econf failed"
+ $(use_enable scsi scsi-device)
+}
- emake -j1 || die "emake failed"
+src_compile() {
+ emake -j1
}
src_install() {
- dobin uae readdisk || die
- cp docs/unix/README docs/README.unix
- rm -r docs/{AmigaOS,BeOS,pOS,translated,unix}
+ dobin uae readdisk
+ cp docs/unix/README docs/README.unix || die
+ rm -r docs/{AmigaOS,BeOS,pOS,translated,unix} || die
dodoc docs/*
insinto /usr/share/uae/amiga-tools