summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-04-27 08:09:36 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-04-27 08:09:36 +0000
commit09956ac44d9e842d6dd896ba64d90cca8dbcbad0 (patch)
tree7a2b9c257f9c88a921071fc1d53797cb164b734a /app-emulation/spice/spice-0.8.1.ebuild
parentStable on amd64 wrt bug #364469 (diff)
downloadgentoo-2-09956ac44d9e842d6dd896ba64d90cca8dbcbad0.tar.gz
gentoo-2-09956ac44d9e842d6dd896ba64d90cca8dbcbad0.tar.bz2
gentoo-2-09956ac44d9e842d6dd896ba64d90cca8dbcbad0.zip
Version bump.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/spice/spice-0.8.1.ebuild')
-rw-r--r--app-emulation/spice/spice-0.8.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emulation/spice/spice-0.8.1.ebuild b/app-emulation/spice/spice-0.8.1.ebuild
new file mode 100644
index 000000000000..9897a2df5ae9
--- /dev/null
+++ b/app-emulation/spice/spice-0.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.8.1.ebuild,v 1.1 2011/04/27 08:09:36 dev-zero Exp $
+
+EAPI=4
+
+DESCRIPTION="SPICE server and client."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui static-libs"
+
+RDEPEND=">=app-emulation/spice-protocol-0.8
+ >=x11-libs/pixman-0.17.7
+ media-libs/alsa-lib
+ media-libs/celt:0.5.1
+ dev-libs/openssl
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXfixes
+ virtual/jpeg
+ sys-libs/zlib
+ gui? ( =dev-games/cegui-0.6* )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+# maintainer notes:
+# * opengl support is currently broken
+# * add slirp for tunnel-support
+# * add libcacard for smartcard support
+
+src_configure() {
+ local myconf=""
+ use gui && myconf+="--enable-gui "
+ econf ${myconf} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || rm "${D}"/usr/lib*/*.la
+}