summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-15 01:32:03 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-15 01:32:03 +0000
commitff2b923af89cc08a56ede4b8ccefd6816ddcecf8 (patch)
treed8e4641160de87ec1cb3088846d95378514dcd7f /app-emulation/snes9x
parentnew version, closes bug #4577 (diff)
downloadgentoo-2-ff2b923af89cc08a56ede4b8ccefd6816ddcecf8.tar.gz
gentoo-2-ff2b923af89cc08a56ede4b8ccefd6816ddcecf8.tar.bz2
gentoo-2-ff2b923af89cc08a56ede4b8ccefd6816ddcecf8.zip
Added GCC 3.1 patch
Diffstat (limited to 'app-emulation/snes9x')
-rw-r--r--app-emulation/snes9x/ChangeLog7
-rw-r--r--app-emulation/snes9x/files/snes9x-gcc3.diff24
-rw-r--r--app-emulation/snes9x/snes9x-139-r1.ebuild3
3 files changed, 32 insertions, 2 deletions
diff --git a/app-emulation/snes9x/ChangeLog b/app-emulation/snes9x/ChangeLog
index 962cb344bbd0..0c7467e8047e 100644
--- a/app-emulation/snes9x/ChangeLog
+++ b/app-emulation/snes9x/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-emulation/snes9x
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/ChangeLog,v 1.2 2002/06/24 05:24:04 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/ChangeLog,v 1.3 2002/07/15 01:32:03 rphillips Exp $
*snes-139-r1 (23 Jun 2002)
+ 14 Jul 2002; Ryan Phillips <rphillips@gentoo.org> snes-139-r1.ebuild
+ files/snes9x-gcc3.diff :
+
+ Added GCC 3.1 patch
+
23 Jun 2002; Ryan Phillips <rphillips@gentoo.org> snes-139-r1.ebuild :
Thanks to Per Wigren the ebuild has been updated with X11 support and
diff --git a/app-emulation/snes9x/files/snes9x-gcc3.diff b/app-emulation/snes9x/files/snes9x-gcc3.diff
new file mode 100644
index 000000000000..a8f92da564ed
--- /dev/null
+++ b/app-emulation/snes9x/files/snes9x-gcc3.diff
@@ -0,0 +1,24 @@
+diff -ur release.orig/Makefile.linux release/Makefile.linux
+--- release.orig/Makefile.linux Sun Jul 14 18:24:34 2002
++++ release/Makefile.linux Sun Jul 14 18:24:48 2002
+@@ -102,7 +102,7 @@
+ OPENGLNO_DEPENDS=use_opengl
+ endif
+
+-CCC = gcc
++CCC = g++
+ CC = gcc
+ NASM = nasm
+
+diff -ur release.orig/unix/config.c release/unix/config.c
+--- release.orig/unix/config.c Sun Jul 14 18:24:34 2002
++++ release/unix/config.c Sun Jul 14 18:25:01 2002
+@@ -528,7 +528,7 @@
+ p = find_config_string(config[0], section, name, NULL);
+
+ if (p)
+- return (p->data ? p->data : "");
++ return (p->data ? p->data : (char*) "");
+ else
+ return def;
+ }
diff --git a/app-emulation/snes9x/snes9x-139-r1.ebuild b/app-emulation/snes9x/snes9x-139-r1.ebuild
index 2457ccea8416..ec0a5f852bfe 100644
--- a/app-emulation/snes9x/snes9x-139-r1.ebuild
+++ b/app-emulation/snes9x/snes9x-139-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/snes9x-139-r1.ebuild,v 1.2 2002/07/11 06:30:12 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/snes9x-139-r1.ebuild,v 1.3 2002/07/15 01:32:03 rphillips Exp $
DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
HOMEPAGE="http://www.snes9x.com/"
@@ -14,6 +14,7 @@ DEPEND="dev-lang/nasm
S=${WORKDIR}/release
src_compile() {
+ patch -p1 < ${FILESDIR}/snes9x-gcc3.diff
emake -f Makefile.linux || die
use opengl && ( emake -f Makefile.linux OPENGL=1 clean all || die )
use glide && ( emake -f Makefile.linux GLIDE=1 clean all || die )