summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-01-05 11:23:23 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-01-05 11:23:23 +0000
commitc7f0d2ace57669a9ab3bdfd081bdb6bb7139eb25 (patch)
tree1fa94be195b5e4e0e427e894ee201e79dfb7154e /app-emulation/libguestfs
parentVersion bump. (diff)
downloadgentoo-2-c7f0d2ace57669a9ab3bdfd081bdb6bb7139eb25.tar.gz
gentoo-2-c7f0d2ace57669a9ab3bdfd081bdb6bb7139eb25.tar.bz2
gentoo-2-c7f0d2ace57669a9ab3bdfd081bdb6bb7139eb25.zip
Bump to 1.8.16, thanks to slepnoga
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/libguestfs')
-rw-r--r--app-emulation/libguestfs/ChangeLog12
-rw-r--r--app-emulation/libguestfs/files/1.8/1.8.16/0001-configure_ac_automagic_patch.patch102
-rw-r--r--app-emulation/libguestfs/files/1.8/1.8.16/0002-disable_php_in_makefile.patch26
-rw-r--r--app-emulation/libguestfs/files/1.8/1.8.16/0003-hivex_to_hard_error.patch19
-rw-r--r--app-emulation/libguestfs/libguestfs-1.8.16.ebuild211
5 files changed, 368 insertions, 2 deletions
diff --git a/app-emulation/libguestfs/ChangeLog b/app-emulation/libguestfs/ChangeLog
index 5241dd113a97..8a4175edd5ee 100644
--- a/app-emulation/libguestfs/ChangeLog
+++ b/app-emulation/libguestfs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/libguestfs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs/ChangeLog,v 1.1 2011/12/11 19:34:22 maksbotan Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs/ChangeLog,v 1.2 2012/01/05 11:23:23 maksbotan Exp $
+
+*libguestfs-1.8.16 (05 Jan 2012)
+
+ 05 Jan 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/1.8/1.8.16/0001-configure_ac_automagic_patch.patch,
+ +files/1.8/1.8.16/0002-disable_php_in_makefile.patch,
+ +files/1.8/1.8.16/0003-hivex_to_hard_error.patch, +libguestfs-1.8.16.ebuild:
+ Bump to 1.8.16, thanks to slepnoga
*libguestfs-1.8.15 (11 Dec 2011)
diff --git a/app-emulation/libguestfs/files/1.8/1.8.16/0001-configure_ac_automagic_patch.patch b/app-emulation/libguestfs/files/1.8/1.8.16/0001-configure_ac_automagic_patch.patch
new file mode 100644
index 000000000000..e9103c6d4422
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.8/1.8.16/0001-configure_ac_automagic_patch.patch
@@ -0,0 +1,102 @@
+# HG changeset patch
+# User Andreis Vinogradovs <spamslepnoga@inbox.ru>
+# Date 1325421041 -7200
+# Node ID ba14909c0a95bf9879e6df25d8128d1cf9a75252
+# Parent c9bc634a526984160a40b70f71895de0a855f4c0
+configure_ac_automagic.patch
+
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -217,6 +217,10 @@
+ if test -f /etc/arch-release; then
+ DISTRO=ARCHLINUX
+ fi
++ dnl Slepnoga for Gentoo
++ if test -f /etc/gentoo-release; then
++ DISTRO=GENTOO
++ fi
+ AC_MSG_RESULT([$DISTRO])
+ AC_SUBST([DISTRO])
+ fi
+@@ -461,7 +465,7 @@
+ AC_DEFINE([HAVE_LIBMAGIC],[1],[libmagic found at compile time.])
+ ], [])
+ ],
+- [AC_MSG_WARN([libmagic not found, some core features will be disabled])])
++ [AC_MSG_FAILURE([libmagic not found, some core features will be disabled])])
+
+ dnl Check for PCRE (highly recommended)
+ PKG_CHECK_MODULES([PCRE], [libpcre],
+@@ -469,7 +473,7 @@
+ AC_SUBST([PCRE_LIBS])
+ AC_DEFINE([HAVE_PCRE],[1],[PCRE found at compile time.])
+ ],
+- [AC_MSG_WARN([PCRE not found, some core features will be disabled])])
++ [AC_MSG_FAILURE([PCRE not found, some core features will be disabled])])
+
+ dnl libvirt (highly recommended)
+ PKG_CHECK_MODULES([LIBVIRT], [libvirt],
+@@ -486,7 +490,7 @@
+ AC_SUBST([LIBXML2_LIBS])
+ AC_DEFINE([HAVE_LIBXML2],[1],[libxml2 found at compile time.])
+ ],
+- [AC_MSG_WARN([libxml2 not found, some core features will be disabled])])
++ [AC_MSG_FAILURE([libxml2 not found, some core features will be disabled])])
+ AM_CONDITIONAL([HAVE_LIBXML2],[test "x$LIBXML2_LIBS" != "x"])
+
+ dnl hivex library (highly recommended)
+@@ -654,13 +658,13 @@
+ AM_CONDITIONAL([HAVE_RUBY],
+ [test "x$RAKE" != "xno" && test -n "$HAVE_LIBRUBY"])
+
+-dnl Check for Java.
+-AC_ARG_WITH(java_home,
+- [AS_HELP_STRING([--with-java-home],
+- [specify path to JDK directory @<:@default=check@:>@])],
+- [],
+- [with_java_home=check])
++AC_ARG_ENABLE([java],
++ AS_HELP_STRING([--enable-java], [Disable Java language bindings]),
++ [enable_java=no],
++ [enable_java=yes])
+
++AS_IF([test "x$enable_java" = "xyes"],
++ [
+ if test "x$with_java_home" != "xno"; then
+ if test "x$with_java_home" != "xyes" && test "x$with_java_home" != "xcheck"
+ then
+@@ -756,7 +760,6 @@
+ fi
+ fi
+ AC_MSG_RESULT([$JNI_CFLAGS])
+-
+ dnl Need extra version flag?
+ AC_MSG_CHECKING([extra javac flags])
+ JAVAC_FLAGS=
+@@ -791,8 +794,8 @@
+ AC_SUBST(JAR_INSTALL_DIR)
+ AC_SUBST(JNI_INSTALL_DIR)
+ AC_SUBST(JNI_VERSION_INFO)
+-
+-AM_CONDITIONAL([HAVE_JAVA],[test -n "$JAVAC"])
++])
++AM_CONDITIONAL([HAVE_JAVA],[test -n "$JAVAC" && test "x$enable_java" != "xno"])
+
+ dnl Check for Haskell (GHC).
+ GHC=no
+@@ -849,8 +852,12 @@
+
+ dnl Replace libtool with a wrapper that clobbers dependency_libs in *.la files
+ dnl http://lists.fedoraproject.org/pipermail/devel/2010-November/146343.html
+-LIBTOOL='bash $(top_srcdir)/libtool-kill-dependency_libs.sh $(top_builddir)/libtool'
+-AC_SUBST([LIBTOOL])
++dnl ha-ha, criocamera :) - gentoo kill la files in other way's
++dnlLIBTOOL='$(SHELL) $(top_srcdir)/libtool-kill-dependency_libs.sh $(top_builddir)/libtool'
++dnl haha, are stub
++dnl AC_PROG_LIBTOOL
++dnl AC_SUBST([LIBTOOL])
++LT_INIT
+
+ dnl Run in subdirs.
+ if test "x$enable_daemon" = "xyes"; then
diff --git a/app-emulation/libguestfs/files/1.8/1.8.16/0002-disable_php_in_makefile.patch b/app-emulation/libguestfs/files/1.8/1.8.16/0002-disable_php_in_makefile.patch
new file mode 100644
index 000000000000..7a83b5a64ec0
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.8/1.8.16/0002-disable_php_in_makefile.patch
@@ -0,0 +1,26 @@
+# HG changeset patch
+# User Andreis Vinogradovs <spamslepnoga@inbox.ru>
+# Date 1325421062 -7200
+# Node ID 8d969d9324fa8f1f5384037627d5478e33be5d47
+# Parent ba14909c0a95bf9879e6df25d8128d1cf9a75252
+disable_php_in_makefile
+
+diff --git a/Makefile.am b/Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -57,9 +57,12 @@
+ if HAVE_HASKELL
+ SUBDIRS += haskell
+ endif
+-if HAVE_PHP
+-SUBDIRS += php
+-endif
++
++# use Gentoo way to compile/install php extension
++# due slot system
++#if HAVE_PHP
++#SUBDIRS += php
++#endif
+
+ # Unconditional because nothing is built yet.
+ SUBDIRS += csharp
diff --git a/app-emulation/libguestfs/files/1.8/1.8.16/0003-hivex_to_hard_error.patch b/app-emulation/libguestfs/files/1.8/1.8.16/0003-hivex_to_hard_error.patch
new file mode 100644
index 000000000000..1d3dcc628044
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.8/1.8.16/0003-hivex_to_hard_error.patch
@@ -0,0 +1,19 @@
+# HG changeset patch
+# User Andreis Vinogradovs <spamslepnoga@inbox.ru>
+# Date 1325421826 -7200
+# Node ID 4bcdef3cca5c867d82c72d4b394b866a3b9f2d95
+# Parent 8d969d9324fa8f1f5384037627d5478e33be5d47
+hivex to hard error
+
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -501,7 +501,7 @@
+ AC_SUBST([HIVEX_LIBS])
+ AC_DEFINE([HAVE_HIVEX],[1],[hivex library found at compile time.])
+ ],
+- [AC_MSG_WARN([hivex not found, some core features will be disabled])])
++ [AC_MSG_ERROR([hivex not found, some core features will be disabled])])
+
+ dnl FUSE is optional to build the FUSE module.
+ AC_ARG_ENABLE([fuse],
diff --git a/app-emulation/libguestfs/libguestfs-1.8.16.ebuild b/app-emulation/libguestfs/libguestfs-1.8.16.ebuild
new file mode 100644
index 000000000000..2e3d3e99d890
--- /dev/null
+++ b/app-emulation/libguestfs/libguestfs-1.8.16.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs/libguestfs-1.8.16.ebuild,v 1.1 2012/01/05 11:23:23 maksbotan Exp $
+
+EAPI="3"
+
+WANT_AUTOMAKE="1.11"
+
+JAVA_PKG_OPT_USE="java"
+JAVA_PKG_ALLOW_VM_CHANGE="yes"
+APLANCE_PV="1.7.18"
+PYTHON_DEPEND="python? 2:2.6"
+USE_RUBY="ruby18"
+RUBY_OPTIONAL="yes"
+PHP_EXT_NAME="guestfs_php"
+USE_PHP="php5-3 php5-4"
+PHP_EXT_OPTIONAL_USE="php"
+
+inherit autotools bash-completion-r1 confutils versionator java-pkg-opt-2 perl-module python ruby-ng php-ext-source-r2 ghc-package
+
+MY_PV_1="$(get_version_component_range 1-2)"
+MY_PV_2="$(get_version_component_range 2)"
+
+[[ $(( $(get_version_component_range 2) % 2 )) -eq 0 ]] && SD="stable" || SD="development"
+
+DESCRIPTION="Library for accessing and modifying virtual machine (VM) disk images"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/${MY_PV_1}-${SD}/${P}.tar.gz
+ http://rion-overlay.googlecode.com/files/${PN}-${APLANCE_PV}-x86_64.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Upstream NOT supported 32-bit version, keyword in own risk
+KEYWORDS="~amd64"
+IUSE="fuse +ocaml perl python ruby haskell +readline nls php debug doc nls source javadoc"
+
+COMMON_DEPEND="
+ virtual/perl-Getopt-Long
+ >=dev-perl/Sys-Virt-0.2.4
+ >=app-misc/hivex-1.2.1[perl]
+ dev-perl/libintl-perl
+ dev-perl/String-ShellQuote
+ dev-libs/libpcre
+ app-arch/cpio
+ dev-lang/perl
+ app-cdr/cdrkit
+ >=app-emulation/qemu-kvm-0.13[qemu_user_targets_x86_64,qemu_softmmu_targets_x86_64]
+ sys-apps/fakeroot
+ sys-apps/file
+ app-emulation/libvirt
+ dev-libs/libxml2:2
+ >=sys-apps/fakechroot-2.8
+ >=app-admin/augeas-0.7.1
+ sys-fs/squashfs-tools
+ perl? ( virtual/perl-ExtUtils-MakeMaker )
+ fuse? ( sys-fs/fuse )
+ readline? ( sys-libs/readline )
+ doc? ( dev-libs/libxml2 )
+ ocaml? ( dev-lang/ocaml
+ dev-ml/findlib
+ dev-ml/xml-light )
+ ruby? ( dev-lang/ruby
+ dev-ruby/rake )
+ java? ( virtual/jre )
+ haskell? ( dev-lang/ghc )"
+
+DEPEND="${COMMON_DEPEND}
+ java? ( >=virtual/jdk-1.6
+ source? ( app-arch/zip ) )
+ doc? ( app-text/po4a )"
+RDEPEND="${COMMON_DEPEND}
+ java? ( >=virtual/jre-1.6 )"
+
+PHP_EXT_S="${S}/php/extension"
+
+pkg_setup() {
+ use java && java-pkg-opt-2_pkg_setup
+
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ python_need_rebuild
+ fi
+
+ confutils_use_depend_all source java
+ confutils_use_depend_all javadoc java
+
+ use ruby && ruby-ng_pkg_setup
+ use haskell && ghc-package_pkg_setup
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd "${WORKDIR}"
+ mkdir image || die
+ cd image || die
+ unpack libguestfs-${APLANCE_PV}-x86_64.tar.gz
+ cp "${WORKDIR}"/image/usr/local/lib/guestfs/* "${S}"/appliance/ || die
+
+ # part of php-ext-source-r2_src_unpack
+ # whole version cannot be called here as it will attempt to unpack ${A}
+ if use php; then
+ local slot orig_s="${PHP_EXT_S}"
+ for slot in $(php_get_slots); do
+ cp -r "${orig_s}" "${WORKDIR}/${slot}" || die
+ done
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/1.8/${PV}"/000*.patch
+
+ use java && java-pkg-opt-2_src_prepare
+ eautoreconf
+
+ if use php; then
+ php-ext-source-r2_src_prepare
+ fi
+}
+
+src_configure() {
+
+ # Disable feature test for kvm for more reason
+ # i.e: not loaded module in __build__ time,
+ # build server not supported kvm, etc. ...
+ #
+ # In fact, this feature is virtio support and requires
+ # configured kernel.
+ export vmchannel_test=no
+
+ econf \
+ --with-repo=fedora-12 \
+ --disable-appliance \
+ --disable-daemon \
+ --with-drive-if=virtio \
+ --with-net-if=virtio-net-pci \
+ --disable-rpath \
+ $(use_enable java) \
+ $(use_enable nls) \
+ $(use_with readline) \
+ $(use_enable ocaml ocaml-viewer) \
+ $(use_enable perl) \
+ $(use_enable fuse) \
+ $(use_enable ocaml) \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable haskell) \
+ $(use_with doc po4a)
+
+ if use php; then
+ php-ext-source-r2_src_configure
+ fi
+}
+
+src_compile() {
+ emake || die
+
+ if use php; then
+ php-ext-source-r2_src_compile
+ fi
+}
+
+src_test() {
+ emake -j1 check || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+
+ dodoc BUGS HACKING README RELEASE-NOTES TODO
+
+ dobashcomp "${D}/etc"/bash_completion.d/guestfish-bash-completion.sh
+
+ rm -fr "${D}/etc"/bash* || die
+
+ insinto /usr/$(get_libdir)/guestfs/
+ doins "${WORKDIR}/image/usr/local/lib/"guestfs/*
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+ if use java; then
+ java-pkg_newjar java/${P}.jar ${PN},jar
+ rm -fr "${D}/usr"/share/java
+ rm -fr "${D}/usr"/share/javadoc
+ if use source;then
+ java-pkg_dosrc java/com/redhat/et/libguestfs/*
+ fi
+ if use javadoc;then
+ java-pkg_dojavadoc java/api
+ fi
+ fi
+
+ use perl && fixlocalpod
+ python_clean_installation_image -q
+
+ if use php; then
+ php-ext-source-r2_src_install
+ fi
+}
+
+pkg_preinst() {
+ use java && java-pkg-opt-2_pkg_preinst
+}
+
+pkg_postinst() {
+ use haskell && ghc-package_pkg_postinst
+}
+
+pkg_prerm() {
+ use haskell && ghc-package_pkg_prerm
+}