summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-23 03:08:58 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-23 03:08:58 +0000
commitaee3cbeef55092ba2163f48fd39044975bdc95fe (patch)
tree5b2f2f0fbc28a057829f9a08b286582067afef22 /app-emulation/ies4linux
parentStable on mips, per #167391. (diff)
downloadgentoo-2-aee3cbeef55092ba2163f48fd39044975bdc95fe.tar.gz
gentoo-2-aee3cbeef55092ba2163f48fd39044975bdc95fe.tar.bz2
gentoo-2-aee3cbeef55092ba2163f48fd39044975bdc95fe.zip
app-emulation/ies4linux: added 2.5_beta6 version for testing purposes {fixing bug #182855)
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-emulation/ies4linux')
-rw-r--r--app-emulation/ies4linux/ChangeLog9
-rw-r--r--app-emulation/ies4linux/files/digest-ies4linux-2.5_beta63
-rw-r--r--app-emulation/ies4linux/files/ies4linux-2.5_beta6-Installation_directory_discovery.patch13
-rw-r--r--app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild124
4 files changed, 148 insertions, 1 deletions
diff --git a/app-emulation/ies4linux/ChangeLog b/app-emulation/ies4linux/ChangeLog
index d292abca3aea..1befc216ae6d 100644
--- a/app-emulation/ies4linux/ChangeLog
+++ b/app-emulation/ies4linux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/ies4linux
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ies4linux/ChangeLog,v 1.1 2007/06/21 18:34:07 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ies4linux/ChangeLog,v 1.2 2007/06/23 03:08:57 jurek Exp $
+
+*ies4linux-2.5_beta6 (23 Jun 2007)
+
+ 23 Jun 2007; Jurek Bartuszek <jurek@gentoo.org>
+ +files/ies4linux-2.5_beta6-Installation_directory_discovery.patch,
+ +ies4linux-2.5_beta6.ebuild:
+ Added 2.5_beta6 version for testing purposes {fixing bug #182855)
*ies4linux-2.0.5 (21 Jun 2007)
diff --git a/app-emulation/ies4linux/files/digest-ies4linux-2.5_beta6 b/app-emulation/ies4linux/files/digest-ies4linux-2.5_beta6
new file mode 100644
index 000000000000..dd32f0782e5a
--- /dev/null
+++ b/app-emulation/ies4linux/files/digest-ies4linux-2.5_beta6
@@ -0,0 +1,3 @@
+MD5 9d2362c998372a6a59553e867e7712a6 ies4linux-2.5beta6.tar.gz 324934
+RMD160 6f487255687671625c6cbefdf62ea79caf391000 ies4linux-2.5beta6.tar.gz 324934
+SHA256 0fc553e5e98bd95ce211903e526737a1101cb31194224d7ecef4982f2e0e863f ies4linux-2.5beta6.tar.gz 324934
diff --git a/app-emulation/ies4linux/files/ies4linux-2.5_beta6-Installation_directory_discovery.patch b/app-emulation/ies4linux/files/ies4linux-2.5_beta6-Installation_directory_discovery.patch
new file mode 100644
index 000000000000..e2b0a5279c31
--- /dev/null
+++ b/app-emulation/ies4linux/files/ies4linux-2.5_beta6-Installation_directory_discovery.patch
@@ -0,0 +1,13 @@
+diff -u -r ies4linux-2.5beta6-orig/ies4linux ies4linux-2.5beta6/ies4linux
+--- ies4linux-2.5beta6-orig/ies4linux 2007-02-22 10:04:16.000000000 +0100
++++ ies4linux-2.5beta6/ies4linux 2007-06-22 01:38:10.000000000 +0200
+@@ -7,7 +7,8 @@
+ # Released under the GNU GPL. See LICENSE for more information
+
+ # Discover ies4linux installation folder
+-IES4LINUX=`dirname "$0"`
++IES4LINUX_RELPATH="$(test -L $0 && echo $(readlink $0) || echo $0)"
++IES4LINUX="$(dirname $IES4LINUX_RELPATH)"
+ cd "$IES4LINUX"
+ export IES4LINUX=`pwd`
+
diff --git a/app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild b/app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild
new file mode 100644
index 000000000000..c5266e9fd4db
--- /dev/null
+++ b/app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild,v 1.1 2007/06/23 03:08:57 jurek Exp $
+
+inherit eutils versionator
+
+MY_PV="$(replace_version_separator 2 '')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Installer for Microsoft Internet Explorer"
+HOMEPAGE="http://www.ies4linux.org/"
+SRC_URI="http://www.ies4linux.org/downloads/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gtk kde"
+
+DEPEND=">=app-arch/cabextract-1.0
+ >=app-emulation/wine-0.9.0"
+
+RDEPEND="${DEPEND}
+ gtk? ( dev-python/pygtk
+ >=dev-lang/python-2.4 )
+ kde? ( kde-base/kommander )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+
+ unpack "${A}"
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-Installation_directory_discovery.patch" || die "epatch failed"
+}
+
+src_install() {
+
+ INS_BASE_PATH="/usr/lib/${PN}"
+
+ # Main executable script
+
+ insinto "${INS_BASE_PATH}"
+
+ insopts -m0755
+ doins "${PN}" || die "doins failed"
+
+ dosym "${INS_BASE_PATH}/${PN}" "/usr/bin/${PN}" || die "dosym failed"
+
+ # Main libraries
+
+ insinto "${INS_BASE_PATH}/lib"
+
+ insopts -m0644
+ ( doins "lib/files" &&
+ doins "lib/${PN}.svg" &&
+ doins "lib/messages.txt"
+ ) || die "doins failed"
+
+ insopts -m0755
+ ( doins "lib/"*.sh &&
+ doins "lib/xdg-desktop-icon" &&
+ doins "lib/xdg-desktop-menu"
+ ) || die "doins failed"
+
+ # Localization libraries
+
+ insinto "${INS_BASE_PATH}/lang"
+
+ insopts -m0644
+ doins "lang/"*.sh || die "doins failed"
+
+ # Windows registry files
+
+ insinto "${INS_BASE_PATH}/winereg"
+
+ insopts -m0644
+ doins "winereg/"*.reg || die "doins failed"
+
+ # Graphical installers
+
+ insopts -m0644
+
+ insinto "${INS_BASE_PATH}/ui/kommander"
+ ( doins "ui/kommander/"*.kmdr &&
+ doins "ui/kommander/"*.sh
+ ) || die "doins failed"
+
+ insinto "${INS_BASE_PATH}/ui/pygtk"
+ ( doins "ui/pygtk/"*.py &&
+ doins "ui/pygtk/"*.sh
+ ) || die "doins failed"
+
+ # Documentation
+
+ dodoc "README" || die "dodoc failed"
+}
+
+pkg_postinst() {
+
+ elog
+ elog "IEs4Linux is an installer for Microsoft Internet Explorer."
+ elog "You just emerged the installer, you now have to run \`${PN}\`,"
+ elog "as a normal user, to actually install Microsoft Internet Explorer."
+ elog
+
+ use gtk && (
+ elog "To use the PyGTK installer interface, start IEs4Linux"
+ elog "with the \"--gui gtk\" option."
+ elog
+ )
+
+ use kde && (
+ elog "To use the KDE Kommander installer interface, start IEs4Linux"
+ elog "with the \"--gui kommander\" option."
+ elog
+ )
+
+ elog "Do note that, while IEs4Linux itself, is licensed under the GPL-2,"
+ elog "it is only an installer for Microsoft Internet Explorer. You must own"
+ elog "a Microsoft Windows license, and agree to the Internet Explorer license,"
+ elog "to install any version of Microsoft Internet Explorer."
+ elog
+}