summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-11 09:29:40 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-11 09:29:40 +0000
commit522fbb3159fa78c27ce1e9333bc8fb5d72916f62 (patch)
tree9b976f34cc862d1068ca97a008dbb0642d754787 /app-emulation/hercules/hercules-3.06.ebuild
parentFix typo in snmp subdir munging #253344. (diff)
downloadgentoo-2-522fbb3159fa78c27ce1e9333bc8fb5d72916f62.tar.gz
gentoo-2-522fbb3159fa78c27ce1e9333bc8fb5d72916f62.tar.bz2
gentoo-2-522fbb3159fa78c27ce1e9333bc8fb5d72916f62.zip
restore USE=custom-cflags
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-emulation/hercules/hercules-3.06.ebuild')
-rw-r--r--app-emulation/hercules/hercules-3.06.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-emulation/hercules/hercules-3.06.ebuild b/app-emulation/hercules/hercules-3.06.ebuild
index 322d51036a99..dd55240e4276 100644
--- a/app-emulation/hercules/hercules-3.06.ebuild
+++ b/app-emulation/hercules/hercules-3.06.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.06.ebuild,v 1.1 2009/01/11 08:36:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.06.ebuild,v 1.2 2009/01/11 09:29:40 vapier Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
HOMEPAGE="http://www.hercules-390.org/"
@@ -11,7 +11,7 @@ SRC_URI="http://www.hercules-390.org/${P}.tar.gz"
LICENSE="QPL-1.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE=""
+IUSE="custom-cflags"
src_unpack() {
unpack ${A}
@@ -27,12 +27,12 @@ src_unpack() {
}
src_compile() {
+ use custom-cflags || strip-flags
econf \
--enable-cckd-bzip2 \
--enable-het-bzip2 \
--enable-setuid-hercifc \
--enable-custom="Gentoo Linux ${PF}.ebuild" \
- --disable-optimization \
|| die "econf failed"
emake || die "emake failed"
}