summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-18 23:27:32 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-18 23:27:32 +0000
commitdca0f81799bc2c5bc7c650fe2866e812ce1caa22 (patch)
tree1e9cb8f9db157760a32add4c36927ce34adf4071 /app-emulation/gngb
parentUpstream bugfix patch (#2) applied. (diff)
downloadgentoo-2-dca0f81799bc2c5bc7c650fe2866e812ce1caa22.tar.gz
gentoo-2-dca0f81799bc2c5bc7c650fe2866e812ce1caa22.tar.bz2
gentoo-2-dca0f81799bc2c5bc7c650fe2866e812ce1caa22.zip
new package. Fixes #3815
Diffstat (limited to 'app-emulation/gngb')
-rw-r--r--app-emulation/gngb/ChangeLog13
-rw-r--r--app-emulation/gngb/files/digest-gngb-200201111
-rw-r--r--app-emulation/gngb/gngb-20020111.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/gngb/ChangeLog b/app-emulation/gngb/ChangeLog
new file mode 100644
index 000000000000..55342054b332
--- /dev/null
+++ b/app-emulation/gngb/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/gngb
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gngb/ChangeLog,v 1.1 2002/06/18 23:27:32 rphillips Exp $
+
+*gngb-20020111 (18 Jun 2002)
+
+ 18 Jun 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/gngb/files/digest-gngb-20020111 b/app-emulation/gngb/files/digest-gngb-20020111
new file mode 100644
index 000000000000..dba96e9339d2
--- /dev/null
+++ b/app-emulation/gngb/files/digest-gngb-20020111
@@ -0,0 +1 @@
+MD5 549100377559045cf80d370de6203ba8 gngb-20020111.tar.gz 131251
diff --git a/app-emulation/gngb/gngb-20020111.ebuild b/app-emulation/gngb/gngb-20020111.ebuild
new file mode 100644
index 000000000000..ecde2ab8ce79
--- /dev/null
+++ b/app-emulation/gngb/gngb-20020111.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.8 2002/05/30 01:54:49 sandymac Exp
+
+DESCRIPTION="gngb - Gameboy / Gameboy Color emulator"
+HOMEPAGE="http://members.lycos.fr/frogus/gngb/"
+LICENSE="GPL"
+RDEPEND="media-libs/libsdl
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}"
+SRC_URI="http://membres.lycos.fr/frogus/gngb/download/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ use opengl || myconf=" --with-gl "
+ ./configure ${myconf}\
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ dodoc NEWS README TODO INSTALL AUTHORS
+ make DESTDIR=${D} install || die
+}