summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2007-04-02 21:36:22 +0000
committerHanno Böck <hanno@gentoo.org>2007-04-02 21:36:22 +0000
commitd91cf8f16311e14c519409fac75d81cbf183a73b (patch)
tree142f561c5f0d8018580cf2d5bbc3b226c1d86756 /app-emulation/dosemu
parentgimp-help bump (diff)
downloadgentoo-2-d91cf8f16311e14c519409fac75d81cbf183a73b.tar.gz
gentoo-2-d91cf8f16311e14c519409fac75d81cbf183a73b.tar.bz2
gentoo-2-d91cf8f16311e14c519409fac75d81cbf183a73b.zip
dosemu version bump
(Portage version: 2.1.2.3)
Diffstat (limited to 'app-emulation/dosemu')
-rw-r--r--app-emulation/dosemu/ChangeLog9
-rw-r--r--app-emulation/dosemu/dosemu-1.3.4.ebuild74
-rw-r--r--app-emulation/dosemu/files/digest-dosemu-1.3.46
-rw-r--r--app-emulation/dosemu/files/dosemu-1.3.4-shm.diff11
-rw-r--r--app-emulation/dosemu/files/dosemu-1.3.4-slang2.diff27
-rw-r--r--app-emulation/dosemu/files/dosemu-compile-asm.diff11
6 files changed, 137 insertions, 1 deletions
diff --git a/app-emulation/dosemu/ChangeLog b/app-emulation/dosemu/ChangeLog
index c154f1d900b6..6c69f0a2ea42 100644
--- a/app-emulation/dosemu/ChangeLog
+++ b/app-emulation/dosemu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/dosemu
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.39 2007/02/25 15:27:55 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.40 2007/04/02 21:36:22 hanno Exp $
+
+*dosemu-1.3.4 (02 Apr 2007)
+
+ 02 Apr 2007; Hanno Boeck <hanno@gentoo.org> +files/dosemu-1.3.4-shm.diff,
+ +files/dosemu-1.3.4-slang2.diff, +files/dosemu-compile-asm.diff,
+ +dosemu-1.3.4.ebuild:
+ Version bump and a bunch of fixes.
25 Feb 2007; Samuli Suominen <drac@gentoo.org> dosemu-1.3.3.ebuild:
Remove virtual/x11 usage wrt bug 166370.
diff --git a/app-emulation/dosemu/dosemu-1.3.4.ebuild b/app-emulation/dosemu/dosemu-1.3.4.ebuild
new file mode 100644
index 000000000000..b633f2de208e
--- /dev/null
+++ b/app-emulation/dosemu/dosemu-1.3.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.3.4.ebuild,v 1.1 2007/04/02 21:36:22 hanno Exp $
+
+inherit flag-o-matic eutils autotools
+
+P_FD=dosemu-freedos-b9r5a-bin
+DESCRIPTION="DOS Emulator"
+HOMEPAGE="http://www.dosemu.org/"
+SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
+ mirror://sourceforge/dosemu/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="X svga gpm debug"
+
+RDEPEND="X? (
+ || ( (
+ x11-libs/libXxf86vm
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-proto/xf86dgaproto
+ x11-apps/xset
+ x11-apps/xlsfonts
+ x11-apps/bdftopcf
+ x11-apps/mkfontdir
+ )
+ virtual/x11
+ ) )
+ svga? ( media-libs/svgalib )
+ gpm? ( sys-libs/gpm )
+ >=sys-libs/slang-1.4"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.57"
+
+src_unpack() {
+ unpack ${P}.tgz
+ cd ${S}
+
+ epatch ${FILESDIR}/dosemu-1.3.3-configure.ac.patch
+ epatch ${FILESDIR}/dosemu-1.3.4-shm.diff
+ epatch ${FILESDIR}/dosemu-1.3.4-slang2.diff
+ epatch ${FILESDIR}/dosemu-compile-asm.diff
+
+ eautoreconf || die "autoconf failed"
+}
+
+src_compile() {
+ # Has problems with -O3 on some systems
+ replace-flags -O[3-9] -O2
+
+ # Fix compilation on hardened
+ append-flags -fno-pic
+
+ unset KERNEL
+
+ econf `use_with X x` \
+ `use_enable svga svgalib` \
+ `use_enable debug` \
+ `use_with gpm` \
+ --with-fdtarball=${DISTDIR}/${P_FD}.tgz \
+ --sysconfdir=/etc/dosemu/ \
+ --with-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ # Don't remove COPYING, see bug #137286
+ dodoc Bugs ChangeLog COPYING NEWS THANKS
+}
diff --git a/app-emulation/dosemu/files/digest-dosemu-1.3.4 b/app-emulation/dosemu/files/digest-dosemu-1.3.4
new file mode 100644
index 000000000000..17b268bc267f
--- /dev/null
+++ b/app-emulation/dosemu/files/digest-dosemu-1.3.4
@@ -0,0 +1,6 @@
+MD5 4fbfdc50ea86d860dd9cea59ea7f4b47 dosemu-1.3.4.tgz 2250288
+RMD160 e6509e9499a91351a79e065e68ed9fc2c453a940 dosemu-1.3.4.tgz 2250288
+SHA256 754de8be3ad8720dcc647eb903e681c55976ea06463a75bca3f5ac181a0355dd dosemu-1.3.4.tgz 2250288
+MD5 153ef4f6ab653497836502c9e3e18c3a dosemu-freedos-b9r5a-bin.tgz 1154735
+RMD160 54b2c7c2ca13139b555f6c0318576b9db91875da dosemu-freedos-b9r5a-bin.tgz 1154735
+SHA256 bd143b04add270425f117c5186468914765437c7b9c9c9a44eb0f278798e6850 dosemu-freedos-b9r5a-bin.tgz 1154735
diff --git a/app-emulation/dosemu/files/dosemu-1.3.4-shm.diff b/app-emulation/dosemu/files/dosemu-1.3.4-shm.diff
new file mode 100644
index 000000000000..f0868a988f0b
--- /dev/null
+++ b/app-emulation/dosemu/files/dosemu-1.3.4-shm.diff
@@ -0,0 +1,11 @@
+--- dosemu-1.3.4/etc/dosemu.conf.orig 2007-01-28 22:19:44.000000000 +0100
++++ dosemu-1.3.4/etc/dosemu.conf 2007-01-28 22:19:58.000000000 +0100
+@@ -166,7 +166,7 @@
+ # preferred mapping driver, one of: auto, mapshm, mapashm, mapfile
+ # Default: ""="auto"
+
+-# $_mapping= ""
++$_mapping= "mapshm"
+
+ ##############################################################################
+ ## Debug settings
diff --git a/app-emulation/dosemu/files/dosemu-1.3.4-slang2.diff b/app-emulation/dosemu/files/dosemu-1.3.4-slang2.diff
new file mode 100644
index 000000000000..dbf4a2ac6893
--- /dev/null
+++ b/app-emulation/dosemu/files/dosemu-1.3.4-slang2.diff
@@ -0,0 +1,27 @@
+--- dosemu-1.1.5-old/configure.ac
++++ dosemu-1.1.5/configure.ac
+@@ -262,8 +262,8 @@
+ else
+ if test -d $prefix/include/slang; then
+ SLANGINC="-I${prefix}/include/slang"
+- elif test -d /usr/include/slang; then
+- SLANGINC="-I/usr/include/slang"
++ elif test -d /usr/include/slang-2; then
++ SLANGINC="-I/usr/include/slang-2"
+ fi
+ fi
+ else
+@@ -286,11 +286,11 @@
+ AC_MSG_RESULT($SLANGINC $SLANGLIB)
+ have_slang="no"
+ AC_CHECK_HEADER(slang.h,
+- AC_CHECK_LIB(slang, SLtt_get_terminfo,
++ AC_CHECK_LIB(slang-2, SLtt_get_terminfo,
+ AC_MSG_NOTICE(Compiling with S-Lang support...)
+ have_slang="yes"
+ AC_DEFINE(USE_SLANG)
+- SLANGLIB="$SLANGLIB -lslang -lm",
++ SLANGLIB="$SLANGLIB -lslang-2 -lm",
+ [AC_MSG_WARN([No S-Lang library found.])]
+ $srcdir/mkpluginhooks enable term no
+ ),
diff --git a/app-emulation/dosemu/files/dosemu-compile-asm.diff b/app-emulation/dosemu/files/dosemu-compile-asm.diff
new file mode 100644
index 000000000000..a404d57cf4ab
--- /dev/null
+++ b/app-emulation/dosemu/files/dosemu-compile-asm.diff
@@ -0,0 +1,11 @@
+--- dosemu-1.3.4/src/env/video/instremu.c 2006-11-11 23:22:27.000000000 +0100
++++ dosemu-1.3.4-p/src/env/video/instremu.c 2007-01-30 13:36:08.000000000 +0100
+@@ -112,7 +112,7 @@
+ shr $1, %0\n\
+ "#insn" %4, %1\n\
+ pushf; pop %0\n \
+- " : "=g" (eflags), #istype (op1) : "0" (eflags), "1" (op1), #type (op2));
++ " : "=r" (eflags), #istype (op1) : "0" (eflags), "1" (op1), #type (op2));
+
+
+ #if !defined True