summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-16 01:35:25 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-16 01:35:25 +0000
commitf03c464cba9d6d3207f809ffb1c6f6e7b7983eb7 (patch)
tree4e95887a6d340d6fbc782cc527bed7c8694d838d /app-emulation/daphne
parentadded ppc keyword (diff)
downloadgentoo-2-f03c464cba9d6d3207f809ffb1c6f6e7b7983eb7.tar.gz
gentoo-2-f03c464cba9d6d3207f809ffb1c6f6e7b7983eb7.tar.bz2
gentoo-2-f03c464cba9d6d3207f809ffb1c6f6e7b7983eb7.zip
initial ebuild #18807
Diffstat (limited to 'app-emulation/daphne')
-rw-r--r--app-emulation/daphne/ChangeLog8
-rw-r--r--app-emulation/daphne/Manifest3
-rw-r--r--app-emulation/daphne/daphne-0.99.6.ebuild58
-rw-r--r--app-emulation/daphne/files/digest-daphne-0.99.61
4 files changed, 70 insertions, 0 deletions
diff --git a/app-emulation/daphne/ChangeLog b/app-emulation/daphne/ChangeLog
new file mode 100644
index 000000000000..45d0cfd6e1ce
--- /dev/null
+++ b/app-emulation/daphne/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/daphne
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/daphne/ChangeLog,v 1.1 2003/07/16 01:35:19 vapier Exp $
+
+*daphne-0.99.6 (15 Jul 2003)
+
+ 15 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Andrea Cerrito <cerrito@centromultimediale.it> #18807.
diff --git a/app-emulation/daphne/Manifest b/app-emulation/daphne/Manifest
new file mode 100644
index 000000000000..6e6f326ce8cf
--- /dev/null
+++ b/app-emulation/daphne/Manifest
@@ -0,0 +1,3 @@
+MD5 8c819c5ceafbe235dfa7fb2a35bf84ce files/digest-daphne-0.99.6 70
+MD5 59f2ddcdaa71e4cef603e72c8d5da584 daphne-0.99.6.ebuild 1600
+MD5 ef108c87c654c2330a686adacd4e381a ChangeLog 398
diff --git a/app-emulation/daphne/daphne-0.99.6.ebuild b/app-emulation/daphne/daphne-0.99.6.ebuild
new file mode 100644
index 000000000000..4e9b040a3db7
--- /dev/null
+++ b/app-emulation/daphne/daphne-0.99.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/daphne/daphne-0.99.6.ebuild,v 1.1 2003/07/16 01:35:19 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Laserdisc Arcade Game Emulator"
+SRC_URI="http://www.daphne-emu.com/download/${P}-src.tar.gz"
+HOMEPAGE="http://www.daphne-emu.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND="virtual/glibc
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ sys-libs/zlib"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src
+ sed -e "s:-march=i686:${CFLAGS}:" Makefile.vars.linux_x86 > Makefile.vars
+
+ # lets make this guy play nice with our filesystem setup
+ sed -i "s:pics/:${GAMES_DATADIR}/${PN}/pics/:g" video/video.cpp
+ sed -i "s:roms/:${GAMES_DATADIR}/${PN}/roms/:g" game/game.cpp
+ sed -i "s:sound/:${GAMES_DATADIR}/${PN}/sound/:g" sound/sound.cpp
+ sed -i "s:./lib:${GAMES_LIBDIR}/${PN}/lib:g" io/dll.h
+ sed -i "s:daphne_log.txt:/tmp/daphne_log.txt:g" daphne.cpp daphne.h io/error.cpp
+ sed -i "s:dapinput.ini:~/.dapinput.ini:" io/input.cpp
+}
+
+src_compile() {
+ cd ${S}/src
+ emake || die "src build failed"
+ cd ${S}/src/vldp
+ emake -f Makefile.linux || die "vldp build failed"
+ cd ${S}/src/vldp2
+ egamesconf || die
+ emake -f Makefile.linux || die "vldp2 build failed"
+}
+
+src_install() {
+ dogamesbin daphne
+ exeinto ${GAMES_LIBDIR}/${PN}
+ doexe libvldp*.so
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -rf pics sound roms ${D}/${GAMES_DATADIR}/${PN}/
+ dodoc doc/*.{ini,txt}
+ dohtml -r doc/*
+ prepgamesdirs
+}
diff --git a/app-emulation/daphne/files/digest-daphne-0.99.6 b/app-emulation/daphne/files/digest-daphne-0.99.6
new file mode 100644
index 000000000000..115b93db4360
--- /dev/null
+++ b/app-emulation/daphne/files/digest-daphne-0.99.6
@@ -0,0 +1 @@
+MD5 7602c8c1c7d54f61e23e55fe55b44ffd daphne-0.99.6-src.tar.gz 2685633