summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-01 02:51:37 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-01 02:51:37 +0000
commite8b62424755d8d5e763042b1edf419d61efe5583 (patch)
treec93f081bc04e5a67e18f46f8862f49a0de41783e /app-emulation/crossover-office-pro-bin
parentDont force a52/dts disabling since the pkg no longer offers the options at al... (diff)
downloadgentoo-2-e8b62424755d8d5e763042b1edf419d61efe5583.tar.gz
gentoo-2-e8b62424755d8d5e763042b1edf419d61efe5583.tar.bz2
gentoo-2-e8b62424755d8d5e763042b1edf419d61efe5583.zip
Version bump #342791 by Michiel de Bruijne.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/crossover-office-pro-bin')
-rw-r--r--app-emulation/crossover-office-pro-bin/ChangeLog10
-rw-r--r--app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.2.0.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/app-emulation/crossover-office-pro-bin/ChangeLog b/app-emulation/crossover-office-pro-bin/ChangeLog
index 54990a9452a8..9df4af79b140 100644
--- a/app-emulation/crossover-office-pro-bin/ChangeLog
+++ b/app-emulation/crossover-office-pro-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/crossover-office-pro-bin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/ChangeLog,v 1.19 2010/08/03 18:25:00 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/ChangeLog,v 1.20 2011/03/01 02:51:37 vapier Exp $
+
+*crossover-office-pro-bin-9.2.0 (01 Mar 2011)
+
+ 01 Mar 2011; Mike Frysinger <vapier@gentoo.org>
+ +crossover-office-pro-bin-9.2.0.ebuild:
+ Version bump #342791 by Michiel de Bruijne.
03 Aug 2010; Mike Frysinger <vapier@gentoo.org>
crossover-office-pro-bin-9.1.0.ebuild:
diff --git a/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.2.0.ebuild b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.2.0.ebuild
new file mode 100644
index 000000000000..9f87752385c1
--- /dev/null
+++ b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.2.0.ebuild,v 1.1 2011/03/01 02:51:37 vapier Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="simplified/streamlined version of wine with commercial support"
+HOMEPAGE="http://www.codeweavers.com/products/cxoffice/"
+SRC_URI="install-crossover-pro-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="nas"
+RESTRICT="fetch strip"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ dev-util/desktop-file-utils
+ nas? ( media-libs/nas )
+ amd64? ( app-emulation/emul-linux-x86-xlibs )
+ media-libs/jpeg:62
+ media-libs/libpng:1.2"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins share/crossover/data/cxoffice.conf
+}
+
+pkg_postinst() {
+ elog "Run /opt/cxoffice/bin/cxsetup as normal user to create"
+ elog "bottles and install Windows applications."
+}