summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-06-25 17:38:00 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-06-25 17:38:00 +0000
commitead5445b41e13ca65d53bd851d385f842abf6bf8 (patch)
treedd67ac69148dd5c6257aabee3fbfda27320a6fba /app-emacs/tnt
parentRevision bumps to add support for new Java system. (diff)
downloadgentoo-2-ead5445b41e13ca65d53bd851d385f842abf6bf8.tar.gz
gentoo-2-ead5445b41e13ca65d53bd851d385f842abf6bf8.tar.bz2
gentoo-2-ead5445b41e13ca65d53bd851d385f842abf6bf8.zip
New upstream version.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'app-emacs/tnt')
-rw-r--r--app-emacs/tnt/ChangeLog10
-rw-r--r--app-emacs/tnt/files/51tnt-gentoo.el9
-rw-r--r--app-emacs/tnt/files/digest-tnt-2.63
-rw-r--r--app-emacs/tnt/tnt-2.6.ebuild30
4 files changed, 50 insertions, 2 deletions
diff --git a/app-emacs/tnt/ChangeLog b/app-emacs/tnt/ChangeLog
index fda4cd47b02f..bc8c8c697ba5 100644
--- a/app-emacs/tnt/ChangeLog
+++ b/app-emacs/tnt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/tnt
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/tnt/ChangeLog,v 1.5 2005/08/28 02:27:40 tester Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/tnt/ChangeLog,v 1.6 2006/06/25 17:38:00 mkennedy Exp $
+
+*tnt-2.6 (25 Jun 2006)
+
+ 25 Jun 2006; Matthew Kennedy <mkennedy@gentoo.org> +files/51tnt-gentoo.el,
+ +tnt-2.6.ebuild:
+ New upstream version.
28 Aug 2005; Olivier Crête <tester@gentoo.org> tnt-2.4.ebuild:
Marked ~amd64, thanks to AT AJ Armstrong <aja@gentoo.org> for testing
diff --git a/app-emacs/tnt/files/51tnt-gentoo.el b/app-emacs/tnt/files/51tnt-gentoo.el
new file mode 100644
index 000000000000..78c0af045eca
--- /dev/null
+++ b/app-emacs/tnt/files/51tnt-gentoo.el
@@ -0,0 +1,9 @@
+
+;;; tnt site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'tnt-open "tnt" "Start TNT" t)
+(autoload 'tnt-proxy-switch-servers "tnt" "Switch TNT proxy servers." t)
+(autoload 'tnt-proxy-toggle-proxy-use "tnt" "Toggle use of TNT proxy server." t)
+(autoload 'tnt-customize "tnt" "Customization of the group 'tnt'." t)
diff --git a/app-emacs/tnt/files/digest-tnt-2.6 b/app-emacs/tnt/files/digest-tnt-2.6
new file mode 100644
index 000000000000..e80a042df53d
--- /dev/null
+++ b/app-emacs/tnt/files/digest-tnt-2.6
@@ -0,0 +1,3 @@
+MD5 6c2481d87da5fbf3424caca4f2b5129d tnt-2.6.tar.gz 112490
+RMD160 f698f25813fbb60035fbbbb55a339145cb7bbbbc tnt-2.6.tar.gz 112490
+SHA256 207ee988867537f8707c26503c6c7c9c2f9f818720199a813360d60e66d272eb tnt-2.6.tar.gz 112490
diff --git a/app-emacs/tnt/tnt-2.6.ebuild b/app-emacs/tnt/tnt-2.6.ebuild
new file mode 100644
index 000000000000..00fb16395388
--- /dev/null
+++ b/app-emacs/tnt/tnt-2.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/tnt/tnt-2.6.ebuild,v 1.1 2006/06/25 17:38:00 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Client for the AOL Instant Messenging service using the Emacs text editor as it's UI."
+HOMEPAGE="http://tnt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tnt/${P}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/emacs"
+
+src_compile() {
+ elisp-comp *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install ${FILESDIR}/51tnt-gentoo.el
+ insinto $SITELISP/tnt/sounds
+ doins sounds/*
+ dodoc ChangeLog INSTALL PROTOCOL README
+ insinto /usr/share/doc/${PF}/procmail
+ doins procmail/*
+}