summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-08-15 07:37:56 +0000
committerUlrich Müller <ulm@gentoo.org>2007-08-15 07:37:56 +0000
commit19cafc71bed79b90ab94c4354cd5909fd2896f24 (patch)
tree0df6ee3dd7d966ba6a9848996ad71eb2da1027aa /app-emacs/nxml-mode
parentremove old (diff)
downloadgentoo-2-19cafc71bed79b90ab94c4354cd5909fd2896f24.tar.gz
gentoo-2-19cafc71bed79b90ab94c4354cd5909fd2896f24.tar.bz2
gentoo-2-19cafc71bed79b90ab94c4354cd5909fd2896f24.zip
Fix "range striding over charsets" error; bug #188112.
(Portage version: 2.1.3.5)
Diffstat (limited to 'app-emacs/nxml-mode')
-rw-r--r--app-emacs/nxml-mode/ChangeLog9
-rw-r--r--app-emacs/nxml-mode/files/digest-nxml-mode-20041004-r16
-rw-r--r--app-emacs/nxml-mode/files/xsd-regexp.el.2006-01-26.patch22
-rw-r--r--app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild41
4 files changed, 77 insertions, 1 deletions
diff --git a/app-emacs/nxml-mode/ChangeLog b/app-emacs/nxml-mode/ChangeLog
index 6ad6e94f54ad..165f26a578fe 100644
--- a/app-emacs/nxml-mode/ChangeLog
+++ b/app-emacs/nxml-mode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/nxml-mode
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-mode/ChangeLog,v 1.23 2007/07/02 07:32:10 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-mode/ChangeLog,v 1.24 2007/08/15 07:37:56 ulm Exp $
+
+*nxml-mode-20041004-r1 (15 Aug 2007)
+
+ 15 Aug 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/xsd-regexp.el.2006-01-26.patch, +nxml-mode-20041004-r1.ebuild:
+ Fix "range striding over charsets" error; bug #188112, reported by
+ Martin von Gagern <Martin.vGagern@gmx.net>. Other minor changes.
02 Jul 2007; Christian Faulhammer <opfer@gentoo.org>
nxml-mode-20041004.ebuild:
diff --git a/app-emacs/nxml-mode/files/digest-nxml-mode-20041004-r1 b/app-emacs/nxml-mode/files/digest-nxml-mode-20041004-r1
new file mode 100644
index 000000000000..431875c7937a
--- /dev/null
+++ b/app-emacs/nxml-mode/files/digest-nxml-mode-20041004-r1
@@ -0,0 +1,6 @@
+MD5 d98a6a37ad177f89698561416dc1195c nxml-mode-20040910-xmlschema.patch.gz 9069
+RMD160 59091172e8544cb52fee7d3f44c353fdd6d78584 nxml-mode-20040910-xmlschema.patch.gz 9069
+SHA256 66be83896133c7d7e2debd275edb90527b87425bd8c05cf415c905520bc04914 nxml-mode-20040910-xmlschema.patch.gz 9069
+MD5 ac137024cf337d6f11d8ab278d39b4db nxml-mode-20041004.tar.gz 443020
+RMD160 37188e12507eea2b24c6ad99c4930c8fe0660e79 nxml-mode-20041004.tar.gz 443020
+SHA256 8cf71922962b134e08c4ad9048cd66e85c8297372f14dd1f1ada2d26c69c62ae nxml-mode-20041004.tar.gz 443020
diff --git a/app-emacs/nxml-mode/files/xsd-regexp.el.2006-01-26.patch b/app-emacs/nxml-mode/files/xsd-regexp.el.2006-01-26.patch
new file mode 100644
index 000000000000..09820e1546dc
--- /dev/null
+++ b/app-emacs/nxml-mode/files/xsd-regexp.el.2006-01-26.patch
@@ -0,0 +1,22 @@
+--- xsd-regexp.el.orig 2006-01-27 00:31:24.000000000 +0100
++++ xsd-regexp.el 2006-01-27 00:32:20.328529600 +0100
+@@ -290,7 +290,8 @@
+ (defun xsdre-compile-single-char (ch)
+ (if (memq ch '(?. ?* ?+ ?? ?\[ ?\] ?^ ?$ ?\\))
+ (string ?\\ ch)
+- (string (decode-char 'ucs ch))))
++ (let ((utf-translate-cjk-mode nil))
++ (string (decode-char 'ucs ch)))))
+
+ (defun xsdre-char-class-to-range-list (cc)
+ "Return a range-list for a symbolic char-class."
+@@ -403,7 +404,8 @@
+ (setq range-list (cdr range-list)))
+ (setq chars
+ (mapcar (lambda (c)
+- (decode-char 'ucs c))
++ (let ((utf-translate-cjk-mode nil))
++ (decode-char 'ucs c)))
+ chars))
+ (when caret
+ (setq chars (cons ?^ chars)))
diff --git a/app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild b/app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild
new file mode 100644
index 000000000000..fbe40d1a5674
--- /dev/null
+++ b/app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild,v 1.1 2007/08/15 07:37:56 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="A major mode for GNU Emacs for editing XML documents."
+HOMEPAGE="http://www.thaiopensource.com/nxml-mode/
+http://www.emacswiki.org/cgi-bin/wiki/NxmlMode"
+SRC_URI="http://thaiopensource.com/download/${P}.tar.gz
+ mirror://gentoo/${PN}-20040910-xmlschema.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+SITEFILE=80${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-info-gentoo.patch"
+ epatch "${WORKDIR}/${PN}-20040910-xmlschema.patch"
+ epatch "${FILESDIR}/xsd-regexp.el.2006-01-26.patch" # bug #188112
+}
+
+src_compile() {
+ emacs -batch -l rng-auto.el -f rng-byte-compile-load \
+ || die "byte compilation failed"
+ makeinfo --force nxml-mode.texi || die "makeinfo failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ cp -r "${S}/schema" "${D}/${SITELISP}/${PN}"
+ cp -r "${S}/char-name" "${D}/${SITELISP}/${PN}"
+ doinfo nxml-mode.info
+ dodoc README VERSION TODO NEWS || die "dodoc failed"
+}