summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-07-04 23:07:57 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-07-04 23:07:57 +0000
commit45cc3f5577c9fe9299220ce8bc5db526eb6e86fa (patch)
treebf667313edab5bc461191a0339473944917d0ff8 /app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild
parentremove virtual/emacs from DEPEND; add die comment (diff)
downloadgentoo-2-45cc3f5577c9fe9299220ce8bc5db526eb6e86fa.tar.gz
gentoo-2-45cc3f5577c9fe9299220ce8bc5db526eb6e86fa.tar.bz2
gentoo-2-45cc3f5577c9fe9299220ce8bc5db526eb6e86fa.zip
removed pkg_postrm(); reordered KEYWORDS; manual make call to emake; removed virtual/emacs from DEPEND; added some quotes; added some die comments; prettied up SITEFILE handling
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild')
-rw-r--r--app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild b/app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild
index 33e92fbf0ee6..9e6594e73b4b 100644
--- a/app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild
+++ b/app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild,v 1.4 2007/05/28 14:53:19 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild,v 1.5 2007/07/04 23:07:57 opfer Exp $
inherit elisp
@@ -11,22 +11,22 @@ LICENSE="GPL-2"
SLOT="0"
IUSE=""
-KEYWORDS="x86 amd64 ppc sparc"
+KEYWORDS="amd64 ppc sparc x86"
-DEPEND="virtual/emacs"
RDEPEND="${DEPEND}
app-crypt/gnupg"
RESTRICT="test"
+SITEFILE=50${PN}-gentoo.el
src_compile() {
export EMACS=/usr/bin/emacs
- econf || die
- make || die
+ econf || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
- einstall lispdir="${D}/${SITELISP}/${PN}" || die
- elisp-site-file-install "${FILESDIR}/50mailcrypt-gentoo.el"
+ einstall lispdir="${D}/${SITELISP}/${PN}" || die "einstall failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
dodoc ANNOUNCE ChangeLog* INSTALL LCD-entry mailcrypt.dvi NEWS ONEWS README*
}
@@ -36,7 +36,3 @@ pkg_postinst() {
elog "See /usr/share/doc/${P}/INSTALL.gz for how to customize mailcrypt"
elog
}
-
-pkg_postrm() {
- elisp-site-regen
-}