summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/highline
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/highline')
-rw-r--r--app-emacs/highline/ChangeLog11
-rw-r--r--app-emacs/highline/files/50highline-gentoo.el15
-rw-r--r--app-emacs/highline/files/digest-highline-4.11
-rw-r--r--app-emacs/highline/highline-4.1.ebuild38
4 files changed, 65 insertions, 0 deletions
diff --git a/app-emacs/highline/ChangeLog b/app-emacs/highline/ChangeLog
new file mode 100644
index 000000000000..f54ce9e0c542
--- /dev/null
+++ b/app-emacs/highline/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/highline
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/highline/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*highline-4.1 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ highline-4.1.ebuild, files/50highline-gentoo.el,
+ files/digest-highline-4.1 :
+
+ Initial import.
diff --git a/app-emacs/highline/files/50highline-gentoo.el b/app-emacs/highline/files/50highline-gentoo.el
new file mode 100644
index 000000000000..cb1e6538e0fa
--- /dev/null
+++ b/app-emacs/highline/files/50highline-gentoo.el
@@ -0,0 +1,15 @@
+
+;;; highline site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'highline)
+(global-set-key "\C-c\C-a" 'highline-on)
+(global-set-key "\C-c\C-b" 'highline-off)
+(global-set-key "\C-c\C-l" 'highline-local-mode)
+(global-set-key "\C-c\C-d" 'highline-mode-on)
+(global-set-key "\C-c\C-e" 'highline-mode-off)
+(global-set-key "\C-c\C-g" 'highline-mode)
+(global-set-key "\C-c\C-c" 'highline-customize)
+(global-set-key "\C-c\C-v\C-n" 'highline-view-on)
+(global-set-key "\C-c\C-v\C-f" 'highline-view-off)
+(global-set-key "\C-c\C-v\C-t" 'highline-view-mode)
diff --git a/app-emacs/highline/files/digest-highline-4.1 b/app-emacs/highline/files/digest-highline-4.1
new file mode 100644
index 000000000000..c0ab12b50d11
--- /dev/null
+++ b/app-emacs/highline/files/digest-highline-4.1
@@ -0,0 +1 @@
+MD5 94e2121df4204d2fb40358d4d60db895 highline-4.1.tar.bz2 6903
diff --git a/app-emacs/highline/highline-4.1.ebuild b/app-emacs/highline/highline-4.1.ebuild
new file mode 100644
index 000000000000..41e5dd190134
--- /dev/null
+++ b/app-emacs/highline/highline-4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/highline/highline-4.1.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Minor mode to highlight current line in buffer"
+HOMEPAGE="http://www.cpqd.br/~vinicius/emacs/Emacs.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50highline-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/highline.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}