summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-12-30 22:56:37 +0000
committerUlrich Müller <ulm@gentoo.org>2008-12-30 22:56:37 +0000
commit2f44c96ca88c5ad81eb40473ec2845421e61ad88 (patch)
treeeb5e0438c031a6d01e3c881480694e13fb3a90ff /app-emacs/ess
parentAdd live udev ebuild. (diff)
downloadgentoo-2-2f44c96ca88c5ad81eb40473ec2845421e61ad88.tar.gz
gentoo-2-2f44c96ca88c5ad81eb40473ec2845421e61ad88.tar.bz2
gentoo-2-2f44c96ca88c5ad81eb40473ec2845421e61ad88.zip
Version bump, bug 253116. Some changes in src_install wrt documentation.
(Portage version: 2.2_rc20/cvs/Linux 2.6.27-gentoo-r4 i686)
Diffstat (limited to 'app-emacs/ess')
-rw-r--r--app-emacs/ess/ChangeLog7
-rw-r--r--app-emacs/ess/ess-5.3.10.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/app-emacs/ess/ChangeLog b/app-emacs/ess/ChangeLog
index aff70779de08..0856b385af00 100644
--- a/app-emacs/ess/ChangeLog
+++ b/app-emacs/ess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/ess
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ChangeLog,v 1.37 2008/12/20 16:49:41 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ChangeLog,v 1.38 2008/12/30 22:56:37 ulm Exp $
+
+*ess-5.3.10 (30 Dec 2008)
+
+ 30 Dec 2008; Ulrich Mueller <ulm@gentoo.org> +ess-5.3.10.ebuild:
+ Version bump, bug 253116. Some changes in src_install wrt documentation.
20 Dec 2008; Christian Faulhammer <fauli@gentoo.org> -ess-5.3.6-r1.ebuild,
-ess-5.3.7.ebuild:
diff --git a/app-emacs/ess/ess-5.3.10.ebuild b/app-emacs/ess/ess-5.3.10.ebuild
new file mode 100644
index 000000000000..70597c75d799
--- /dev/null
+++ b/app-emacs/ess/ess-5.3.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ess-5.3.10.ebuild,v 1.1 2008/12/30 22:56:37 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+SRC_URI="http://ess.r-project.org/downloads/ess/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-text/texi2html
+ virtual/latex-base"
+RDEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake PREFIX=/usr \
+ INFODIR=/usr/share/info \
+ LISPDIR="${SITELISP}"/ess \
+ || die "emake failed"
+}
+
+src_install() {
+ # Install all elisp sources; the Makefile installs only part of them.
+ # This has to go before emake install, see bug 205156 comment 3.
+ elisp-install ${PN} lisp/ess*.el || die
+
+ # make install fails to create some directories
+ dodir /usr/share/doc/${PF}/{html,refcard}
+
+ emake PREFIX="${D}/usr" \
+ INFODIR="${D}/usr/share/info" \
+ LISPDIR="${D}${SITELISP}/ess" \
+ DOCDIR="${D}/usr/share/doc/${PF}" \
+ install || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ # Most documentation is installed by the package's build system
+ dodoc ChangeLog doc/{NEWS,TODO,ess-intro.pdf} || die "dodoc failed"
+ newdoc lisp/ChangeLog ChangeLog-lisp || die "newdoc failed"
+ prepalldocs
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Please see /usr/share/doc/${PF} for the complete documentation."
+ elog "Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+}