summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-04-21 10:06:04 +0000
committerUlrich Müller <ulm@gentoo.org>2007-04-21 10:06:04 +0000
commit5f17a1b70254652609ef07c1857abf674e9ce96c (patch)
tree31adc9afecc86c04249bc0b81d40d090ffaae81c /app-emacs/erobot
parentia64 + x86 stable (diff)
downloadgentoo-2-5f17a1b70254652609ef07c1857abf674e9ce96c.tar.gz
gentoo-2-5f17a1b70254652609ef07c1857abf674e9ce96c.tar.bz2
gentoo-2-5f17a1b70254652609ef07c1857abf674e9ce96c.zip
Bugfix in interactive function call.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-emacs/erobot')
-rw-r--r--app-emacs/erobot/ChangeLog6
-rw-r--r--app-emacs/erobot/erobot-2.1.0-r1.ebuild10
-rw-r--r--app-emacs/erobot/files/erobot-2.1.0-fix-interactive.patch11
3 files changed, 24 insertions, 3 deletions
diff --git a/app-emacs/erobot/ChangeLog b/app-emacs/erobot/ChangeLog
index d78b7ab65b6e..9b1049530216 100644
--- a/app-emacs/erobot/ChangeLog
+++ b/app-emacs/erobot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/erobot
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/erobot/ChangeLog,v 1.9 2007/04/21 08:36:19 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/erobot/ChangeLog,v 1.10 2007/04/21 10:06:04 ulm Exp $
+
+ 21 Apr 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/erobot-2.1.0-fix-interactive.patch, erobot-2.1.0-r1.ebuild:
+ Bugfix in interactive function call.
*erobot-2.1.0-r1 (21 Apr 2007)
diff --git a/app-emacs/erobot/erobot-2.1.0-r1.ebuild b/app-emacs/erobot/erobot-2.1.0-r1.ebuild
index 5bb1b3aabd76..fcc11fdd2b58 100644
--- a/app-emacs/erobot/erobot-2.1.0-r1.ebuild
+++ b/app-emacs/erobot/erobot-2.1.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/erobot/erobot-2.1.0-r1.ebuild,v 1.1 2007/04/21 08:36:19 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/erobot/erobot-2.1.0-r1.ebuild,v 1.2 2007/04/21 10:06:04 ulm Exp $
-inherit elisp
+inherit elisp eutils
DESCRIPTION="Battle-bots for Emacs!"
HOMEPAGE="http://www.geocities.com/kensanata/emacs-games.html"
@@ -14,3 +14,9 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
SITEFILE=51${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-fix-interactive.patch"
+}
diff --git a/app-emacs/erobot/files/erobot-2.1.0-fix-interactive.patch b/app-emacs/erobot/files/erobot-2.1.0-fix-interactive.patch
new file mode 100644
index 000000000000..69b195170a85
--- /dev/null
+++ b/app-emacs/erobot/files/erobot-2.1.0-fix-interactive.patch
@@ -0,0 +1,11 @@
+--- erobot.el~ 2002-09-28 21:25:39.000000000 +0200
++++ erobot.el 2007-04-21 11:57:15.000000000 +0200
+@@ -230,7 +230,7 @@
+ `erobot-max-turns' has been exceeded, or if the char q is pressed
+ while the game is running. When the game ends, the candidates on
+ the map are returned in a list."
+- (interactive "i\n\naCandidate A: \naCandidate B: ")
++ (interactive "aCandidate A: \naCandidate B: ")
+ ;; Place candidates on the map and set erobot-candidates
+ (setq erobot-candidates nil)
+ (erobot-initialize candidates)