summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-07-04 09:29:29 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-07-04 09:29:29 +0000
commit071de2d864ed67bb62e943dc91479d06c2eb3ced (patch)
tree358b46b843b1eca8cdb93da59d14c2ae2331c5bd /app-emacs/doxymacs
parentVersion bump thanks to David Morton. Fixes bug #166608 (diff)
downloadgentoo-2-071de2d864ed67bb62e943dc91479d06c2eb3ced.tar.gz
gentoo-2-071de2d864ed67bb62e943dc91479d06c2eb3ced.tar.bz2
gentoo-2-071de2d864ed67bb62e943dc91479d06c2eb3ced.zip
don't create autoloads as they are not sufficient; instead load doxymacs when a C mode is entered; kill the font-lock in the site-init; fixes bug 184175, reported by Anders Bach Nielsen <abachn@daimi.au.dk>
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-emacs/doxymacs')
-rw-r--r--app-emacs/doxymacs/ChangeLog10
-rw-r--r--app-emacs/doxymacs/doxymacs-1.8.0-r1.ebuild44
-rw-r--r--app-emacs/doxymacs/doxymacs-1.8.0.ebuild9
-rw-r--r--app-emacs/doxymacs/files/50doxymacs-gentoo.el8
-rw-r--r--app-emacs/doxymacs/files/digest-doxymacs-1.8.0-r13
5 files changed, 65 insertions, 9 deletions
diff --git a/app-emacs/doxymacs/ChangeLog b/app-emacs/doxymacs/ChangeLog
index c3345ca4bacc..f1bb2d5baa07 100644
--- a/app-emacs/doxymacs/ChangeLog
+++ b/app-emacs/doxymacs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/doxymacs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/doxymacs/ChangeLog,v 1.1 2007/07/02 06:44:23 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/doxymacs/ChangeLog,v 1.2 2007/07/04 09:29:29 opfer Exp $
+
+*doxymacs-1.8.0-r1 (04 Jul 2007)
+
+ 04 Jul 2007; Christian Faulhammer <opfer@gentoo.org>
+ files/50doxymacs-gentoo.el, +doxymacs-1.8.0-r1.ebuild:
+ don't create autoloads as they are not sufficient; instead load doxymacs
+ when a C mode is entered; kill the font-lock in the site-init; fixes bug
+ 184175, reported by Anders Bach Nielsen <abachn@daimi.au.dk>
*doxymacs-1.8.0 (02 Jul 2007)
diff --git a/app-emacs/doxymacs/doxymacs-1.8.0-r1.ebuild b/app-emacs/doxymacs/doxymacs-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..263b8eef5056
--- /dev/null
+++ b/app-emacs/doxymacs/doxymacs-1.8.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/doxymacs/doxymacs-1.8.0-r1.ebuild,v 1.1 2007/07/04 09:29:29 opfer Exp $
+
+NEED_EMACS=22
+
+inherit elisp
+
+DESCRIPTION="Doxygen editing minor mode"
+HOMEPAGE="http://doxymacs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libxml2-2.6.13"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50doxymacs-gentoo.el"
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_compile() {
+ econf \
+ --with-datadir="${SITELISP}/${PN}" \
+ --with-lispdir="${SITELISP}/${PN}" \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ datadir="${D}/${SITELISP}/${PN}" \
+ lispdir="${D}/${SITELISP}/${PN}" \
+ install \
+ || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc ${DOCS} || die "dodoc failed"
+}
diff --git a/app-emacs/doxymacs/doxymacs-1.8.0.ebuild b/app-emacs/doxymacs/doxymacs-1.8.0.ebuild
index c01d6db1631a..18d3d3d9398e 100644
--- a/app-emacs/doxymacs/doxymacs-1.8.0.ebuild
+++ b/app-emacs/doxymacs/doxymacs-1.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/doxymacs/doxymacs-1.8.0.ebuild,v 1.1 2007/07/02 06:44:23 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/doxymacs/doxymacs-1.8.0.ebuild,v 1.2 2007/07/04 09:29:29 opfer Exp $
NEED_EMACS=22
@@ -44,3 +44,10 @@ src_install() {
dodoc ${DOCS} || die "dodoc failed"
}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "doxymacs is loaded for all C modes"
+ elog "if you need it in other situations, please add (require 'doxmacs)"
+ elog "to your ~/.emacs file"
+}
diff --git a/app-emacs/doxymacs/files/50doxymacs-gentoo.el b/app-emacs/doxymacs/files/50doxymacs-gentoo.el
index 08f4affa7ac3..5a179c63415f 100644
--- a/app-emacs/doxymacs/files/50doxymacs-gentoo.el
+++ b/app-emacs/doxymacs/files/50doxymacs-gentoo.el
@@ -1,11 +1,5 @@
-
;;; doxymacs site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
-(load "doxymacs-autoloads" nil t)
-(add-hook 'c-mode-common-hook 'doxymacs-mode)
-(defun my-doxymacs-font-lock-hook ()
- (if (or (eq major-mode 'c-mode) (eq major-mode 'c++-mode))
- (doxymacs-font-lock)))
-(add-hook 'font-lock-mode-hook 'my-doxymacs-font-lock-hook)
+(add-hook 'c-mode-common-hook (load "doxymacs" nil t))
diff --git a/app-emacs/doxymacs/files/digest-doxymacs-1.8.0-r1 b/app-emacs/doxymacs/files/digest-doxymacs-1.8.0-r1
new file mode 100644
index 000000000000..0bb51ca72d8f
--- /dev/null
+++ b/app-emacs/doxymacs/files/digest-doxymacs-1.8.0-r1
@@ -0,0 +1,3 @@
+MD5 a2c1750efdec955f42e410a18ebd4eb8 doxymacs-1.8.0.tar.gz 133600
+RMD160 f7a0657251d9220d75aec08dd796dbba3cfe99a5 doxymacs-1.8.0.tar.gz 133600
+SHA256 a23fd833bc3c21ee5387c62597610941e987f9d4372916f996bf6249cc495afa doxymacs-1.8.0.tar.gz 133600