summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-04-05 05:11:43 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-04-05 05:11:43 +0000
commite4bcf888710a185f7ca7c90a7244458c07413ae9 (patch)
treee24510e96570b4d55c780239258977f0db7e6bf0 /app-editors
parentVersion bump #84878. (diff)
downloadgentoo-2-e4bcf888710a185f7ca7c90a7244458c07413ae9.tar.gz
gentoo-2-e4bcf888710a185f7ca7c90a7244458c07413ae9.tar.bz2
gentoo-2-e4bcf888710a185f7ca7c90a7244458c07413ae9.zip
Version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog7
-rw-r--r--app-editors/scite/Manifest18
-rw-r--r--app-editors/scite/files/digest-scite-1.6.31
-rw-r--r--app-editors/scite/scite-1.6.3.ebuild78
4 files changed, 90 insertions, 14 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index f5ecc7b8fd36..84e850bc782f 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/scite
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.35 2005/03/14 13:44:47 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.36 2005/04/05 05:11:43 pythonhead Exp $
+
+*scite-1.6.3 (05 Apr 2005)
+
+ 05 Apr 2005; Rob Cakebread <pythonhead@gentoo.org> +scite-1.6.3.ebuild:
+ Version bump.
14 Mar 2005; Gustavo Zacarias <gustavoz@gentoo.org> scite-1.6.2.ebuild:
Stable on sparc
diff --git a/app-editors/scite/Manifest b/app-editors/scite/Manifest
index b14b3202ea8a..17e8018d78d3 100644
--- a/app-editors/scite/Manifest
+++ b/app-editors/scite/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 4eb1abff335478b86f5c65997e0148f2 metadata.xml 222
MD5 9f1d42a87c768bd7df461c3ff1ce68cf ChangeLog 5942
+MD5 4eb1abff335478b86f5c65997e0148f2 metadata.xml 222
MD5 52fd7b75b63648a39662fb442b86837d scite-1.6.2.ebuild 1900
+MD5 4830981292e8ebbf3f7b55977f674662 scite-1.6.3.ebuild 1916
MD5 46e756e5ecd7701d47299d6e6bb37018 scite-1.6.1.ebuild 1895
-MD5 2561568c62ec3edc2b46be6638c80427 files/scite.desktop 169
-MD5 c022b3ac9b612f257e304f7f90eb7f98 files/digest-scite-1.6.1 58
MD5 42ceb479aebfc9cd9818f0d6a0e39020 files/digest-scite-1.6.2 58
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFCNZUmKRy60XGEcJIRArZHAJ4+Nfhixdse8MgKfaCeU74JgCX81gCdETIt
-EZeFCHmuU3225sGSRhyOm5I=
-=EAO3
------END PGP SIGNATURE-----
+MD5 e7e5f87db815dce89e538345b0894d08 files/digest-scite-1.6.3 58
+MD5 c022b3ac9b612f257e304f7f90eb7f98 files/digest-scite-1.6.1 58
+MD5 2561568c62ec3edc2b46be6638c80427 files/scite.desktop 169
diff --git a/app-editors/scite/files/digest-scite-1.6.3 b/app-editors/scite/files/digest-scite-1.6.3
new file mode 100644
index 000000000000..f4a20dcdba4e
--- /dev/null
+++ b/app-editors/scite/files/digest-scite-1.6.3
@@ -0,0 +1 @@
+MD5 d0978625e0c3407bf481f4b63c5ce32b scite163.tgz 1180759
diff --git a/app-editors/scite/scite-1.6.3.ebuild b/app-editors/scite/scite-1.6.3.ebuild
new file mode 100644
index 000000000000..ff6947ba3438
--- /dev/null
+++ b/app-editors/scite/scite-1.6.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.6.3.ebuild,v 1.1 2005/04/05 05:11:43 pythonhead Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://www.scintilla.org"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86 ~amd64"
+IUSE="gtk2 lua"
+
+RDEPEND="gtk2? ( >=x11-libs/gtk+-2 )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}/gtk
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/scintilla/gtk
+ #This xpm bug should be fixed upstream in 1.6.4:
+ mv ../src/xpm.cxx ../src/XPM.cxx
+ mv ../src/xpm.h ../src/XPM.h
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ || die "error patching makefile"
+
+ cd ${S}
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ || die "error patching makefile"
+
+}
+
+src_compile() {
+ local makeopts
+ use gtk2 || makeopts="GTK1=1"
+ #use debug && makeopts="${makeopts} DEBUG=1"
+
+ make -C ../../scintilla/gtk ${makeopts} || die "prep make failed"
+ emake ${makeopts} || die "make failed"
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/bin
+ dodir /usr/share
+ dodir /usr/share/pixmaps
+ dodir /usr/share/applications
+
+ make prefix=${D}/usr install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv ${D}/usr/bin/SciTE ${D}/usr/bin/scite
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f ${D}/usr/share/applications/SciTE.desktop
+ doins ${FILESDIR}/scite.desktop
+
+ doman ../doc/scite.1
+ dodoc ../README
+}