summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-03-09 14:37:54 +0000
committerMichał Górny <mgorny@gentoo.org>2015-03-09 14:37:54 +0000
commitae18b8a0aca82d0998001d6636f233819ac98901 (patch)
treee8170d37360b889e215ccf3f90463c5fec2c6b14 /app-editors
parentDrop incomplete installation of pythontex and import fedora patch for format-... (diff)
downloadgentoo-2-ae18b8a0aca82d0998001d6636f233819ac98901.tar.gz
gentoo-2-ae18b8a0aca82d0998001d6636f233819ac98901.tar.bz2
gentoo-2-ae18b8a0aca82d0998001d6636f233819ac98901.zip
Version bump. Upstream added optional GTK+3 support, started using GSettings and improved GUI configurability.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mousepad/ChangeLog11
-rw-r--r--app-editors/mousepad/metadata.xml3
-rw-r--r--app-editors/mousepad/mousepad-0.4.0.ebuild47
3 files changed, 59 insertions, 2 deletions
diff --git a/app-editors/mousepad/ChangeLog b/app-editors/mousepad/ChangeLog
index 224656efe995..e3badd8e9ce3 100644
--- a/app-editors/mousepad/ChangeLog
+++ b/app-editors/mousepad/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/mousepad
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mousepad/ChangeLog,v 1.30 2013/04/11 18:08:23 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mousepad/ChangeLog,v 1.31 2015/03/09 14:37:54 mgorny Exp $
+
+*mousepad-0.4.0 (09 Mar 2015)
+
+ 09 Mar 2015; Michał Górny <mgorny@gentoo.org> +mousepad-0.4.0.ebuild,
+ metadata.xml:
+ Version bump. Upstream added optional GTK+3 support, started using GSettings
+ and improved GUI configurability.
11 Apr 2013; Agostino Sarubbo <ago@gentoo.org> mousepad-0.3.0.ebuild:
Stable for x86, wrt bug #465286
diff --git a/app-editors/mousepad/metadata.xml b/app-editors/mousepad/metadata.xml
index d56729e92f8e..f2d9e5bd83fd 100644
--- a/app-editors/mousepad/metadata.xml
+++ b/app-editors/mousepad/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>xfce</herd>
+ <use>
+ <flag name='gtk3'>Use GTK+3 instead of GTK+2</flag>
+ </use>
</pkgmetadata>
diff --git a/app-editors/mousepad/mousepad-0.4.0.ebuild b/app-editors/mousepad/mousepad-0.4.0.ebuild
new file mode 100644
index 000000000000..91c3ab1441c9
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mousepad/mousepad-0.4.0.ebuild,v 1.1 2015/03/09 14:37:54 mgorny Exp $
+
+EAPI=5
+inherit gnome2-utils xfconf
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/start"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dbus gtk3"
+
+RDEPEND=">=dev-libs/glib-2.30:2=
+ dbus? ( >=dev-libs/dbus-glib-0.100:0= )
+ !gtk3? ( >=x11-libs/gtk+-2.24:2=
+ x11-libs/gtksourceview:2.0= )
+ gtk3? ( x11-libs/gtk+:3=
+ x11-libs/gtksourceview:3.0= )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ $(use_enable dbus)
+ $(use_enable gtk3)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
+
+pkg_preinst() {
+ xfconf_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ gnome2_schemas_update
+}