summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-02-13 16:30:44 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-02-13 16:30:44 +0000
commita3660467afd7cc16845cf959e81f3a4f4e3f7694 (patch)
tree66dd9d4337cd0f7cb2f3e171ccf3e88133138252 /app-editors
parentMark arm stable. (diff)
downloadgentoo-2-a3660467afd7cc16845cf959e81f3a4f4e3f7694.tar.gz
gentoo-2-a3660467afd7cc16845cf959e81f3a4f4e3f7694.tar.bz2
gentoo-2-a3660467afd7cc16845cf959e81f3a4f4e3f7694.zip
Migrate changes from Gentoo Prefix. EAPI4, darwin patch, emake call modifications
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/levee/ChangeLog9
-rw-r--r--app-editors/levee/files/levee-3.4o-darwin.patch16
-rw-r--r--app-editors/levee/levee-3.5a.ebuild22
3 files changed, 35 insertions, 12 deletions
diff --git a/app-editors/levee/ChangeLog b/app-editors/levee/ChangeLog
index 67d5901a2872..05c512e031a7 100644
--- a/app-editors/levee/ChangeLog
+++ b/app-editors/levee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/levee
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/ChangeLog,v 1.25 2009/11/30 23:30:54 tcunha Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/ChangeLog,v 1.26 2012/02/13 16:30:44 darkside Exp $
+
+ 13 Feb 2012; Jeremy Olexa <darkside@gentoo.org>
+ +files/levee-3.4o-darwin.patch, levee-3.5a.ebuild:
+ Migrate changes from Gentoo Prefix. EAPI4, darwin patch, emake call
+ modifications
01 Dec 2009; Tiago Cunha <tcunha@gentoo.org> levee-3.5a.ebuild:
stable sparc, bug 289333
diff --git a/app-editors/levee/files/levee-3.4o-darwin.patch b/app-editors/levee/files/levee-3.4o-darwin.patch
new file mode 100644
index 000000000000..9481b1a3ade9
--- /dev/null
+++ b/app-editors/levee/files/levee-3.4o-darwin.patch
@@ -0,0 +1,16 @@
+--- unixcall.c.orig 2007-03-18 17:46:05 +0100
++++ unixcall.c 2007-03-18 17:51:13 +0100
+@@ -77,6 +77,13 @@
+ static int ioset = 0;
+ static struct termios old;
+
++#if defined(__MACH__)
++# define TCGETS TIOCGETA
++# define TCSETS TIOCSETA
++# define TCGETA TIOCGETA
++# define TCSETAF TIOCSETAF
++#endif
++
+ void
+ initcon()
+ {
diff --git a/app-editors/levee/levee-3.5a.ebuild b/app-editors/levee/levee-3.5a.ebuild
index 2f529e426851..5487ef7c90f1 100644
--- a/app-editors/levee/levee-3.5a.ebuild
+++ b/app-editors/levee/levee-3.5a.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/levee-3.5a.ebuild,v 1.5 2009/11/30 23:30:54 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/levee-3.5a.ebuild,v 1.6 2012/02/13 16:30:44 darkside Exp $
+
+EAPI=4
inherit toolchain-funcs eutils
@@ -10,26 +12,26 @@ SRC_URI="http://www.pell.chi.il.us/~orc/Code/levee/${P}.tar.gz"
LICENSE="levee"
SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
+KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE=""
DEPEND="!app-text/lv
sys-libs/ncurses"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.4o-darwin.patch
epatch "${FILESDIR}"/${P}-QA.patch
epatch "${FILESDIR}"/${PN}-3.5-glibc210.patch
}
src_compile() {
- ./configure.sh --prefix=/usr || die "configure failed"
- emake CFLAGS="${CFLAGS} -Wall -Wextra ${LDFLAGS}" \
- CC=$(tc-getCC) || die "emake failed"
+ export AC_CPP_PROG=$(tc-getCPP)
+ export AC_PATH=${PATH}
+ ./configure.sh --prefix="${PREFIX}"/usr || die "configure failed"
+ emake CFLAGS="${CFLAGS} -Wall -Wextra ${LDFLAGS}" CC=$(tc-getCC)
}
src_install() {
- emake PREFIX="${D}" install || die "emake install failed"
+ emake PREFIX="${D}${EPREFIX}" install
}