summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-03-07 22:13:02 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-03-07 22:13:02 +0000
commit75cf5fe4cd7739affe1ad86cb53eaa169fd0bd9b (patch)
tree5413e1303d1bcd8841b8898c3b7915a7babd67da /app-editors
parentKernel patches 2.6.28.6 and 2.6.28.7. Removal of redundant ms keyboard patch.... (diff)
downloadgentoo-2-75cf5fe4cd7739affe1ad86cb53eaa169fd0bd9b.tar.gz
gentoo-2-75cf5fe4cd7739affe1ad86cb53eaa169fd0bd9b.tar.bz2
gentoo-2-75cf5fe4cd7739affe1ad86cb53eaa169fd0bd9b.zip
prune built_with_use and use EAPI 2
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gobby/ChangeLog6
-rw-r--r--app-editors/gobby/gobby-0.4.5.ebuild15
-rw-r--r--app-editors/gobby/gobby-0.4.8.ebuild15
3 files changed, 13 insertions, 23 deletions
diff --git a/app-editors/gobby/ChangeLog b/app-editors/gobby/ChangeLog
index ff6f284d9727..6ef8b9a53bde 100644
--- a/app-editors/gobby/ChangeLog
+++ b/app-editors/gobby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/gobby
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.26 2009/03/07 22:08:43 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.27 2009/03/07 22:13:02 fauli Exp $
+
+ 07 Mar 2009; Christian Faulhammer <fauli@gentoo.org> gobby-0.4.5.ebuild,
+ gobby-0.4.8.ebuild:
+ prune built_with_use and use EAPI 2
07 Mar 2009; Christian Faulhammer <fauli@gentoo.org>
-gobby-0.4.5-r1.ebuild, -gobby-0.4.6.ebuild:
diff --git a/app-editors/gobby/gobby-0.4.5.ebuild b/app-editors/gobby/gobby-0.4.5.ebuild
index 7a5dc1f93812..0576cb5f47be 100644
--- a/app-editors/gobby/gobby-0.4.5.ebuild
+++ b/app-editors/gobby/gobby-0.4.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.5.ebuild,v 1.7 2008/07/27 13:26:50 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.5.ebuild,v 1.8 2009/03/07 22:13:02 fauli Exp $
-EAPI=1
+EAPI=2
inherit base eutils
@@ -20,6 +20,7 @@ RDEPEND=">=dev-cpp/glibmm-2.6
>=net-libs/obby-0.4.4
>=dev-cpp/libxmlpp-2.6
x11-libs/gtksourceview:1.0
+ avahi? ( >=net-libs/obby-0.4.4[avahi] )
gnome? ( gnome-base/gnome-vfs )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -29,14 +30,6 @@ RESTRICT="test"
PATCHES=( "${FILESDIR}/${PN}-0.4.5-gcc43.patch" )
-pkg_setup() {
- if use avahi && ! built_with_use net-libs/obby avahi ; then
- eerror "Please reinstall net-libs/obby with the avahi USE-flag enabled"
- eerror "for zeroconf/DNS-SD support or disable it for this package."
- die "Missing 'avahi' USE-flag for net-libs/obby"
- fi
-}
-
src_compile() {
econf \
$(use_with gnome) \
diff --git a/app-editors/gobby/gobby-0.4.8.ebuild b/app-editors/gobby/gobby-0.4.8.ebuild
index 45c954c4e045..b259e12c19a3 100644
--- a/app-editors/gobby/gobby-0.4.8.ebuild
+++ b/app-editors/gobby/gobby-0.4.8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.8.ebuild,v 1.2 2008/11/09 03:22:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.8.ebuild,v 1.3 2009/03/07 22:13:02 fauli Exp $
-EAPI=1
+EAPI=2
inherit base eutils
@@ -20,6 +20,7 @@ RDEPEND=">=dev-cpp/glibmm-2.6
>=net-libs/obby-0.4.6
>=dev-cpp/libxmlpp-2.6
x11-libs/gtksourceview:2.0
+ avahi? ( >=net-libs/obby-0.4.6 )
gnome? ( gnome-base/gnome-vfs )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -27,14 +28,6 @@ DEPEND="${RDEPEND}
# There's only one test and it needs X
RESTRICT="test"
-pkg_setup() {
- if use avahi && ! built_with_use net-libs/obby avahi ; then
- eerror "Please reinstall net-libs/obby with the avahi USE-flag enabled"
- eerror "for zeroconf/DNS-SD support or disable it for this package."
- die "Missing 'avahi' USE-flag for net-libs/obby"
- fi
-}
-
src_compile() {
econf \
--with-gtksourceview2 \