summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-09-02 14:44:07 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-09-02 14:44:07 +0000
commit0a9d47f1160314abcac3bb46ab4f3f7b03d546e8 (patch)
tree3cac951264d9c95fc91fea149a47a4433f191d94 /app-editors/uemacs-pk
parentWarn if ACPI_VIDEO is not enabled in kernel. (diff)
downloadgentoo-2-0a9d47f1160314abcac3bb46ab4f3f7b03d546e8.tar.gz
gentoo-2-0a9d47f1160314abcac3bb46ab4f3f7b03d546e8.tar.bz2
gentoo-2-0a9d47f1160314abcac3bb46ab4f3f7b03d546e8.zip
Respect LDFLAGS, fixes bug 335516 by flameeyes. Port to EAPI 3 and remove some die comments
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-editors/uemacs-pk')
-rw-r--r--app-editors/uemacs-pk/ChangeLog9
-rw-r--r--app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild16
2 files changed, 16 insertions, 9 deletions
diff --git a/app-editors/uemacs-pk/ChangeLog b/app-editors/uemacs-pk/ChangeLog
index 66c73ae02766..25fca4225790 100644
--- a/app-editors/uemacs-pk/ChangeLog
+++ b/app-editors/uemacs-pk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/uemacs-pk
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/uemacs-pk/ChangeLog,v 1.5 2008/01/27 10:29:53 opfer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/uemacs-pk/ChangeLog,v 1.6 2010/09/02 14:44:07 fauli Exp $
+
+ 02 Sep 2010; Christian Faulhammer <fauli@gentoo.org>
+ uemacs-pk-4.0.18.ebuild:
+ Respect LDFLAGS, fixes bug 335516 by flameeyes. Port to EAPI 3 and remove
+ some die comments
27 Jan 2008; Christian Faulhammer <opfer@gentoo.org>
uemacs-pk-4.0.18.ebuild:
diff --git a/app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild b/app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild
index 40048e1a3f98..04c457b6ff23 100644
--- a/app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild
+++ b/app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild,v 1.5 2008/01/27 10:29:53 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild,v 1.6 2010/09/02 14:44:07 fauli Exp $
+
+EAPI=3
inherit eutils toolchain-funcs
@@ -18,14 +20,14 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/em-${PV}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
+ # Respect LDFLAGS when linking, bug 335516
+ sed -e 's:${CC} ${DEFINES} -o emacs ${OBJ} ${LIBS}:${CC} ${DEFINES} ${LDFLAGS} -o emacs ${OBJ} ${LIBS}:' -i "${S}"/makefile || die
}
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
}
src_install() {
@@ -33,5 +35,5 @@ src_install() {
insinto /usr/share/${PN}
doins emacs.hlp
newins emacs.rc .emacsrc
- dodoc readme readme.39e emacs.ps || die "dodoc failed"
+ dodoc readme readme.39e emacs.ps || die
}