summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-07-10 16:40:38 +0000
committerNaohiro Aota <naota@gentoo.org>2011-07-10 16:40:38 +0000
commitd8cdbdfb74f06395a6eebdf08edf6fbe38b449af (patch)
tree3d180cb7df5604969aaa2b194f0587f1dd0de412 /app-editors/ng
parentVersion bump. (diff)
downloadgentoo-2-d8cdbdfb74f06395a6eebdf08edf6fbe38b449af.tar.gz
gentoo-2-d8cdbdfb74f06395a6eebdf08edf6fbe38b449af.tar.bz2
gentoo-2-d8cdbdfb74f06395a6eebdf08edf6fbe38b449af.zip
Add configure fix. Fix bug #371211.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/ng')
-rw-r--r--app-editors/ng/ChangeLog8
-rw-r--r--app-editors/ng/files/ng-1.5beta1-configure.patch19
-rw-r--r--app-editors/ng/ng-1.5_beta1-r1.ebuild7
3 files changed, 30 insertions, 4 deletions
diff --git a/app-editors/ng/ChangeLog b/app-editors/ng/ChangeLog
index 0b9a28ed9141..e03d9720c85a 100644
--- a/app-editors/ng/ChangeLog
+++ b/app-editors/ng/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/ng
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ChangeLog,v 1.12 2010/06/28 18:04:38 angelos Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ChangeLog,v 1.13 2011/07/10 16:40:38 naota Exp $
+
+ 10 Jul 2011; Naohiro Aota <naota@gentoo.org> ng-1.5_beta1-r1.ebuild,
+ +files/ng-1.5beta1-configure.patch:
+ Add configure fix. Fix bug #371211.
28 Jun 2010; Christoph Mende <angelos@gentoo.org> ng-1.5_beta1.ebuild,
ng-1.5_beta1-r1.ebuild:
diff --git a/app-editors/ng/files/ng-1.5beta1-configure.patch b/app-editors/ng/files/ng-1.5beta1-configure.patch
new file mode 100644
index 000000000000..25f383a0be2d
--- /dev/null
+++ b/app-editors/ng/files/ng-1.5beta1-configure.patch
@@ -0,0 +1,19 @@
+diff --git a/sys/unix/configure.in b/sys/unix/configure.in
+index e034edc..b62535d 100644
+--- a/sys/unix/configure.in
++++ b/sys/unix/configure.in
+@@ -83,8 +83,12 @@ AC_DEFINE_UNQUOTED(RMDIR_CMD, "$rmdir_cmd")
+ dnl If the user wants canna support.
+ AC_MSG_CHECKING(if --enable-canna option specified)
+ AC_ARG_ENABLE(canna,
+- [ --enable-canna[=DIR] Build a canna version.],
+- [cv_canna="yes"; cannapath=$enableval], [cv_canna="no"])
++ [ --enable-canna[=DIR] Build a canna version.])
++AS_IF([test "x$enable_canna" != "xno"], [
++ cv_canna="yes"; cannapath=$enableval
++][
++ cv_canna="no";
++])
+ AC_MSG_RESULT($cv_canna)
+ if test "$cv_canna" = "yes"; then
+
diff --git a/app-editors/ng/ng-1.5_beta1-r1.ebuild b/app-editors/ng/ng-1.5_beta1-r1.ebuild
index a34baeda7e1c..34ec0eebd391 100644
--- a/app-editors/ng/ng-1.5_beta1-r1.ebuild
+++ b/app-editors/ng/ng-1.5_beta1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ng-1.5_beta1-r1.ebuild,v 1.2 2010/06/28 18:04:38 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ng-1.5_beta1-r1.ebuild,v 1.3 2011/07/10 16:40:38 naota Exp $
inherit eutils
@@ -27,7 +27,10 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${MY_P}-ncurses.patch"
+ epatch "${FILESDIR}/${MY_P}-configure.patch"
sed -i -e "/NO_BACKUP/s/undef/define/" config.h || die "sed failed"
+
+ autoconf sys/unix/configure.in > configure
}
src_compile() {