summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-12 20:49:50 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-12 20:49:50 +0000
commit9918fd93d803934c799d852231774163b0977d5b (patch)
tree1c5163dd3409251488a5c12813bb607919f91b63 /app-editors/nedit
parentamd64 stable wrt bug #209888 (diff)
downloadgentoo-2-9918fd93d803934c799d852231774163b0977d5b.tar.gz
gentoo-2-9918fd93d803934c799d852231774163b0977d5b.tar.bz2
gentoo-2-9918fd93d803934c799d852231774163b0977d5b.zip
Fix Motif version detection and disable ARGB visuals, bugs 200628 and 181952.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-editors/nedit')
-rw-r--r--app-editors/nedit/ChangeLog12
-rw-r--r--app-editors/nedit/files/nedit-5.5-argbvisuals.patch24
-rw-r--r--app-editors/nedit/files/nedit-5.5-motif23.patch13
-rw-r--r--app-editors/nedit/nedit-5.5-r1.ebuild49
4 files changed, 96 insertions, 2 deletions
diff --git a/app-editors/nedit/ChangeLog b/app-editors/nedit/ChangeLog
index 8ac6c517d6aa..b843d09abcb6 100644
--- a/app-editors/nedit/ChangeLog
+++ b/app-editors/nedit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/nedit
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/ChangeLog,v 1.46 2007/07/05 20:36:32 uberlord Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/ChangeLog,v 1.47 2008/02/12 20:49:50 ulm Exp $
+
+*nedit-5.5-r1 (12 Feb 2008)
+
+ 12 Feb 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/nedit-5.5-argbvisuals.patch, +files/nedit-5.5-motif23.patch,
+ +nedit-5.5-r1.ebuild:
+ Fix Motif version detection and disable ARGB visuals, bugs 200628 and 181952.
+ Both patches provided by Ioan Marius Curelariu <icurelariu@gmail.com>.
05 Jul 2007; Roy Marples <uberlord@gentoo.org> nedit-5.5.ebuild:
Keyworded ~x86-fbsd, #184298 thanks to Sascha Lucas.
diff --git a/app-editors/nedit/files/nedit-5.5-argbvisuals.patch b/app-editors/nedit/files/nedit-5.5-argbvisuals.patch
new file mode 100644
index 000000000000..e684892e65ad
--- /dev/null
+++ b/app-editors/nedit/files/nedit-5.5-argbvisuals.patch
@@ -0,0 +1,24 @@
+
+--- source/nedit.c.or 2004-09-02 11:49:56.000000000 +0300
++++ source/nedit.c 2007-05-29 15:15:19.000000000 +0300
+@@ -434,6 +434,20 @@
+ and -iconic are per-window and it should not be allowed to consume them,
+ so we temporarily masked them out. */
+ maskArgvKeywords(argc, argv, protectedKeywords);
++ /* X.Org 6.8 and above add support for ARGB visuals (with alpha-channel),
++ typically with a 32-bit color depth. By default, NEdit uses the visual
++ with the largest color depth. However, both OpenMotif and Lesstif
++ cannot handle ARGB visuals (crashes, weird display effects, ...), so
++ NEdit should avoid selecting such a visual.
++ Unfortunatly, there appears to be no reliable way to identify
++ ARGB visuals that doesn't require some of the recent X.Org
++ extensions. Luckily, the X.Org developers have provided a mechanism
++ that can hide these problematic visuals from the application. This can
++ be achieved by setting the XLIB_SKIP_ARGB_VISUALS environment variable.
++ Users can set this variable before starting NEdit, but it is much
++ more convenient that NEdit takes care of this. This must be done before
++ the display is opened (empirically verified). */
++ putenv("XLIB_SKIP_ARGB_VISUALS=1");
+ TheDisplay = XtOpenDisplay (context, NULL, APP_NAME, APP_CLASS,
+ NULL, 0, &argc, argv);
+ unmaskArgvKeywords(argc, argv, protectedKeywords);
diff --git a/app-editors/nedit/files/nedit-5.5-motif23.patch b/app-editors/nedit/files/nedit-5.5-motif23.patch
new file mode 100644
index 000000000000..bfbb971c1abf
--- /dev/null
+++ b/app-editors/nedit/files/nedit-5.5-motif23.patch
@@ -0,0 +1,13 @@
+
+--- util/check_lin_tif.c.or 2007-10-17 12:53:19.000000000 +0300
++++ util/check_lin_tif.c 2007-10-17 13:02:29.000000000 +0300
+@@ -251,7 +251,8 @@
+ if (!force_bad &&
+ ((XmVERSION == 2 && XmREVISION == 1) ||
+ (XmVERSION == 2 && XmREVISION == 2 && XmUPDATE_LEVEL == 3 &&
+- strcmp("@(#)Motif Version 2.2.3", vs) == 0))) {
++ strcmp("@(#)Motif Version 2.2.3", vs) == 0) ||
++ (XmVERSION == 2 && XmREVISION >= 3))) {
+ exit(0);
+ }
+
diff --git a/app-editors/nedit/nedit-5.5-r1.ebuild b/app-editors/nedit/nedit-5.5-r1.ebuild
new file mode 100644
index 000000000000..2cc2b17c332c
--- /dev/null
+++ b/app-editors/nedit/nedit-5.5-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5-r1.ebuild,v 1.1 2008/02/12 20:49:50 ulm Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Multi-purpose text editor for the X Window System"
+HOMEPAGE="http://nedit.org/"
+SRC_URI="mirror://sourceforge/nedit/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="spell"
+
+RDEPEND="spell? ( virtual/aspell-dict )
+ x11-libs/openmotif
+ x11-libs/libXp"
+DEPEND="${RDEPEND}
+ || ( dev-util/yacc sys-devel/bison )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-argbvisuals.patch"
+ epatch "${FILESDIR}/${P}-motif23.patch"
+}
+
+src_compile() {
+ sed -i -e "s:-Wl,-Bstatic::" makefiles/Makefile.linux
+ sed -i -e "s:0.93.0:0.94.0:" util/check_lin_tif.c
+ sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" makefiles/Makefile.linux
+ sed -i -e 's:"/bin/csh":"/bin/sh":' source/preferences.c
+ make CC="$(tc-getCC)" linux || die
+}
+
+src_install() {
+ into /usr
+ dobin source/nedit
+ exeinto /usr/bin
+ newexe source/nc neditc
+ newman doc/nedit.man nedit.1
+ newman doc/nc.man neditc.1
+
+ dodoc README ReleaseNotes ChangeLog COPYRIGHT
+ cd doc
+ dodoc *.txt nedit.doc README.FAQ NEdit.ad
+ dohtml *.{dtd,xsl,xml,html,awk}
+}