summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-04 22:04:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-04 22:04:19 +0000
commitf1e4d1a070ae8af264b61a65a0befb7a47d4c25f (patch)
tree2a0e06fe4dd7a4583abd025d5b706bd2cdcd7811 /app-editors/joe
parentclean old, dep-broken ebuild (diff)
downloadgentoo-2-f1e4d1a070ae8af264b61a65a0befb7a47d4c25f.tar.gz
gentoo-2-f1e4d1a070ae8af264b61a65a0befb7a47d4c25f.tar.bz2
gentoo-2-f1e4d1a070ae8af264b61a65a0befb7a47d4c25f.zip
Bump to 3.7, fixes #253372
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-editors/joe')
-rw-r--r--app-editors/joe/ChangeLog9
-rw-r--r--app-editors/joe/joe-3.7.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index 4e8853b1bdb5..fd06f7dce2aa 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/joe
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.61 2008/09/11 23:20:52 opfer Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.62 2009/01/04 22:04:19 patrick Exp $
+
+*joe-3.7 (04 Jan 2009)
+
+ 04 Jan 2009; Patrick Lauer <patrick@gentoo.org> +joe-3.7.ebuild:
+ Bump to 3.7, fixes #253372
11 Sep 2008; Christian Faulhammer <opfer@gentoo.org>
-files/joe-3.0-overflow.patch, -files/joe-3.1-overflow.patch,
diff --git a/app-editors/joe/joe-3.7.ebuild b/app-editors/joe/joe-3.7.ebuild
new file mode 100644
index 000000000000..97a23d025893
--- /dev/null
+++ b/app-editors/joe/joe-3.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.7.ebuild,v 1.1 2009/01/04 22:04:19 patrick Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="xterm? ( >=x11-terms/xterm-215-r1 )"
+
+pkg_setup() {
+ if use xterm && ! built_with_use x11-terms/xterm paste64; then
+ die "For full xterm clipboard support build x11-terms/xterm with USE=paste64"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/rc
+
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
+ done
+ fi
+}
+
+src_compile() {
+ # Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
+ replace-flags "-Os" "-O2"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog HACKING HINTS LIST NEWS README TODO
+ # remove superfluous documentation, fixes bug #116861
+ rm -rf "${D}"/etc/joe/doc
+}
+
+pkg_postinst() {
+ if use xterm; then
+ elog "To enable full xterm clipboard you need to set the allowWindowOps"
+ elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ elog "This is false by default due to potential security problems on some"
+ elog "architectures (see bug #91453)."
+ fi
+}