summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-01-16 22:39:38 +0000
committerPacho Ramos <pacho@gentoo.org>2010-01-16 22:39:38 +0000
commita69d7099566b1415e6d8d8ff2036cc510e9540e9 (patch)
treee1d5870a4c00648a132b033cf8622e4c9fc642db /app-editors/joe
parentVersion bump, bug 286734 (diff)
downloadgentoo-2-a69d7099566b1415e6d8d8ff2036cc510e9540e9.tar.gz
gentoo-2-a69d7099566b1415e6d8d8ff2036cc510e9540e9.tar.bz2
gentoo-2-a69d7099566b1415e6d8d8ff2036cc510e9540e9.zip
Fix segfault, bug 283508. Thanks to Martin von Gagern
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/joe')
-rw-r--r--app-editors/joe/ChangeLog10
-rw-r--r--app-editors/joe/files/joe-3.7-segfault-fix.patch17
-rw-r--r--app-editors/joe/joe-3.7-r1.ebuild56
3 files changed, 81 insertions, 2 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index 642dbdff9472..9cd55e425adf 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/joe
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.67 2009/11/15 19:26:48 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.68 2010/01/16 22:39:38 pacho Exp $
+
+*joe-3.7-r1 (16 Jan 2010)
+
+ 16 Jan 2010; Pacho Ramos <pacho@gentoo.org> +joe-3.7-r1.ebuild,
+ +files/joe-3.7-segfault-fix.patch:
+ Fix segfault, bug 283508. Thanks to Martin von Gagern
15 Nov 2009; Raúl Porcel <armin76@gentoo.org> joe-3.5.ebuild,
joe-3.7.ebuild:
diff --git a/app-editors/joe/files/joe-3.7-segfault-fix.patch b/app-editors/joe/files/joe-3.7-segfault-fix.patch
new file mode 100644
index 000000000000..38efac2e30c4
--- /dev/null
+++ b/app-editors/joe/files/joe-3.7-segfault-fix.patch
@@ -0,0 +1,17 @@
+Index: main.c
+===================================================================
+RCS file: /cvsroot/joe-editor/joe-current/main/main.c,v
+retrieving revision 1.5
+retrieving revision 1.6
+diff -u -r1.5 -r1.6
+--- main.c 27 Oct 2008 01:57:13 -0000 1.5
++++ main.c 23 Nov 2008 21:32:15 -0000 1.6
+@@ -431,7 +431,7 @@
+ b->orphan = 1;
+ b->oldcur = pdup(b->bof, USTR "main");
+ pline(b->oldcur, get_file_pos(b->name));
+- p_goto_bol(bw->cursor);
++ p_goto_bol(b->oldcur);
+ line = b->oldcur->line - (maint->h - 1) / 2;
+ if (line < 0)
+ line = 0;
diff --git a/app-editors/joe/joe-3.7-r1.ebuild b/app-editors/joe/joe-3.7-r1.ebuild
new file mode 100644
index 000000000000..ae37e2429f92
--- /dev/null
+++ b/app-editors/joe/joe-3.7-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.7-r1.ebuild,v 1.1 2010/01/16 22:39:38 pacho Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="xterm? ( >=x11-terms/xterm-239 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix segfault, bug 283508
+ epatch "${FILESDIR}/${P}-segfault-fix.patch"
+
+ cd ./rc
+
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
+ done
+ fi
+}
+
+src_compile() {
+ # Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
+ replace-flags "-Os" "-O2"
+
+ econf --docdir=/usr/share/doc/${PF} || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog HACKING HINTS LIST NEWS README TODO
+}
+
+pkg_postinst() {
+ if use xterm; then
+ elog "To enable full xterm clipboard you need to set the allowWindowOps"
+ elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ elog "This is false by default due to potential security problems on some"
+ elog "architectures (see bug #91453)."
+ fi
+}